Author Topic: AirPlay plugin  (Read 59671 times)

franco

  • Newbie
  • *
  • Posts: 12
OK E.Milles !!!

I just configured the plugin in order to allow MusicBee to control the volume of remote speakers.
I disabled all the dsp (but I do not think this was the problem)
Now everything seems fine and the sound is almost as good ...

MusicBee very often crashes when the plugin is active, but that's another problem
Unfortunately, the evaluation period is over and I do not know how to continue my tests ...
can I have a few more days for my tests ??

Thanks in advance ...
Franco

maz1991

  • Guest
Hi:

I paid the 25$ but how do I download the plugin?

im5049

  • Guest
I would very much like to evaluate this, but I am getting nothing on my AppleTV.
I copied the three apx....dll files to the MusicBee folder. Then I copied the out_apx.dll file to the plugin folder. The MusicBee preferences show AppleTV as the remote speakers, but on the AppleTV itself, it only shows iTunes as being shared. MusicBee is nowhere to be seen.
Am I doing something wrong? Do I need to copy the files to other folders? Any help would be appreciated because I would really like to use it.

emilles

  • Jr. Member
  • **
  • Posts: 22
...on the AppleTV itself, it only shows iTunes as being shared. MusicBee is nowhere to be seen. Am I doing something wrong? Do I need to copy the files to other folders? Any help would be appreciated because I would really like to use it.

This plug-in does not set up MusicBee as an iTunes shared library.  You will need to select your ATV from MB and play songs out of the MB library to hear them on the ATV.  Support for the Remote app and library browsing from an Apple TV or other more capable device would need to be added to the plug-in or supplied as a separate plug-in.

im5049

  • Guest
OK, I see that now. It does play to the Apple TV. Unfortunately I'm looking for something that will allow me to play the files that are on my computer in one room, to the Apple TV in another room, and control it from the Apple TV. My files are all FLAC, so iTunes can't do it, and you can't add any apps to the Apple TV itself.
Your plugin works well, but it's not what I need. Thanks.

Derek

  • Newbie
  • *
  • Posts: 19
I just discovered this plugin, it's really what I was looking for since I bought my Sonos Play 5 ! Thanks a lot ! :D

However, nothing is perfect, so here is a bug... MusicBee doesn't run if it is launched withaudio output set on your "remote speakers output" plugin. If I change the output back to default before closing MB, the next time I launch it it works correctly, but if I forget to do this, MS is stuck at launch...
I don't know whether it's a plugin or MB bug, by the way...
I use MB beta2.1.4859.

Hi Eric.  I too have an issue with MB crashing when I have the out_apx in the plugin folder.  Bummer...Would be awesome but for this.  I'd love this to be fixed if you can.

emilles

  • Jr. Member
  • **
  • Posts: 22
I too have an issue with MB crashing when I have the out_apx in the plugin folder.  Bummer...Would be awesome but for this.  I'd love this to be fixed if you can.

Not much I can do without a lot more information.  As stated in the README that comes with the plug-in, you can run DebugView to capture some more info.  Plus send me (through email) the plug-in version you are running, Windows version, AirPlay device type, etc.

slimpyman

  • Jr. Member
  • **
  • Posts: 44
somehow this plugin isnt being detected by musicbee 3

edit: actually it does work... it didnt seem to load all the time. weird, but no problem
Last Edit: April 19, 2016, 04:53:17 AM by slimpyman

Orion

  • Jr. Member
  • **
  • Posts: 87
I've been using your plugin for mounths, Eric, and it worked very well. I left home for hollydays and now when I'm trying to configure the output device, MusicBee suddenly crashes without reason...



Does one know how to solve this bug ?

Thank you very much in advance for your help.

3damien

  • Newbie
  • *
  • Posts: 2
Hi Emilles, thx for your work on the plugin.
I get an error after installing your plugin on Musicbee 3.1.
When selecting the "Remote speakers output" in preferences, i get the following error:

Code
MusicBee v3.1.6466.36486 (Win10.0), 17 sept. 2017 19:17:

#=qD5qkNJrZLg$EQSzyPp2Pm4V9Tg2EhmKjqxoXU0T$N7Y=: Unable to initialise sound device
   à #=qewqr6dDCgjjvMyoIzGJ0pOS_JtJzfrS_firjzFx$umA=.#=qQaRs1bsCMspF33mouAiKjg==(#=q$_U4_JrkubiOyiGMaQ3K5s5iqWmd94JHQXbmeqltEL4= #=qz77gqwQ9kO3Pgy_Lj0KfWA==, String #=q6WfxG93J09A4uRX6fAe7HK1gj_ar419$wRrnG9NZ__w=, #=qyr_pDdshsxNsMtKIuZnvrg== #=qSQIaQ5uJbGid7aigsVoPB$YqcvHN$_HMdIRPJkgVII4=, Int32 #=q0d6Xpv3iIUs5cH8anOemuA==, String #=qc6H78HUc0jb1rwl4BM4_xQ==, IntPtr #=qVX3eLDyQ1von6GJ8mo$wAQ==)
   à #=q667WbFKCkIfd3KTGDsQMBo3pDOjB16kw_Vn7d59fTh8w0v0vickhaIVonJCRyR6F.#=qCX5YW3nNI6AXXziycc8fNKA3RLpX2$ciRnpzab4AJmU=()
   à #=q667WbFKCkIfd3KTGDsQMBo3pDOjB16kw_Vn7d59fTh8w0v0vickhaIVonJCRyR6F.#=qxXq2DbinOO$JhkPqUsNXjQqZcBr43uSU_q9kREyIC8Y=(Object #=qE6vGRfwxNQJjJix_L88kEQ==, EventArgs #=qtMw2z5n55mEaSy$DMDgXdg==)
   à System.Windows.Forms.Control.OnClick(EventArgs e)
   à #=qhZnIjQKGFJ2OwiUKcnhTqRnUaxWBKV_xSv$pmN7tm6A=.OnClick(EventArgs #=qVlOfWaZeZCzpuCuOSWQEJA==)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

could you help ?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595
@3damien,
emilles hasnt been active on this forum for years now. If it was working with v3 and its an important plugin to you then i suggest you revert to 3.0 as I wouldnt be able to solve this without emiles help

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595
@3damien,
it might be fixed now, could you try this version:
http://musicbee.niblseed.com/V3_1/MusicBee31_Patched.zip
unzip and replace the existing musicbee files

LeatherMcWhip

  • Newbie
  • *
  • Posts: 4
@3damien,
it might be fixed now, could you try this version:
http://musicbee.niblseed.com/V3_1/MusicBee31_Patched.zip
unzip and replace the existing musicbee files

@Steven

I found my way here after a few internet searches about the E. Milles Remote Speaker plugin problem I was having. It had worked like a charm for a couple years, but then I updated my MusicBee (which I love) to 3.1 and couldn't get my remote speaker to configure. Error, error, error.

So ... I temporarily removed the Remote Speaker plugin from the MusicBee plugins folder, copied and pasted your patch to the general MusicBee folder, Steven, and re-pasted the remote speakers plugin into the MusicBee plugins folder again ... and we're back. So thank you VERY MUCH for whatever you did there. Hugely appreciated. I mean ... HUGELY!!! Thanks a ton.

Just wanted to let you know!

taravasya

  • Newbie
  • *
  • Posts: 6
Looks like plugin dont work with new, and with patched version(from this link).
I have latest portable MB, and latest plugin version. Then I try to enable plugin I have error:

I dont have installed IPC-plugin(which recomended), because of "dead-site" with it. But as I understand, this plugin only for remote control...

emilles

  • Jr. Member
  • **
  • Posts: 22
This is the patch that was confirmed to fix the loading issues: https://getmusicbee.com/forum/index.php?topic=23304.msg136451#msg136451

I'm not sure if that has made it into MusicBee 3.1 or 3.2.