Author Topic: MusicBee Remote (Remote Control for Android)  (Read 418901 times)

BassT

  • Jr. Member
  • **
  • Posts: 23
Hello kelsos,
i just want to thank you for that app. I really like to use it and it does what i need it to do. It improves the usage of MusicBee a lot for me.

To be honest, i would not use things like browsing the library and stuff a lot, that's much faster on my PC via keyboard and mouse than on a small smartphone. But seeing title information and beeing able to control the playback is just awesome. Thanks again.

There are some small wishes, maybe you can have a look at it:
- Controling the system's volume via app (not only the MusicBee's) and unmuting it (Often i'm on the balcony and the Computer's volume is not loud enough or even muted)
- Sometimes it seems to lose the connection, even if MusicBee is running, it shows track information of an previous song and cannot be controlled anymore. When i go to Settings > Manage Connections and scan again, it works again. Its okay for me at the moment, but if you could have a look at it when there's time...
- (for a far later date maybe) I would wish to stream the MusicBee output to the phone, would be a great addition some day :-)

kelsos

  • Sr. Member
  • ****
  • Posts: 302
I am working on some improvements on the connection front, I hope to have a beta soon with a couple of changes.
Like automatic reconnect if the connection didn't receive anything for a specified period of time, and automatic scanning for remote settings.

I check how easy is to add an option for system volume control.

Also on the streaming front, That would be really hard unless there is already some streaming plugin that can be used as an output.
I really have no idea on that front so if someone knows anything please tell me.

Dieter
After this it still didn't connect?

stardepp

  • Sr. Member
  • ****
  • Posts: 354
I do not go on ... I'll make it easy not to connect the remote MusicBee on my new Android with my MusicBee on Windows. I read in the help for the MusicBee plugin, but I found no solution. Here my plugin settings: https://drive.google.com/file/d/0B9ORseKzkzUcelNVWnlxOV91dk0/view?usp=sharing
What am I doing wrong?

kelsos

  • Sr. Member
  • ****
  • Posts: 302
The problem lies with the specified range. 192.168.178.20->16

The if I recall correctly (It has been a while since I implemented the feature) the way that the range is designed requires the second number to be greater  than the first.

for example for this to work you should have 192.168.178.16->20 to work from 16 to 20. I think this way it blocks every single address from connecting to the plugin.


stardepp

  • Sr. Member
  • ****
  • Posts: 354
I'm still trying to combine my MusicBee Android remote control with MusicBee and know no more advice. What am I doing wrong? With another Android Smarttphone the connection worked previously.

MusicBee for Android showed in the search for a connection to the PC: "connection timeout"

Here you can see my settings:


https://drive.google.com/file/d/0B9ORseKzkzUcaDUzQWh4NVZlbUU/view?usp=sharing

https://drive.google.com/open?id=0B9ORseKzkzUcekgxLThsbEhDWlU

About help I would be very grateful.



Last Edit: July 27, 2016, 10:49:20 PM by stardepp

kelsos

  • Sr. Member
  • ****
  • Posts: 302
In the remote settings you can see a private address list.
This is the address where the android application should connect.
According to the screenshot send the plugin listens to the 192.168.178.20:3000.

On the android application screenshot I can see that the default connection is set to 192.168.1.11:3000, that's not where the plugin is listening.
If your connection Is not automatically detected you should try to add a connection pointing to 192.168.178.20:3000 and make it a default connection.

If this also fails to connect you should check your possible firewall rules.

Keep in mind that the filtering field is there to restrict access to specific addresses.



kelsos

  • Sr. Member
  • ****
  • Posts: 302

stardepp

  • Sr. Member
  • ****
  • Posts: 354
yes, the fault is in the session timeout and "client is not allowed".
Last Edit: July 28, 2016, 02:14:44 PM by stardepp

kelsos

  • Sr. Member
  • ****
  • Posts: 302
Client not allowed means that you blocked the client from connecting through the Address filter option.
You can either change the filter to all or find the address of your android device and add it to the filter.

stardepp

  • Sr. Member
  • ****
  • Posts: 354
Yes, I changed the settings the filter to all, but a connection is still not possible. Here my connecting overview ... "Mot" is my PC, "Linux" is my Android.

https://drive.google.com/open?id=0B9ORseKzkzUcMXNEaHBxVUhlak0

Which filter should I add the address of my Android?

Did you mean so: https://drive.google.com/open?id=0B9ORseKzkzUceFVaaDNEMkN4elk ?
Last Edit: July 28, 2016, 03:16:33 PM by stardepp

stardepp

  • Sr. Member
  • ****
  • Posts: 354

lordlance

  • Jr. Member
  • **
  • Posts: 22
I want to simply drop a HUGE THANK YOU for the whole Remote thing.
Men, this should be fully integrated in MusicBee... Awesome, super useful.

If I can humbly make a request for the wishlist: add the function to start playing an existing playlist, if technically possible, of course.

Turac

  • Newbie
  • *
  • Posts: 1
Today I tried to get your remote running for what felt like 5 hours... just to detect a firewall rule blocking MusicBee from communicating..

Now everything works as expected, thank you for your nice work! :)