Author Topic: Disable Menu Bar in Caption Area  (Read 11546 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33267
this issue is completed unrelated to the menu text clearness.
I have made one more attempt at this (i dont want to install anything that changes the windows system files so wont install the custom theme)

http://musicbee.niblseed.com/Patches/MusicBee.zip

if it still doesnt work (could you let me know), then you can edit MusicBeeSettings.ini
- exit the new MB version
- it will add on the 18th line
<SystemDisableGlow>false</SystemDisableGlow>
- restart, Help/Support/View Settings file
- keep the file open
- exit MB, and change the value to true and save
- restart and the text should not glow

Kaelri

  • Jr. Member
  • **
  • Posts: 95
Here's what I get with the new patch:



When I disable the glow in MusicBeeSettings.ini, I get:



Actually, I sort of like it that way. :D But I think the best solution would be to go back to the previous behavior, but allow users to manually disable glow in MusicBeeSettings.ini, if they so desire. (It obviously doesn't merit a place in the preferences GUI, since this issue probably affects only a tiny minority of users. I certainly don't mind doing a little plaintext tweaking.)

Thanks again for spending so much time on this. Your attention to detail really sets MusicBee apart.
Last Edit: May 05, 2012, 10:12:30 PM by Kaelri

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33267
hopefully this version should use the correct text colour when glow is disabled:
http://musicbee.niblseed.com/Patches/MusicBee.zip


Alexis

  • Hero Member
  • *****
  • Posts: 712
Hi Steven

With this  change... if autohide is enabled,  it does not work on hover when in theatermode, so the 'close' button id not present.


update:

And on escaping Theatermode... it would  then not work in the main player unless the player is restarted.
Last Edit: May 07, 2012, 03:48:20 PM by BeeFanatic
They are not lazy... just more efficient.

mikebo

  • Sr. Member
  • ****
  • Posts: 350
I'm also having issues



there is a bright line across caption and the gap between menubar and panels is now bigger.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33267
this should fix both the reported issues:
http://musicbee.niblseed.com/V2/MusicBee_Exe_Patched.zip

mikebo, i dont know how to get the glow exactly like windows does - i am following the microsoft suggested approach but it is a little different

Alexis

  • Hero Member
  • *****
  • Posts: 712
Thank you Steven.
They are not lazy... just more efficient.

mikebo

  • Sr. Member
  • ****
  • Posts: 350
Thanks, it's fixed. Don't worry about the glow.

Another problem I've noticed is that the window decoration (aero glass or whatever) flickers black when the window is maximized.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33267
it should be barely noticable now, however if too many glitches keep getting reported with this i might just revert to using the standard windows functionality for when the menu bar is docked below the caption bar. All that will mean is the application will need to be restarted when switching the menu dock

http://musicbee.niblseed.com/V2/MusicBee_Exe_Patched.zip

mikebo

  • Sr. Member
  • ****
  • Posts: 350

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33267
i decided to change it so when the window borders are not skinned and you have the menu displayed below the caption bar then it will use the standard windows caption bar. The only small downside is MusicBee will need to be restarted when changing the menu dock. This version should also remove any flicker when the menu is auto-opened/hidden in a windows glass caption bar, with the small downside that when resizing the window will show black flickering when the menu is auto-hidden only. None of the above applies for skinned borders

http://musicbee.niblseed.com/V2/MusicBee_Exe_Patched.zip
Last Edit: May 08, 2012, 10:31:41 PM by Steven