Author Topic: Portable device preferred playlist format  (Read 6361 times)

GabesDad

  • Jr. Member
  • **
  • Posts: 59
This is perhaps two requests in one.  I am using a Windows Mobile phone with the built in Windows Media Player 10 Mobile.  WMP Mobile does not support .m3u or .pls files.  I tried syncing a playlist with the Windows Mobile phone (mounted as a USB mass storage device) and it synced correctly (both the files and creating a .m3u playlist on the device).

So I guess I'm requesting that you add support for at least creating .asx playlists, and secondly the ability to designate a preferred playlist format for a device so that when synchronizing a playlist with that particular device, the playlist is created and saved in the correct format.

Thanks!

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32296

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32296

GabesDad

  • Jr. Member
  • **
  • Posts: 59
Ok, so I did some testing and it works as it should but it does not work in my situation.  Let me explain.  When I mount my Windows Mobile phone as a mass storage device, it mounts the root of the storage card as the mount point.  When the card is not mounted, the Windows Mobile operating system sees the mount point of the storage card as a folder called \storage card\.  So I created a playlist on the device and opened that playlist and one created/synced by Music Bee in notepad.  The paths in the MusicBee created playlist start with \My Music\ . . . , while the paths of device created playlist start with \Storage Card\My Music\ . . .  Technically this is correct since when the storage card is mounted as a mass storage device, the folder \storage card\ becomes the drive letter (in my case drive G:).

So, do you have a suggested solution to let MusicBee know what to resolve the drive letter to for the playlist?  In my case, I would imagine some setting in the device specific sync settings that a user can designate a root folder for (i.e. mounted drive G: = device \Storage Card\).  Thoughts?

Another request - would it be possible to add a setting to designated saved location of playlists on the device?  MusicBee defaults to creating a folder \playlists\ under the location specified as the root for syncing.  However, WMP mobile does not seem to detect the ASX file there.  When creating an ASX file on the device, WMP saves in a folder \playlist\ directly under the root folder of the storage card.

Also I don't know if this matters, but the device created ASX has this additional string:
<Param Name = "encoding" Value = "UTF-8" />

Thanks!
Last Edit: August 18, 2009, 09:05:59 PM by GabesDad

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32296
ok, so it sounds like 2 extra settings for playlists are needed:

playlist folder: - in your case: \storage card\playlist
root folder for tracks in playlists: - in your case: \storage card


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32296

GabesDad

  • Jr. Member
  • **
  • Posts: 59
Ok, seems to be working well, except for one issue.  The files and playlist all transferred fine and were all picked up by the mobile Windows Media Player just fine, however two of the files had special characters (an accented e and an ampersand) in either the path or filename.  The playlist played the remaining files fine, but gave errors on the two files with special characters.  When going to these files through the library (not via the playlist) the files played fine.  Below is the top portion of the ASX playlist that contains the two files (the 2nd and 4th entries):
Code
<asx version="3.0">
  <entry>
    <title>Feeling So Real</title>
    <author>Moby</author>
    <ref href="\storage card\My Music\Moby\Songs 1993-1998\09 - Feeling So Real.wma" />
  </entry>
  <entry>
    <title>Breathe</title>
    <author>Télépopmusik</author>
    <ref href="\storage card\My Music\Télépopmusik\Genetic World\01 - Breathe.mp3" />
  </entry>
  <entry>
    <title>Utopia</title>
    <author>Goldfrapp</author>
    <ref href="\storage card\My Music\Goldfrapp\Felt Mountain\1-08 - Utopia.mp3" />
  </entry>
  <entry>
    <title>Beauties Can Die</title>
    <author>M83</author>
    <ref href="\storage card\My Music\M83\Dead Cities, Red Seas &amp; Lost Ghosts\1-12 - Beauties Can Die.m4a" />
  </entry>

Note that the "&" was converted to a "&amp;"  Any ideas on a remedy for this?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32296
yes reading some reports on the web it looks like asx files are not quite standard xml - i need to use & rather than &amp;
and it uses ISO-8859-1 for the encoding which is probably why the non-ascii chars cause problems.
I'll fix that



GabesDad

  • Jr. Member
  • **
  • Posts: 59
Works great!  I wish I could get some consultants that work for my firm to turn things around this quickly.  Thanks!