Author Topic: Manual playlist sorting in descending order / Add tracks at top  (Read 535 times)

fiso64

  • Jr. Member
  • **
  • Posts: 33
With manual sort order, tracks are always added at the end of the playlist. The "Sort Ascending" and "Sort Descending" toggles are unavailable. I propose for them to become functional in manual sorting, with "descending" reversing the playlist and causing all newly added tracks to appear at the top.

Unless I'm missing something, it's not currently possible for the playlist to be configured this way – you can sort by date added in descending order, but that's the date the track was added to the library, not the playlist.

frankz

  • Sr. Member
  • ****
  • Posts: 3784

fiso64

  • Jr. Member
  • **
  • Posts: 33
Clicking the numbered column (first column) will do exactly this.
I have added the # Column to the displayed fields but clicking it does nothing for me.

frankz

  • Sr. Member
  • ****
  • Posts: 3784
Is your sort set to Manual Order, or are you using some custom sort?

Of course, if you tell it to use a custom sort, it's going to do what you ask.

fiso64

  • Jr. Member
  • **
  • Posts: 33

frankz

  • Sr. Member
  • ****
  • Posts: 3784
Then you're doing something wrong.  Every column header in a playlist is clickable to sort.

MotleyG

  • Full Member
  • ***
  • Posts: 140
Are you clicking on the top header of the column, not just anywhere in the list?

fiso64

  • Jr. Member
  • **
  • Posts: 33
Oh come on. yeah I'm clicking the header part. And the other columns work fine, I can click them to sort by that property.

Even if something is broken on my end I still think my feature request is a good idea because it is far more intuitive (there are multiple questions about this on the forum, users appear to be confused), and because it doesn't require the number column to be active.
Last Edit: February 05, 2024, 08:45:40 PM by fiso64

hiccup

  • Sr. Member
  • ****
  • Posts: 7710
Sorting ascending/descending is working fine for me also.
So it looks like the OP is doing something non-standard and should explain better what he is doing exactly.

purplebee

  • Jr. Member
  • **
  • Posts: 44
Is it just me or is the "#" column not available in Album+Tracks (detailed list) views? If so, you can't do manual order in descending order using that view.

frankz

  • Sr. Member
  • ****
  • Posts: 3784
It's not just you, and that's because no one would in reality want to sort by the order in which the tracks were added to the playlist in Album and Tracks view.

fiso64

  • Jr. Member
  • **
  • Posts: 33
So it looks like the OP is doing something non-standard and should explain better what he is doing exactly.
I go to the playlist tab, where I select one of my playlists which is manually sorted. I right click on the column headers and select "Set displayed fields". I add the "#" field (there are two fields with that name, I choose the first one. The second one is the number of the track within its album). There is now a new column on the right which numbers the tracks in ascending order in the playlist. When I click on that column header, nothing happens. When I click on any other column header such as title or artist, the playlist reorders by that property.

I click on the empty part of the header in the 1., 2. column.
Last Edit: February 06, 2024, 07:22:38 AM by fiso64

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9247
Perhaps I'm misunderstanding the issue, but I'll take a crack at answering.

If you're expecting the -numbers- in the # column to change when clicking on the header, they do not. But the order of the songs does.

Furthermore, there are three columns (fields) at the left of the window. The first is obviously album art. The second is # despite the fact that # does not appear in the header. What is the third?

Try widening the second and third columns to see if the header text appears. (There won't be any text for the artwork column.)

Try a different skin to see if the text appears.

Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

frankz

  • Sr. Member
  • ****
  • Posts: 3784
The (correct) # column seems to be auto-sized.  I can not make it any bigger or smaller. The fact that the "#" title does not show in this column header in the screenshot makes me think this is not the right field.

It is set up using view "Default"  I do not know what this is - maybe there's some sort being applied there.  Mine (that work properly) are set to Track Details.

The numbers actually will change to being in reverse order when you sort the (correct) # column in descending order.  They only go back to being in ascending order if you "Update Play Order," which is not what OP wants to do (that will reinstate new tracks being added to the bottom of the playlist).

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9247
I agree that the # column can not be resized. I hadn't tested it when I suggested it.

My typical view for playlists is Track Details but I just now switched to Default and saw no change.

With a static playlist the numbers in the # column do switch between ascending and descending when clicking the # header. Apparently auto-playlists do not change.

The # not showing in the column header seems to be a clue. Perhaps the OP can share a screenshot of their "Set Displayed Fields" settings. Right-click anywhere in the header bar and select "Set Displayed Fields."
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here