Author Topic: Additional Tagging & Reporting Tools  (Read 967406 times)

nsd3

  • Newbie
  • *
  • Posts: 7
I thought V3.5 was still in beta, hence I've not updated.  If 3.5 is a prerequisite, I'll just wait for the official release.  My thanks to you all that bothered to reply, it's appreciated.

Messiaen

  • Jr. Member
  • **
  • Posts: 106
It's been awhile since I used them, but the two predefined presets "Replace repeating spaces" and "Replace underlines with spaces" both seem to be missing the required actual space-character (for replacement) in their definitions - resulting in either all spaces being removed, or all underlines being simply stripped (not replaced).  I tested with a fresh install of the most recent version's ASR Presets folder.

I know these presets used to work properly, so something might have broken when you revamped the preset-installing procedure recently?  The oldest xml's I have from backup are only from mid January (they're bad too), so the definitions might have been corrupted for awhile.

Strange.

Edit:  Actually, this is odd - if I "fix" the preset by copying it and editing back in the necessary space character, the preset works, and if saved will continue to work unless MB itself is restarted, at which point the preset fails because the "fixed" space character is gone from the definition again!
Last Edit: February 22, 2023, 06:10:00 PM by Messiaen

badchild

  • Newbie
  • *
  • Posts: 7
Hey Man!
Been using Musicbee for years and love it. My library is big enough 53 000 tracks, full albums only all in Flac. I keep track of it on a spreadsheet and have noticed there are discrepancies in the library reports where the results don't match up with reality. Upon further inspection, I've found that the report skips Album titles that are the same....example "Live" or "Greatest Hits".

It's not really important unless you're afflicted with asperger's.....:)

As FZ said....."Music (bee) is the best !

Babydoll32

  • Full Member
  • ***
  • Posts: 140
Hi,
since yesterday I got a little problem with additional tagging tools. I have a template which copied some tags like artist, genre i.e. and also rating tag.
It worked very well till yesterday. All ratings copied fine, but rating tag. I can do what I want, but it makes always a 3-star rating. Has anyone a solution?

Best regards

boroda

  • Hero Member
  • *****
  • Posts: 4748
It's been awhile since I used them, but the two predefined presets "Replace repeating spaces" and "Replace underlines with spaces" both seem to be missing the required actual space-character (for replacement) in their definitions - resulting in either all spaces being removed, or all underlines being simply stripped (not replaced).  I tested with a fresh install of the most recent version's ASR Presets folder.

I know these presets used to work properly, so something might have broken when you revamped the preset-installing procedure recently?  The oldest xml's I have from backup are only from mid January (they're bad too), so the definitions might have been corrupted for awhile.

Strange.

Edit:  Actually, this is odd - if I "fix" the preset by copying it and editing back in the necessary space character, the preset works, and if saved will continue to work unless MB itself is restarted, at which point the preset fails because the "fixed" space character is gone from the definition again!
sorry, don't know how this could happen. i've fixed, will upload fixed version later today.

boroda

  • Hero Member
  • *****
  • Posts: 4748
Hey Man!
Been using Musicbee for years and love it. My library is big enough 53 000 tracks, full albums only all in Flac. I keep track of it on a spreadsheet and have noticed there are discrepancies in the library reports where the results don't match up with reality. Upon further inspection, I've found that the report skips Album titles that are the same....example "Live" or "Greatest Hits".

It's not really important unless you're afflicted with asperger's.....:)

As FZ said....."Music (bee) is the best !
never use just album tag in LR, mb itself treats "album" as a combination of album/album artist tags. do the same in LR. define 2 groupings: album/album artist (displayed!) instead of just album.

boroda

  • Hero Member
  • *****
  • Posts: 4748
Hi,
since yesterday I got a little problem with additional tagging tools. I have a template which copied some tags like artist, genre i.e. and also rating tag.
It worked very well till yesterday. All ratings copied fine, but rating tag. I can do what I want, but it makes always a 3-star rating. Has anyone a solution?

Best regards
send me 1 of problem tracks (if ratings are stored in tracks), and you "copy" preset (select preset and click "export..." button).

boroda

  • Hero Member
  • *****
  • Posts: 4748
It's been awhile since I used them, but the two predefined presets "Replace repeating spaces" and "Replace underlines with spaces" both seem to be missing the required actual space-character (for replacement) in their definitions - resulting in either all spaces being removed, or all underlines being simply stripped (not replaced).  I tested with a fresh install of the most recent version's ASR Presets folder.

I know these presets used to work properly, so something might have broken when you revamped the preset-installing procedure recently?  The oldest xml's I have from backup are only from mid January (they're bad too), so the definitions might have been corrupted for awhile.

Strange.

Edit:  Actually, this is odd - if I "fix" the preset by copying it and editing back in the necessary space character, the preset works, and if saved will continue to work unless MB itself is restarted, at which point the preset fails because the "fixed" space character is gone from the definition again!
i've fixed it:

https://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

Messiaen

  • Jr. Member
  • **
  • Posts: 106
i've fixed it
Umm... no, not so much - the problem remains (I tested on a fully replaced set of presets, just in case, and the plugin version seems to remain unchanged [5.7]).  There is something which is still removing the ' ' character from the actual "Replace with" field, like you're cleaning excess whitespace during installation or something.

The only way I've found to "fix it" properly is to not use a typed <space> character at all and just use "\@char[[0020]]" in the field instead.

boroda

  • Hero Member
  • *****
  • Posts: 4748
you are right. the problem is "whitespace cleanup" for xml files. i see the same when i reimport presets back. this xml behavior is adjustable, but i better stick with your solution.

boroda

  • Hero Member
  • *****
  • Posts: 4748
i've fixed some LR bugs. also, LR export folder is remembered now. download link is the same.


boroda

  • Hero Member
  • *****
  • Posts: 4748
fixed behavior of "#" grouping for LR. may be useful only for generating reports for playlists, but not for entire library:

https://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

Ploki

  • Newbie
  • *
  • Posts: 2
Request for new feature or extend current one

In current function repunct it only translate some special characters to some of this
Code
<< " [ ((
Full definition is in AutoLibraryReports.cs rows starts with 827

It is possible to do something similar with letters? For example I want to translate artists like this:
Céline Dion -> Celine Dion (é -> e)
Christina Stürmer -> Christina Sturmer (ü -> u)
Horkýže Slíže -> Horkyze Slize (ý -> y, ž -> z, í -> i)

Maybe this could help with specifying characters
https://stackoverflow.com/questions/18123501/replacing-accented-characters-with-plain-ascii-ones
https://stackoverflow.com/questions/286921/efficiently-replace-all-accented-characters-in-a-string

i've created new asr preset "Transliterate Unicode characters of <Tag 1> to ASCII characters". 'import new' asr presets after updating plugin. you need to install this plugin to use new preset.
Works great, but with one error - if there is comma in tag, for example:
Money, Money, Money   ->   $TransliterateToAscii(Money, Money, Money)
No Woman, No Cry   ->   $TransliterateToAscii(No Woman, No Cry)
Don't Worry, Be Happy   ->   $TransliterateToAscii(Don't Worry, Be Happy)