Author Topic: Additional Tagging & Reporting Tools  (Read 537870 times)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5839
Okay, maybe I'm missing something. I downloaded the latest update and installed it. How do I get the presets to populate? I typed in "feat" and nothing shows up.
Make sure you've installed the plugin properly. The .dll goes in the plugin directory under the MB directory. And the -entire- ASR Presets directory goes under the Plugins directory.

Do you see any presets at all? If not, you probably haven't imported them. Make sure the presets and dll are placed as above. Launch Additional Tagging Tools from the Tools menu or by right-clicking a track/album > Additional Tagging Tools > Advanced Search & Replace > click on 'Import all' and that should take care of it.

Type "feat" in the search window and the presets containing 'feat' will appear. The most recent version has four presets that meet this criteria.

Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

Corliss Rain

  • Jr. Member
  • **
  • Posts: 26
Okay, I'm an idiot. Instead of having the folder directing in the plugins folder, I had moved the entire folder I extracted the file to into the plugin folder. Working now. Thanks!

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5839
Working now. Thanks!
Glad to hear it was something simple.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

noose6767

  • Newbie
  • *
  • Posts: 4
Hi, I can't seem to get the dialogue to show when I choose the "Copy tags to clipboard" option, it normally
appears and asks me which tags I wish to copy. I think it is because I was running Musicbee on a multiple monitor
set up and am now on a single monitor setup. Hope someone can help, thanks in advance.

noose6767

  • Newbie
  • *
  • Posts: 4
I've fixed it by resetting the x and y values in the mb_TagTools.Settings.xml file

boroda

  • Hero Member
  • *****
  • Posts: 3520
just for future reference: you can clear plugin settings by clicking 'uninstall' button next to plugin name in mb prefs and restarting mb.

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3577
  • MB Version: 3.4.7573 P
Refer to bug report: https://getmusicbee.com/forum/index.php?topic=31196.0

Not sure if it's the plugin or MB.  :-\
MusicBee and my library - Making bee-utiful music together

Charpmen

  • Newbie
  • *
  • Posts: 3
Hi guys, I've looked all over this forum before posting my question. I'm having a hard time to figure out how to modify a script and save in the Advance search & replace tool.

I would like to extract the artists from these song titles in this playlist and place them in the appropriate artist tag https://imgur.com/PuW4i7J

The best preset I've found in the ASR tab is this one that would do the job is thos one https://imgur.com/Nolg4s1 but it's not doing anything.

frankz

  • Hero Member
  • *****
  • Posts: 2155
I think you're using the wrong preset. You don't have any featured artists in the titles.

I think you need Split '<Tag 1>' to tags '<Tag 2>', '<Tag 3>'.

Tag 1 Title Tag 2 Title Tag 3 Artist Custom Text <space>-<space>

Don't type the word space, use however many spaces are before and after the "-" in your current title.

Try it on one or two at first and preview, preview, preview to make sure you're getting the results you want.  Specifically, I don't know if you need an interim tag for "Tag 2" or you can read and write Title in the same operation.

This plugin is a powerful tool and you can screw up your files pretty easily if you don't know what you're doing and/or do things without really thinking about it.


wirtual82

  • Newbie
  • *
  • Posts: 13
How to get rid of this annoying error? I searched the forum, but I understand nothing of what I found about it.

"Some tag names are duplicated". Plugin is not properly initialized.

Sorry, I have no clue.

I had to turn off that plugin because of this error.

Hopefully, I can find the answer because this is a really helpful and great plugin.
Last Edit: April 27, 2020, 05:36:03 PM by wirtual82

wonderdog

  • Newbie
  • *
  • Posts: 2
https://i.imgur.com/mbMCrct.jpg

Is there a way to print exactly the way the Library Report shows album artist, album, artwork when I run "preview"? See image attached.

If I try to do any or the exports HTML, CSV, M3U, TXT I don't get the same results. Under CSV, M3U, TXT i lose the album thumbnail. If I save under any of the HTML I get the Album thumbnails but no album artist or album, just the JPG info under the thumbnail.

The way the "Library Reports" generates the list before any export is what I am hoping to be able to print. It's alphabetized and simple, just album, artist and thumbnail.  



Thank you

kakkun

  • Newbie
  • *
  • Posts: 15
I'm trying to create an advanced search and replace preset that will increment play count and set the "last played" tag as the current time. I've been able to update the play count, but not the last played tag. Is this not possible because the last played tag is not user editable? I would appreciate any help with this.

ariesps

  • Newbie
  • *
  • Posts: 9
Hi all,

I 'm looking to implement some way to copy MusicBee ratings, mainly in FLAC Files, to Traktor compatible rating tag. Half based ratings are disabled on MusicBee

On Mp3Tag I create a RATING WMP tag, which value is replaced based on RATING tag set on MusicBee. This works ok and Traktor reads correctly ratings.



Is there anyway to get this to work within Advanced Search & Replace and regular expressions?

In MusicBee I've created a custom Tag, named RATING WMP, as a number.

Thanks in advance.

ariesps

  • Newbie
  • *
  • Posts: 9
Hi all,

I 'm looking to implement some way to copy MusicBee ratings, mainly in FLAC Files, to Traktor compatible rating tag. Half based ratings are disabled on MusicBee

On Mp3Tag I create a RATING WMP tag, which value is replaced based on RATING tag set on MusicBee. This works ok and Traktor reads correctly ratings.



Is there anyway to get this to work within Advanced Search & Replace and regular expressions?

In MusicBee I've created a custom Tag, named RATING WMP, as a number.

Thanks in advance.

Done!

Although RATING values in Musicbee flac files are 20,40,60,80,100, ASR must read them as (1), (2), (3), (4) or (5). Now RATING WMP custom tag is populated correctly and I can finally have tags in sync between Musicbee & Traktor. Same ratings on both softwares.