Author Topic: Subsonic Client  (Read 77169 times)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5513
This plugin is the only way I can play subsonic server stuff on a windows 10 computer.
It's certainly not the "only" way.
You can also use your web browser to reach your server. From -any- computer running -any- OS, from -any-where.
Download the latest MusicBee v3.3 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

Gerd

  • Newbie
  • *
  • Posts: 2
Hi, i would love to use MusicBee with my Nextcloud installation using the Nextcloud Music app, but somehow i can not connect to its supersonic api. No matter what settings i chose, the supersonic plugin always tells me on ping requests that the server did not respond to ping as expected and i get no tracks displayed in the subsonic folder. any ideas, or can i do somethig to help debugging?

btw, i can perfectly connect to my Nextcloud using Subsonic android app, clementine also works, but its uggly and takes ages to load the library...
Last Edit: April 25, 2020, 05:53:01 PM by Gerd

Gerd

  • Newbie
  • *
  • Posts: 2
seems i am not the first to try this without success, however, i can not even make it detect the subsonic server...

Hello,

My music collection is stored on a Nextcloud server, at home. I have enabled the "music" app (version 0.11.0) to allow streaming the audio files from my collection to external applications compatible with Subsonic (and Ampache).

On my Arch Linux laptop I use "Clementine" which has built-in capabilities to stream from a Subsonic server. This works perfectly.

On my work laptop (Windows 10) I have installed MusicBee and, following the instructions kindly provided by MiDWaN on GitHub, I tried to configure the plugin as shown below:



The music app shows this address to use when browsing the music collection from a Subsonic compatible player:

Code
https://<my.home.server>:<port#>/index.php/apps/music/subsonic

This combination of "hostname" and "port number" is the only one which make possible the main MusicBee window to show "Detected a Subsonic server" and ""Done running GetFolderFiles" messages in the lower left corner (see images below).





The issue is that no audio file from my collection is shown (as you can see in the two images above).

Other details which may help in troubleshooting the issue:

Subsonic Client v2.28.00
MusicBee version: 3.3.7261
Nextcloud version: 16.0.5 running on Ubuntu 18.04.3 LTS
I have a static IP from my ISP


wortoltje

  • Newbie
  • *
  • Posts: 1
Same problem as Valentin, except for using Nextcloud.
I can connect with my Subsonic server and when I try to go to my Subsonic tab in Musicbee albums do show up after a refresh, but i get a message that the directory is NOT FOUND. Also full albums are indicated as single songs with length 0:00 .

Note that this only happened when accessing my full music library. When I tested this with 10+ albums I didn't experienced this problem...

Hello,

My music collection is stored on a Nextcloud server, at home. I have enabled the "music" app (version 0.11.0) to allow streaming the audio files from my collection to external applications compatible with Subsonic (and Ampache).

-------
-------
-------

The issue is that no audio file from my collection is shown (as you can see in the two images above).

Other details which may help in troubleshooting the issue:

Subsonic Client v2.28.00
MusicBee version: 3.3.7261
Nextcloud version: 16.0.5 running on Ubuntu 18.04.3 LTS
I have a static IP from my ISP


dabeastro

  • Newbie
  • *
  • Posts: 4
Thank you so much for your work on this. I've got an Airsonic server working well with this. It populates nicely in the computer node. Node shows up as an option for monitoring.  Nothing happens with this though. So I resorted to just selecting all the files and doing an send to music library. That works pretty well, but will of course need to be done every time I add music to the server. Is this the best/only way to achieve getting the subsonic files into the MB library? Just checking to see if maybe I am missing something on the server side. Thanks again!