Author Topic: 2 lots of album art being listed even though there's only 1 (EDIT - Not a bug)  (Read 1531 times)

Sigma

  • Sr. Member
  • ****
  • Posts: 338
I'm using MusicBee version 3.4.7749.

I noticed today that music I've added to my library in MusicBee in recent months shows as having 2 album cover images, even though there's only 1. For example: -



If I switch between the 2, nothing happens.

All of my albums are stored and tagged the same way. Each album is in its own folder. Inside that folder is a hidden folder.jpg file, and that's also embedded into the tags of the files. If I open a file in MusicBee's own tag editor, it only shows 1 piece of artwork there.

It's obviously not a major issue, but I just wondered why it's happening. It only affects music I've added to MusicBee's library in the last few months. When I check music I added further back than that, it only shows "Image 1: Album cover" and that's it, even though the files are stored/tagged in the exact same way.

This may not even be a bug, but I'm just wondering why it's showing "Image 1: Album cover" and "Image 2: Album cover" for the albums I've added recently, but not older ones.

Thanks!
Last Edit: March 20, 2021, 07:12:14 PM by Sigma

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9353
Open the Tag Editor and look at the artwork tab. You probably have the artwork there twice with the same designation.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

frankz

  • Sr. Member
  • ****
  • Posts: 3876
If you don't want it to consider the folder.jpg as album art, go into Edit->Edit Preferences->Tags(1)...artwork and delete folder.jpg from the list of files to look at.  

I think if you rescanned your library it would probably show this for all of the tracks that have a folder.jpg.

Maybe it's not showing up in the tag editor because it's a hidden file, but MB still knows it's there.  That I don't know.

Sigma

  • Sr. Member
  • ****
  • Posts: 338
Open the Tag Editor and look at the artwork tab. You probably have the artwork there twice with the same designation.

Actually yeah, I do.....



But why? I have not changed any settings in MusicBee, nor how I store or tag music, but now any album I add to my library ends up with 2 lots of artwork like this, when that never used to happen.

frankz

  • Sr. Member
  • ****
  • Posts: 3876
If I open a file in MusicBee's own tag editor, it only shows 1 piece of artwork there.
Open the Tag Editor and look at the artwork tab. You probably have the artwork there twice with the same designation.
Actually yeah, I do.....


?

Sigma

  • Sr. Member
  • ****
  • Posts: 338
?

I was looking in the wrong place initially. I was looking under the "Tags" tab where it also shows the artwork, not the actual "Artwork" tab.

I use MP3Tag to tag files, so I'm not used to looking at MusicBee's tagging options.

I think your other post is probably the solution I'm looking for though, so thanks!

frankz

  • Sr. Member
  • ****
  • Posts: 3876
I was looking in the wrong place initially. I was looking under the "Tags" tab where it also shows the artwork, not the actual "Artwork" tab.
Makes sense.

sveakul

  • Sr. Member
  • ****
  • Posts: 2469
@Sigma:  be sure that anytime you make changes in the list that shows your artwork display order/choice that you remember to hit the "Rescan Artwork" button, not just Save, for your change to be applied.