Author Topic: Everything was great moving to the portable version, but now blurry text  (Read 1450 times)

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
I'm using a 1440 monitor and I have scaling set to 125% in Windows. I also have the compatibility mode for DPI set in the "right click>musicbee.exe" file.

After moving from full install to portable recently, everything was fine. Now the text is a little blurry. It's not bad, but definitely there. Anyone have any ideas?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7723
After moving from full install to portable recently, everything was fine. Now the text is a little blurry. It's not bad, but definitely there. Anyone have any ideas?
So you recently switched to the portable version and all was well. Then all of a sudden the text became blurry: MB isn't going to do this all by itself. Nor is there any option to do this in MB. So something outside of MB changed. What have you installed or reinstalled since you switched to portable?
Have you done a Windows update?
Have you updated your graphics drivers? Or did a Windows update do that?
What happens with 100% scaling?
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
After moving from full install to portable recently, everything was fine. Now the text is a little blurry. It's not bad, but definitely there. Anyone have any ideas?
So you recently switched to the portable version and all was well. Then all of a sudden the text became blurry: MB isn't going to do this all by itself. Nor is there any option to do this in MB. So something outside of MB changed. What have you installed or reinstalled since you switched to portable?
Have you done a Windows update?
Have you updated your graphics drivers? Or did a Windows update do that?
What happens with 100% scaling?


Phred, no updates or graphics differences. I just noticed that I started MB and the custom skins were not scaling correctly, like they were. So I restarted Win and changed everything back to default in Windows scaling. At normal scaling, text is crisp and skins scale correctly. So I set the scaling back to 125% and the skins scaled fine, but the text is no longer crisp.

hiccup

  • Hero Member
  • *****
  • Posts: 5938
First the most obvious question, have you restarted your PC?

You could take a look at the program settings:
Right click the MusicBee.exe icon > tab 'compatibility' > 'Change high dpi settings'
There are some options there that might help getting things right.


musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
First the most obvious question, have you restarted your PC?

You could take a look at the program settings:
Right click the MusicBee.exe icon > tab 'compatibility' > 'Change high dpi settings'
There are some options there that might help getting things right.





First thing I did after i changed Win 10 scaling was to use the high DPI settings options. They worked, then like I said, today, blurry text. I also restarted my computer and made sure it was actually plugged in. :)

I wouldn't even need to change scaling in Windows, except Microbrains changed system font size for menus, top title text, dialogue box text etc from 11pt to 9pt--and I have no idea why they did that.

Just tried system font changer, but it's not working with the latest update from Microbrains. It wold seem that Microbrain s dead set on people using 1080p monitors at 32" to get any usable size out of Windows anymore. That, or they want you to sit 10" away from a 32" 1440 monitor to actual work.

Oh well, what can you expect from a 40 year old company that still doesn't know how to offer a built in dual pane file explorer. After 40 years, they did finally offer a built in calculator with a right side history box. Whew. Probably broke someone's brain doing that one.
Last Edit: January 02, 2021, 06:50:10 AM by musicbee4dwd

hiccup

  • Hero Member
  • *****
  • Posts: 5938
Ah yes, I now see in the start post that you already tried exactly that. Sorry.

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
Ah yes, I now see in the start post that you already tried exactly that. Sorry.

Hey no worries. I advent used the "make sure your computer is plugged in" line for a long time, so thanks for that!

hiccup

  • Hero Member
  • *****
  • Posts: 5938
Hey no worries. I advent used the "make sure your computer is plugged in" line for a long time, so thanks for that!
Are the reading glasses on? Have you tried wiping the monitor for grease?
(sorry, bad humor)

I have no other suggestions. But then again I don't use scaling myself so my experience is not great on that.
Hopefully someone with more experience and insights on the matter has more useful ideas than me ;-)


hiccup

  • Hero Member
  • *****
  • Posts: 5938
It's still bugging me a bit.

If you make adjustments using right click on properties on the .exe, does it give good results for the time being?
But do they revert to blurry after restarting MusicBee and/or the computer?

I am wondering because I am curious where such custom dpi settings are stored.
Since it is a portable install Windows probably shouldn't save it in the registry.
But I also don't think it is stored somewhere in MusicBee.

Are you starting MusicBee from a desktop shortcut? Perhaps the dpi info is (should be) stored in the shortcut.

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
It's still bugging me a bit.

If you make adjustments using right click on properties on the .exe, does it give good results for the time being?
But do they revert to blurry after restarting MusicBee and/or the computer?

I am wondering because I am curious where such custom dpi settings are stored.
Since it is a portable install Windows probably shouldn't save it in the registry.
But I also don't think it is stored somewhere in MusicBee.

Are you starting MusicBee from a desktop shortcut? Perhaps the dpi info is (should be) stored in the shortcut.

Naw.  No matter what I do with the high DPI settings, the text still isn't crisp. I see where you are going, and it's a good idea. It's like the skins render fine after using the high dpi options, but the text isn't following. It's not really bad, but it's visible enough to make me revert my desktop back to 100%, and use in program text scaling for now.

The only problem is that even if you use Windows text scaling, without the option to "make everything larger" Windows dialogue boxes, menus, and title bar remain changed and there is no easy way to adjust them without using "make all things bigger." That just increases DP and reduces desktop space. Back in the day, you could adjust all of that.

Anyway I'm thinking this may have to do with something in my Windows 10. I've also noticed, since reverting back to default 100% desktop size, that the icons on the desktop are spaced FAR too much (see image). Again, no easy way to adjust that--thanks Microbrains.

hiccup

  • Hero Member
  • *****
  • Posts: 5938
Anyway I'm thinking this may have to do with something in my Windows 10. I've also noticed, since reverting back to default 100% desktop size, that the icons on the desktop are spaced FAR too much (see image). Again, no easy way to adjust that--thanks Microbrains.

These things are adjustable by editing registry settings.
If you do a google search you should be able to find the relevant registry entries that effect dpi, desktop icon size and spacing etc.
I believe there are also tools that can reset all Windows dpi and/or icon registry settings to the original values without you needing to open regedit.
But be very careful if this is new to you, you can make things worse or create very serious problems if you make mistakes in the registry.

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
Anyway I'm thinking this may have to do with something in my Windows 10. I've also noticed, since reverting back to default 100% desktop size, that the icons on the desktop are spaced FAR too much (see image). Again, no easy way to adjust that--thanks Microbrains.

These things are adjustable by editing registry settings.
If you do a google search you should be able to find the relevant registry entries that effect dpi, desktop icon size and spacing etc.
I believe there are also tools that can reset all Windows dpi and/or icon registry settings to the original values without you needing to open regedit.
But be very careful if this is new to you, you can make things worse or create very serious problems if you make mistakes in the registry.

I got the registry fixed for the icons. I also have fixed the MB text using a few other types of font sizing options. First, I'm not increasing the size of everything in the "scaling" option. if others are having any problems with their high DPI monitors:

1. Leave scaling at 100%, default.
2. In the programs you use, use their own internal font size options, like the one in MB or Firefox.
3. Problem: Windows title bars, menus, right click menu, and dialogue boxes will remain small.
4. Fix: Use the font only size option in Settings>Ease of Access>Display> [make text bigger]
Now everything scales perfectly because you haven't changed scaling, and you get a larger font in "Windows Only Programs." MB font size is not affected, for instance.

Limitation: Window's dialogue boxes, other than menus, will still display with small text. For instance, if you open the "System Information" app, although the menus and title bar will have inherited your increased font size, the dialogue box itself, that which contains the system information, will remain at the Microbrain's preferred unbelievably idiotic font size choice of. . .wait for it. . .9pt font.

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 790
Anyway I'm thinking this may have to do with something in my Windows 10. I've also noticed, since reverting back to default 100% desktop size, that the icons on the desktop are spaced FAR too much (see image). Again, no easy way to adjust that--thanks Microbrains.

These things are adjustable by editing registry settings.
If you do a google search you should be able to find the relevant registry entries that effect dpi, desktop icon size and spacing etc.
I believe there are also tools that can reset all Windows dpi and/or icon registry settings to the original values without you needing to open regedit.
But be very careful if this is new to you, you can make things worse or create very serious problems if you make mistakes in the registry.

I got the registry fixed for the icons. I also have fixed the MB text using a few other types of font sizing options. First, I'm not increasing the size of everything in the "scaling" option. if others are having any problems with their high DPI monitors:

1. Leave scaling at 100%, default.
2. In the programs you use, use their own internal font size options, like the one in MB or Firefox.
3. Problem: Windows title bars, menus, right click menu, and dialogue boxes will remain small.
4. Fix: Use the font only size option in Settings>Ease of Access>Display> [make text bigger]
Now everything scales perfectly because you haven't changed scaling, and you get a larger font in "Windows Only Programs." MB font size is not affected, for instance.

Limitation: Window's dialogue boxes, other than menus, will still display with small text. For instance, if you open the "System Information" app, although the menus and title bar will have inherited your increased font size, the dialogue box itself, that which contains the system information, will remain at the Microbrain's preferred unbelievably idiotic font size choice of. . .wait for it. . .9pt font.

This would be a great post to include in the FAQ, if it ever gets off the ground.  :-X

musicbee4dwd

  • Full Member
  • ***
  • Posts: 182
This would be a great post to include in the FAQ, if it ever gets off the ground.  :-X

The only other problem is that some programs do not have a text size option, so you're still stuck in Microscopic text. I'm just dealing with that.