Author Topic: double-click to Auto Playlist doesn't activate it anymore  (Read 1691 times)

tubescreamer

  • Jr. Member
  • **
  • Posts: 83
Hi,

first of all many things for your continuous effort to maintain MusicBee, its a phantastic player. Maybe you could get this little bug fixed with not too much effort.

It doesn't work anymore to activate an auto-playlist by double-clicking with the mouse.
At the bottom I can see clearly that in the status line the number of file, storage, playtime doesn't change.

I remember it worked in the past (long ago, but sry, I always forgot to make a bug report) and it was very user friendly in terms of handling.
I just checked the latest version 3.4.7628, also doesn't work in this release.

Now its not so comfortably as you have to perform two actions:
- right-click with a mouse and
- then select either "play" or "play in random order".

It would be great if "double-click" to an auto playlist would again activate it.

Many thanks.

Windows 10 Pro 20H2, fresh installation 2 month ago // RME UFX+ via AES to ADI-2 Pro FS R BE (USB DAC) // using RME ASIO driver
Last Edit: December 22, 2020, 10:28:46 AM by tubescreamer

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595
By "activate" you mean play the files in the playlist?
I am having no issues doing that

tubescreamer

  • Jr. Member
  • **
  • Posts: 83
Yes, that the
- filtering is automatically being applied
- songs seleced
- and being played



Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595
I still have no idea what the issue is you are reporting. The video doesnt give me any clues as to what the issue is

tubescreamer

  • Jr. Member
  • **
  • Posts: 83
In the video you see that the music doesn't change if I simply double click to different autoplay lists.
What I see here on screen additionally is, that the music selection doesn't change at all. Same amount of files.
Because of the definition in the autoplaylist (rating and random play order) the music should change.

Then I switch over to select an autoplaylist and select play from the pulldown menue.
Now you can hear that other music is being selected and a random song is being played.
This I repeated also for some time.

Then again I switched to only double clicking and you hear again that only the same song is being played,
although the music selection should change and a random song should be played.

You see in the video when I start performing rightclick and then select play.
Then you hear that the music changes (because in the autoplaylist I defined random play order).
Then after a few successful changes I simply double clicked again and then you hear again only the same song start.

tubescreamer

  • Jr. Member
  • **
  • Posts: 83
I found something that might help you ...

Tried various things also a new windows user account. With a new user account and "default settings" the double click to autoplaylists works.
Assumption: so it seems to be related to my settings / customizations...

Back to my normal user account:
Simply by occasion I stumbled over "Autoplaylist Explorer", never used this before. There the double clicking works !!!

Here two screenshots:

1. With this customization auto play lists DO NOT work with a doubleclick


2. With "Autoplaylist Explorer" auto playlists work by doubleclicking to them


#2 is no solution for me, I prefer #1 because then more space for the content is left.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595
can you send me a link to your settings file (help/ support/ view settings)



Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33595

tubescreamer

  • Jr. Member
  • **
  • Posts: 83
Excellent Steven, this fixes the issue :-) Donation on the way via paypal "2543" with a comma somewhere in between ;)
Last Edit: December 23, 2020, 10:17:41 AM by tubescreamer

Terry Walker

  • Jr. Member
  • **
  • Posts: 92
This should fix the issue:
https://getmusicbee.com/patches/MusicBee34_Patched.zip
unzip and replace the existing musicbee application files
I have the same problem as well, Thanks steven. It works :)