Author Topic: Artwork issue with recently added tracks  (Read 578 times)

MartinH

  • Newbie
  • *
  • Posts: 2
Hi,
I recently added several album tracks to my library in Musicbee.

I searched for artwork and updated the albums artwork.

I then noticed that whichever artwork I updated last all of the recently added albums updated with this artwork.

Clearly these recently added albums are linked somehow? but I cannot figure out how.

I added the albums and tracks using "Add files to Library" which brought up the folder "AppData>Roaming>MusicBee>Equaliser".

I can see all my tracks in this folder.

Are all the tracks linked in this folder which is why when I update one album artwork, they all update?

If so, how do I 'un-link' them.

When I update the artwork I select and tick 'Embed' for both the music and the track.

I haven't been using MusicBee long and I love it. This is the first time I have added tracks to my library, so I believe it is something I have done, some setting I need to change, I just can't figure out what I need to do.

Please help. Thanks

Martin

frankz

  • Sr. Member
  • ****
  • Posts: 3868
Go to Edit->Edit Preferences->Tags(1)...artwork and under "set which pictures are displayed" make sure "Embedded" is first and remove whatever other options are there that you don't want MB to see.

Also, you should probably put your music files somewhere other than the internal directory for the program's equalizer files.  Probably doesn't hurt to have them there, but it also doesn't make much sense.

https://musicbee.fandom.com/wiki/File_Organization

MartinH

  • Newbie
  • *
  • Posts: 2
Hi FrankZ,
Thanks for your very quick reply.

I ensured that 'Embedded' is at the top of the list (which I did yesterday after reading another similar post here) and un-ticked the other non required items on the list.

This did allow me to change the album artwork independently of the other albums/tracks in the main panel, however I noticed it updated the picture in the thumbnail on the side Album panel with the last updated artwork.

I decided that the best course of action is to delete all the recently added tracks and start again.

I will send them to the inbox this time and then add to the library.

I learned something else about MusicBee today, that the support is very impressive.

Many thanks for your response.

Regards

Martin

 

frankz

  • Sr. Member
  • ****
  • Posts: 3868
Should have mentioned this, but after you change artwork options globally you have to go to Tools->Advanced->Reset Artwork Cache