Author Topic: Option to resample all audio to 44.1khz  (Read 135 times)

willguitar100

  • Newbie
  • *
  • Posts: 7
Yes I know, this sounds stupid, but let me explain.

I use ASIO to enjoy music in the background while I record whatever it is that I do on my computer. This way, the system audio I'm recording is not intruded by any music. I also just use ASIO in general with my computer, since my audio interface that I run all of my audio through works best with it. The problem is that any immediate change in sample rate completely wrecks my audio on the computer and all the programs that I'm running.

First I get this error

Then I hear a click and the music stops playing. All of my system audio is extremely distorted and the pitch of everything changes to compensate the difference in sample rate (if I'm in a call and a 96khz audio file starts playing, everyone's voices go really high pitched and my voice goes super low pitched on their end). The only way to fix this glitch when it happens is to close out of musicbee, reopen it, click a 44.1khz song, see the same "Unable to start playback" error again, reboot musicbee again, and play a 44.1khz file again. Then and only then will the audio fix itself. It happens regularly when I accidentally play a higher sample rate song through ASIO.

This is definitely not MusicBee's fault, but there is sort of a way to currently fix the issue with MusicBee.

In the options I'm able to resample my audio to 48KHz, 96KHz, or 192KHz, but absent is a 44.1KHz option.


I assume it's because most people would find it pointless to resample higher rate music down to 44.1KHz, but the functionality is already available in the software.


Reading an old forum post here from 2014, I found that enabling crossfade will force the software into 44.1KHz mode, because it needs a consistent sample rate to be able to fade between tracks. I enabled it and tried to set the crossfade as low as possible which is 0.1 seconds. It seems to work fine for the most part, but songs that were already intended to transition seamlessly now have short surges in volume because, well, they're being crossfaded.



Maybe there is a better way around this highly specific issue I'm having, but I think it would be worth having as an option if it's kind of already there. Thanks for your consideration!

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30846
This is a very easy change so I have included it in the next v3.4 alpha update

willguitar100

  • Newbie
  • *
  • Posts: 7
This is a very easy change so I have included it in the next v3.4 alpha update
Thank you!! I really appreciate it :)