Author Topic: Delete files in the folder but not in the database  (Read 1985 times)

webmasterab

  • Newbie
  • *
  • Posts: 16
We are using the latest version of musicbee and have the following when deleting files via musicbee.


This is the CD we want to remove.


This is the folder of this CD, now with files


We are now going to delete the files via the database


After deleting in the database, the folder is empty


But they are still in the database



As you can see it can no longer be called because the file no longer exists.


So what we do now is then select all files again and click on delete again and then it will also be removed from the database
Last Edit: May 14, 2020, 04:24:10 PM by webmasterab

frankz

  • Sr. Member
  • ****
  • Posts: 3868
As you can see...
No I can't.  If your img link doesn't have a png, bmp or jpg at the end, it's not an image.

webmasterab

  • Newbie
  • *
  • Posts: 16
As you can see...
No I can't.  If your img link doesn't have a png, bmp or jpg at the end, it's not an image.

Was already trying to fix it

psychoadept

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 10692
Are you using a computer folder view? I have also noticed this when deleting files from a folder (whether it's in the actual library or not).
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

falso63

  • Newbie
  • *
  • Posts: 6
i think they are not in the database as there is problem marker shown next to the files.

i think they are still in viewer cache.

try pressing F5 to refresh the screen?

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34407

webmasterab

  • Newbie
  • *
  • Posts: 16
I copied the patch over it.
It is now the case that when I delete a file in the database it immediately indicates that the file does not exist, using the exclamation mark.
I still have to press f5 myself to get it out of the database.
f5 is still an extra action.
Hopefully this can also be resolved

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34407

webmasterab

  • Newbie
  • *
  • Posts: 16
Yes it works now.
Thank you very much for this fast service