Author Topic: Having Numerous Playback Issues  (Read 1040 times)

Similtiades

  • Newbie
  • *
  • Posts: 15
Hi all, I hope this is the right place for this. Basically, I'm having numerous playback issues with MusicBee over the last couple of months. Before that everything was fine, but I'm just about at wits' end with it at the moment.

The most common issue is that playback will stop completely at the end of a song, seemingly at random. On the "Now Playing" view it remains on the image of the artist that was just playing, and playback won't move on to the next song at all, no matter what I do, until I close MusicBee and restart.  When I restart the programme, one of three things will happen:
1 - it most often plays the next song with no problem, but only if I press the skip button, because it will reload at the start of the last song that finished playing.
2 - it won't play anything at all, and simply remains frozen until I reboot it another few times.
3 - it plays when I pres the skip button, but only after several reboots during which it will delete songs from the upcoming queue at random every time I press the play or skip buttons.
This happens seemingly at random. Sometimes it crashes every other song like this, and other times it will play fine for hours on end. I would say on average this might happen three times an hour though.

Another issue that I'm having is that when I add songs to the queue or drag them to where I want them, it can also have multiple unintended results, such as:
1 - it doesn't add the songs to the queue at all.
2 - it adds them after the next song instead of next in the queue, or it adds them somewhere else randomly in the list of songs I've already queued, but not at the end of the queue where it's supposed to be.
3 - it adds them to the queue whilst deleting everything else I've already added.
4 - it adds them in the right order but in the wrong place, and when I rearrange it to where it was supposed to be or how I wanted it, it will delete everything in the queue that was in between them.

Additionally, when I attempt to play a playlist from a song instead of simply clicking on the play button at the top of the playlist, it will simply play that song then resort to a random library shuffle after, instead of continuing with the playlist. If I press the play button at the top next to the playlist name:
1 - sometimes it will add the playlist, in order as in unshuffled, to the upcoming queue - but not at the end of the queue, somewhere in the middle.
2 - sometimes it will shuffle the playlist with whatever else was already playing or previously playing.
3- sometimes it will play the first track of the playlist, then go back to what was previously playing.
The same happens when playing albums.

Artist biographies on the "Now Playing" tab don't save if I edit them, and don't scroll. I don't like having a huge block of pointless text there that I have to scroll down to read, especially when there's so much that it's impossible to read during one song, so I'm editing them down to vital information at they come up - but it never seems to save when I save it.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10678
Hi, welcome to the forum!

Based on what you've said, there may be a deeper problem here. I'm wondering if it has to do with file write access or even a drive going bad. Are you having trouble anywhere else?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Similtiades

  • Newbie
  • *
  • Posts: 15
Haven't noticed any issues anywhere else - everything plays fine in iTunes, for example. It was fine for all of last year when I downloaded MusicBee; then I left the laptop at home while I was abroad for a couple of months. Since I got back it's been acting up like this... Also I should add, I updated to the latest version of MusicBee and it happens less often since then, but still happens.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10678
I would suggest installing the portable version of MB in a new directory (on the desktop, maybe) and seeing what happens with a new copy of MusicBee and a new library file. This kind of weirdness and inconsistency really suggests a corrupt file somewhere, which, since you say your laptop was unused for a long period before it started, seems very possible.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

frankz

  • Hero Member
  • *****
  • Posts: 3290
FWIW failing drive was the first thing I thought, too.  Might be worth a disc scan.
A smile is happiness you'll find right under your nose.