Author Topic: Truncated tracks  (Read 3940 times)

Jimboss

  • Newbie
  • *
  • Posts: 1
MB cuts the last half second off some tracks, willy-nilly, regardless of settings in Preferences/Player/Sound Effects. Have tried various combinations of Add Silence, Remove Silence but they seem to be disabled: They don't do anything.

karbock

  • Jr. Member
  • **
  • Posts: 47
+1

I have uploaded a file concerned by the issue here

The sample contains the pronunciation of "Bohuslav Matěj Černohorský".
Most of the time, MB doesn't play the last syllable, hence you hear "Bohuslav Matěj Černohor" instead.

sveakul

  • Hero Member
  • *****
  • Posts: 1907
+1

I have uploaded a file concerned by the issue here
The sample contains the pronunciation of "Bohuslav Matěj Černohorský".
Most of the time, MB doesn't play the last syllable, hence you hear "Bohuslav Matěj Černohor" instead.
This file plays all the way through here every time.  MusicBee 3.4.7992 P; WASAPI exclusive, zero DSP except EQ.  File is mono, Lame-encoded, and has a 24kHz sample rate/32kb bit rate.  Try updating to the latest version of MusicBee including the latest patch if you haven't done so.

karbock

  • Jr. Member
  • **
  • Posts: 47
Thanks, skeakul!

MB was already up-to-date (MusicBee v3.4.7992.33416D). No DSP either.

The output mode was initially set to DirectSound here.
Changing to "WASAPI exclusive" doesn't change the behaviour,
whereas "WASAPI shared" raises the rate of correct readings to around 50%.

sveakul

  • Hero Member
  • *****
  • Posts: 1907
The output mode was initially set to DirectSound here.
Changing to "WASAPI exclusive" doesn't change the behaviour,
whereas "WASAPI shared" raises the rate of correct readings to around 50%.
That's strange!  What kind of antivirus do you run?  Be sure that all your MusicBee folders and the folders containing your music files are excluded/whitelisted from any of its monitoring options.

I am running newer versions of most of the BASS libraries due to personal eccentricities, but with no DSP active this shouldn't involve bassmix.dll or bass_fx.dll.  Nevertheless you could try updating those with the ones here, both of which are release versions: https://www.un4seen.com/download.php?bassmix24 , https://www.un4seen.com/download.php?z/0/bass_fx24

You could also try updating bass.dll itself to the 2.4.16.7 version (https://www.un4seen.com/download.php?bass24).  But check the antivirus thing first.

karbock

  • Jr. Member
  • **
  • Posts: 47
Sorry, no change either after whitelisting the folders in the antivirus (BitDefender) and upgrading BASS (bass.dll + bass_fx.dll + bassmix.dll).

But...
* The audio file is played correctly when it's last in the playlist.
* When followed by anything, the issue shows up, although crossfading is inactive.

I have uploaded my MusicBee3Settings.ini to the same cloud folder, just in case.

sveakul

  • Hero Member
  • *****
  • Posts: 1907
OK I'm out of ideas then, maybe someone else can help.  BTW I don't see your ini file you said you uploaded at the link you posted previously, only the sample MP3 file.

Edit:  also tried adding it inside a playlist to see if I could duplicate what you said about it being followed by anything--still plays through fine.
Last Edit: November 20, 2021, 07:36:13 PM by sveakul

hiccup

  • Hero Member
  • *****
  • Posts: 5932
I also experience no issues whatsoever with playing the (excerpt of the) song.
Checking it with mp3diags also doesn't indicate any technical problems with the file. (except it being of low audio quality)

Perhaps an issue with the audio device drivers?
Or maybe other software installed that is in the audio path?

frankz

  • Hero Member
  • *****
  • Posts: 3166
Maybe a silly question, but you don't have remove beginning and end silence checked in the Player preferences do you? The fact that it doesn't happen when it's the last track to be played made me think of this.
A smile is happiness you'll find right under your nose.

karbock

  • Jr. Member
  • **
  • Posts: 47
Thanks to all for your answers. This topic definitely has a mysterious side.

* MusicBee3Settings.ini should be available now, along with a list of my installed drivers.
* In Preferences/Player, option "Remove silence ..." is not ticked.
* Option "Add silence to end of each track: ... seconds" doesn't work either with the aforementioned MP3, strangely enough.

hiccup

  • Hero Member
  • *****
  • Posts: 5932
Does it make a difference if you deselect 'load the entire file into memory'?

karbock

  • Jr. Member
  • **
  • Posts: 47
Does it make a difference if you deselect 'load the entire file into memory'?

No, it doesn't, but I have just found a combination of options that fixes the truncation issue, at last!

Under Preferences/Player/Audio Player:
* output = WASAPI exclusive
* event mode ON

Since I didn't mark what other files the truncation occurred with, I can only wait and see if it happens again.

Thanks again to you all!

RuNeN00b

  • Newbie
  • *
  • Posts: 3
I'm redoing the track listing of Abbey Road to have Her Majesty in the middle. When I re-export the file of Mean Mr. Mustard through Audacity (because Her Majesty has slight bleedover), it exports just the way I left it. When I play it through MB, the last two drum hits get cut off, despite the track time still being the same as it was on the selection I had for Audacity. The same thing happens for the cut I did of Her Majesty into Polythene Pam.

I don't have any of the settings enabled to cut down the start or end of tracks, so I'm very confused why VLC will play this file without any hitches, but MB won't.