Author Topic: [fixed] error=BASS_ERROR_CODEC  (Read 28417 times)

maelcum

  • Newbie
  • *
  • Posts: 2
Hi.

I've installed
- MusicBee 1.2.4037
- it's Update 4103
- XulRunner 1.9.2.16
- new Skins
- and the Codecs
--   bassaac.dll (in \MusicBee),
--   lame.exe (in \MusicBee\Codecs), as well as
--   neroaacenc.exe (in \MusicBee\Codecs)
on a freshly installed Windows 7 Ultimate N (<-!) x64 Retail-Installation.
[ I am aware that the additional codecs are not necessary; I just wanted to make sure nothing MB would look for is missing. ]

Things seem to work fine; the library loads, I can search and mangle the files, but playback is not possible. Instead, the dialog "Unable to open file (error=BASS_ERROR_CODEC)" is shown.

I've tried al possible sound devices in Preferences > Player as well as the output options and the 32 bit output flag - to no avail.

Could it be that MusicBee needs some files from Windows Media Player or Windows Media Center? The N-Sub-Edition of Windows doesn't come with them (or their supporting files). (See: http://en.wikipedia.org/wiki/Windows_7_editions under Sub-Editions).

Are there other requirements on a fresh installation that I should be aware of?

Thanks in advance.
Last Edit: April 07, 2011, 11:48:02 PM by maelcum

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
its been asked a few times before on the forum
http://getmusicbee.com/forum/index.php?topic=2322.0

Due to licensing restrictions MusicBee (and most other freeware players that havent purchased the required MP3 licenses) can only use the MP3 codec that comes already installed with windows.
However the Windows 'N' series does not include this codec. You can download it yourself from miscrosoft:
http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=31017ed3-166a-4c75-b90c-a6cef9b414c4

maelcum

  • Newbie
  • *
  • Posts: 2
Thanks a lot!!
I've searched the forums before; sorry to have repeated the question.  ::)
Changed title to [ fixed ]

Lightblur

  • Guest
Thank very much Steven!! I also had this problem but I have Windows 8 Pro N and I solved installing the same update, only for Windows 8.
This is the link, just in case someone else will have the same problem in the future =)
http://www.microsoft.com/it-it/download/details.aspx?id=30685

theASDF

  • Guest
sorry for digging this up again. i got the same error aswell because i use windows 7 n. i am avoiding the microsoft media pack as 99% of it is stuff i dont need and want. i downloaded ffdshow to do the decoding but it does not help me with the problem. any idea why? or any idea what alternatives i could use?

baZzz

  • Guest
I had the same problem and didn't feel like installing all that M$ bloatware either. I found a working solution by just installing a MP3 codec. It's free and only a mere 160 kB. You can download it here: http://www.free-codecs.com/download/MPEG_Layer_3_Codec.htm

theASDF

  • Guest
I had the same problem and didn't feel like installing all that M$ bloatware either. I found a working solution by just installing a MP3 codec. It's free and only a mere 160 kB. You can download it here: http://www.free-codecs.com/download/MPEG_Layer_3_Codec.htm

i have no idea why that decoder worked and the one i had didnt, but thanks, it fixed the problem :)

MasterP

  • Jr. Member
  • **
  • Posts: 68
Maybe link the codec or this thread in the error message? Wasnt clear to me first, what was the problem.
Glad i found this post. The codec from the last link worked fine. Thanks.

Angiel

  • Guest
Thanks a bunch. I have also a win 7 N version and got same errors, cldn't play anything. And i really like MusicBee. until i found this topic i thought that i will have to let MusicBee go. Thank you for posting the freeware codec i rly didn't want to install WMP.  It worked wonderfully. And mods pls don't delete this topic is useful. BTW the link with the other topic doesn't work or i can't see it, since i just made this account to say my thanks :D.

Demeev

  • Guest
I had the same problem and didn't feel like installing all that M$ bloatware either. I found a working solution by just installing a MP3 codec. It's free and only a mere 160 kB. You can download it here: http://www.free-codecs.com/download/MPEG_Layer_3_Codec.htm

?????? ?????? ! ?????? ??????? ???? ?????? !