Author Topic: Merge albums in a playlist ordered by size?  (Read 4222 times)

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3776
  • MB Version: 3.5.8367 P
Oops! left a line out of the instuctions  :-[
Revised instructions below:

Go to Preferences> Tags(1)> custom tags
Define a custom tag with the display name 'Album bytes' and select 'Save to MusicBee database only'

Go into Auto Library Reports (ALR) and select new preset.
Highlight <Empty preset>
'Functions for new fields:' should display <Grouping>. If it doesn't, change it so it does.
From LH column select <Album unique Id> then Album
Change 'Functions for new fields:' to Sum
Again from LH column select Size (not in the alphabetical list, it's about 3rd last)
Select 'Preview' and see if report compiles.

Now change 'Save field' to 'Sum(Size)' and 'to tag:' to 'Album bytes'
Tick check box in front of ALR preset so that it's calculated and saved at startup
Select 'Update preset' then 'Close'

You can now use/display the 'Album bytes' tag in MusicBee.

Now it should work for you
MusicBee and my library - Making bee-utiful music together

Fivda

  • Jr. Member
  • **
  • Posts: 74
Oops! left a line out of the instuctions  :-[
Revised instructions below:

Go to Preferences> Tags(1)> custom tags
Define a custom tag with the display name 'Album bytes' and select 'Save to MusicBee database only'

Go into Auto Library Reports (ALR) and select new preset.
Highlight <Empty preset>
'Functions for new fields:' should display <Grouping>. If it doesn't, change it so it does.
From LH column select <Album unique Id> then Album
Change 'Functions for new fields:' to Sum
Again from LH column select Size (not in the alphabetical list, it's about 3rd last)
Select 'Preview' and see if report compiles.

Now change 'Save field' to 'Sum(Size)' and 'to tag:' to 'Album bytes'
Tick check box in front of ALR preset so that it's calculated and saved at startup
Select 'Update preset' then 'Close'

You can now use/display the 'Album bytes' tag in MusicBee.

Now it should work for you

In the ALR tab, the only checboxes i see are "calculate aggregated functions" and "save only if tag".
Which am i supposed to check?

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3776
  • MB Version: 3.5.8367 P
Which am i supposed to check?

The other one in front of the preset highlighted in blue
MusicBee and my library - Making bee-utiful music together

Fivda

  • Jr. Member
  • **
  • Posts: 74
Which am i supposed to check?

The other one in front of the preset highlighted in blue

I should have done everything right, but it still sorts everything by alphabetical order 😭

frankz

  • Hero Member
  • *****
  • Posts: 3308
Quote
Now change 'Save field' to 'Sum(Size)' and 'to tag:' to 'Album bytes'

You're not saving the sum to a tag.
A smile is happiness you'll find right under your nose.

Fivda

  • Jr. Member
  • **
  • Posts: 74
Quote
Now change 'Save field' to 'Sum(Size)' and 'to tag:' to 'Album bytes'

You're not saving the sum to a tag.

Still same result... Sorry. Recorded what I do step by step, please tell me if I'm doing anything wrong.
Video

frankz

  • Hero Member
  • *****
  • Posts: 3308
Looks like you're following his instructions.

Are the values getting written to the tag or no?
A smile is happiness you'll find right under your nose.

Fivda

  • Jr. Member
  • **
  • Posts: 74
Looks like you're following his instructions.

Are the values getting written to the tag or no?

Is there a way to know how?

frankz

  • Hero Member
  • *****
  • Posts: 3308
Yes, you'd look in the tag editor on the Tags(2) page and see if there's a value for your custom tag.
A smile is happiness you'll find right under your nose.

Fivda

  • Jr. Member
  • **
  • Posts: 74
Yes, you'd look in the tag editor on the Tags(2) page and see if there's a value for your custom tag.

There's nothing...

frankz

  • Hero Member
  • *****
  • Posts: 3308
Have you closed / reopened MB to get the report to run?
A smile is happiness you'll find right under your nose.

Fivda

  • Jr. Member
  • **
  • Posts: 74
Have you closed / reopened MB to get the report to run?

I think the problem was that i ticked the checkbox BEFORE i update the preset. I restarted, and it reported now. I updated before checking and it seems to behave more like to what i originally wanted now, the order is different- Not exactly precise however, like the albums aren't sorted by size. (first album is 1gb, then 250mb, then 517..)

But we're getting somewhere (as the first is indeed one of the heaviest album in playlist)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8165
first album is 1gb, then 250mb, then 517..)
It might be doing an ASCII sort instead of a true numerical sort.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3776
  • MB Version: 3.5.8367 P
Go to Preferences> Tags (2)> tag handling> Configure Fields
and make sure 'Album bytes' is set to type 'Number'
MusicBee and my library - Making bee-utiful music together

Fivda

  • Jr. Member
  • **
  • Posts: 74
Go to Preferences> Tags (2)> tag handling> Configure Fields
and make sure 'Album bytes' is set to type 'Number'

put it under "left / Number", re-updated the preset, saved, closed and reoppened music be, re-sorted by Album Bytes (desc) / album but still the same kind of result.