Author Topic: [SOLVED] Cannot paste artwork -> "Invalid picture" [MB 3.3 upd. 4]  (Read 2431 times)

karbock

  • Sr. Member
  • ****
  • Posts: 315
Buggy version:
MusicBeeSetup_3_3_Update4.zip

Latest functioning version:
MusicBeeSetup_3_3_Update3.zip

Actions performed when bug shows up:
- outside MB, copy artwork to clipboard
- in MB, right click on an artist's thumbnail
- select "Paste Artwork"

Error message:
In MB 3.3 upd. 4, you get an error window, reading "Invalid picture",
whereas in MB 3.3 upd. 3, the artist's thumbnail is changed as expected.
Last Edit: October 29, 2022, 10:50:26 AM by karbock

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34268
Working fine here. Not sure what to suggest as nothing I can think of has changed

karbock

  • Sr. Member
  • ****
  • Posts: 315
Thanks for your quick answer, Steven.

After reinstalling Update 4 over Update 3, the function now works fine.
One further IT mystery to puzzle out...
Last Edit: February 14, 2020, 04:54:18 PM by karbock

karbock

  • Sr. Member
  • ****
  • Posts: 315
A few hours later, the problem is occurring again in MB 3.3 update 4.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34268
when that happens try pasting in a picture tool such as paint.net
i expect its something like you have run out of memory on the clipboard

karbock

  • Sr. Member
  • ****
  • Posts: 315
Pasting works fine with any image editor, though.

Moreover, the problem started to occur with 3.3 upd. 3, too. Strangely enough, the problem disappears each time after reinstalling MusicBee.
After the latest reinstallation, I made a backup copy of folder "C:\Program Files (x86)\MusicBee", for future comparison with the state of the folder when the bug shows up again.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34268

karbock

  • Sr. Member
  • ****
  • Posts: 315
The problem is solved now.

There were inconsistent values in MusicBee3Settings.ini,
as I had migrated MusicBee along with its libraries from another computer,
forgetting to change the user name in the ini file.

* Computer 1
- User 'Marc'
- MusicBee 3.3 upd 3

* Computer 2
- Users 'acer' and 'Marc', both with administrator privileges
- MusicBee 3.3 upd 4 runs under user 'acer'

Strangely enough, in the problematic state (Computer 2), each time I performed "Paste Artwork":
- the .jpg file was created in 'C:\Users\Marc\Music\MusicBee\Artist Pictures\Thumb'
whereas
- the .png file was not created in 'C:\Users\acer\AppData\Local\MusicBee\InternalCache\ArtistThumbs'
Last Edit: February 23, 2020, 04:12:27 PM by karbock