Author Topic: Auto DJ not registering or saving filtres  (Read 1990 times)

ms.glug

  • Newbie
  • *
  • Posts: 7
I like Auto DJ. It has "rediscovered" some of my old tracks that I hadn't played in ages. However, I want to be able to tell it not to play certain genres, such as kids' songs for example, which are on my hard drive because, well, I have kids! I also want it not to repeat the same artist too frequently. I know how to do it (I'm not much of a technical whizz but I can manage that much). So I do it, and it ignores me. Every now and again I get Thomas the Tank Engine or Shawn the Sheep. I also get 2, sometimes even 3 tracks from the same artist in a row. It's simply ignoring the filters. And when I shut MB down and reopen it (usually another day) it has deleted the number of tracks for the repeat and replaced it with zero. It also unticks the filter box. There appears to be no "save" button. Might this be a problem?

If anyone has any ideas how to fix this it would be much appreciated.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
can you post a screenshot showing the filters you have chosen



Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
Its working fine for me and I dont recall anyone else reporting this issue. The auto-dj settings get saved when you click the Preview or Start DJ buttons

hiccup

  • Hero Member
  • *****
  • Posts: 8013
Or was I supposed to do this?

You should change 'all of the following rules' to 'any of the following rules'.

I'm sorry, this was a wrong statement.
Last Edit: November 16, 2019, 05:37:11 PM by hiccup

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9447
@ms.glug-
Off-topic, but what is the font used in your screenshot?
Thanks.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

ms.glug

  • Newbie
  • *
  • Posts: 7
As you can see, the Preview option is blanked out. I can't press it. There is also no Start DJ button that I can see. I realise that nobody else has reported this problem as I did search to make sure it hadn't already been solved. But I do have this problem.  :-\





The font is Never Say Never btw.

ms.glug

  • Newbie
  • *
  • Posts: 7
OK. So I just pressed Stop. Then the Preview button became available, as it were, so I pressed it and the list filled with tracks. Then I pressed the Start DJ button that magically appeared where the Stop button had been. I'm no tech wizard, as I said, so I was just experimenting and accidentally hit upon this..... I had no idea the Start DJ button would be concealed behind the Stop button. Perhaps not the most intuitive feature. But hey ho, we'll see if it works. Thanks for your help. I'll be back on here if I hear the Wombles again  ::)

hiccup

  • Hero Member
  • *****
  • Posts: 8013
Not sure, but maybe changing the wording would make things a little more obvious?

Change 'stop' and 'start' to 'activate' and 'deactivate'?
'start' to me suggests and resembles 'play', which isn't really the case here.

And even when AutoDJ is already 'activated', maybe 'preview' could still be an available option?
Not sure about the logics why it wouldn't be.
Last Edit: November 16, 2019, 08:57:29 PM by hiccup

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9447
The font is Never Say Never btw.
Thank you for this.

Now back to your issue: What version of MB are you using (Help > About) and did you use the Store, Installer, or Portable version?

It's working as expected for me on v3.3.7257 P
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

hiccup

  • Hero Member
  • *****
  • Posts: 8013
Now back to your issue

I believe the OP figured it out already.
My reply was directed at Steven, suggesting a possible change/improvement to the matter.

ms.glug

  • Newbie
  • *
  • Posts: 7
The font is Never Say Never btw.
Thank you for this.

Now back to your issue: What version of MB are you using (Help > About) and did you use the Store, Installer, or Portable version?

It's working as expected for me on v3.3.7257 P

My version is 3.3.7165, downloaded from the website only a couple of weeks ago. It seems to be working now. I think I was just thrown by the way it's set up. It wasn't immediately obvious what I was supposed to do.