Author Topic: Album Artwork Not Displaying  (Read 2492 times)

TehDunsparce

  • Newbie
  • *
  • Posts: 3
There are three songs in my library where the track information on the bottom right displays the artwork but the album on the main screen does not. I tried to fix this issue via this thread, but not only did it not fix my problem, it made it much much worse. The tracks in question still don't display the artwork, and now every other track has had the artwork of another album copied over it.



And it isn't just the same artwork either, it seems to be semi-random from any of the album artworks I saved manually. I feel like this ties into the other problem I was having, where the Update Missing Artwork button would always replace the artwork with a specific cover (the one seen most in the attached picture).

The artwork isn't gone for the 100's of songs I have, it just has the main artwork overwritten, is there a way to fix this other than deleting each of the overwritten covers manually? Is there a way to get my Update Missing Artwork button into not incorrectly updating the song with the wrong artwork? And is there a way to get the artwork from my initial problem to display on the actual album?

Any help would be greatly appreciated.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
Hi, welcome to the forum!

Can you please give us a screenshot of your tags (1) preferences?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)


TehDunsparce

  • Newbie
  • *
  • Posts: 3
I think I may have fixed the large issue of all the messed up artwork. I had a single file named Cover.jpg in my music folder and deleting it (and then refreshing artwork cache) seemed to fix all the songs that got changed. I still have the problem with the certain songs not showing the album artwork even when the track information does though.

Edit: the affected files give an error of "A picture is corrupted, no longer exists or is inaccessible." I downloaded the art via the auto-tagger, but should I try going online to find the artwork and put it in manually for these songs?
Last Edit: August 16, 2018, 09:02:12 PM by TehDunsparce

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
The first thing I suggest is going to the box where it says "set which pictures are displayed" and moving embedded to the #1 spot, since that's your selected storage method. Rescan then, of course.

You could try downloading the corrupted artwork again, or you could just do it manually, as you say.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)