Author Topic: musicbee requires exclusive control of audio  (Read 2934 times)

tetron

  • Newbie
  • *
  • Posts: 1
On Win10 musicbee cannot run unless audio is set to allow  "exclusive control of audio"

Once this is on, if musicbee is loaded (not playing), nothing else can play sounds.

I would say this is very annoying, eg if I want to just check something out I can't pause, I have to actually close the whole thing and load it again.


Is there a good reason in 2019 this is the only app that takes exclusive control of audio without a good reason? It's not like a game or something where you do want to mute everything else going on.

CritterMan

  • Sr. Member
  • ****
  • Posts: 556
  • Now with FiiO M11!
I can't reproduce this issue. Can you share a screenshot of your player settings?

Ctrl+o > select the Player tab on the left side

Your output setting (the top one) should be set to DirectSound. Anything else forces exclusive mode. The sound device setting (just below that) should be whatever your default audio device is. If that doesn't fix the issue, the other settings might shine some light on the situation.

Edit: WASAPI (Shared) may also work. Forgot about that one.
Home Desk ~ MB 3.3 Portable • Questyle CMA400i (ASIO) • Sennheiser HD 660S (balanced) / Audeze EL-8 Closed Back / Fostex TR-X00 Ebony • Teac AI-101DA • Jamo C93 + Dayton Audio SUB-1000
Work Desk ~ MB 3.3 Portable / Tidal • SMSL SU-8 v2 • Nobsound NS-05P • THX AAA 789 • Sennheiser HD 58X (balanced)
OTG ~ FiiO M11 • Audiofly AF180 / B&O H6

sveakul

  • Hero Member
  • *****
  • Posts: 2561
Hi tetron:

1.  What version of MusicBee are you running?  Please update to the latest 3.3x patched version.

2.  What do you have the output set to in Prefs/Player?

If you have output set to wasapi-exclusive, MB will take exclusive control of audio if that is allowed in your Windows device settings.   If you choose the wasapi-SHARED or DirectSound output in MusicBee, it will NOT take exclusive control of the audio device.