Author Topic: Can't connect to remote speakers or stereo  (Read 17675 times)


blueriver

  • Jr. Member
  • **
  • Posts: 41
Thanks.  Tried it but it won't hold the selection of remote speakers in player configuration.  I select output speakers then apply and save then select play and I get message that no speakers are selected.  Go and check and they are no longer selected>??

emilles

  • Jr. Member
  • **
  • Posts: 22
Even with this update (refers to your 3.1 patch posted on the 12th), Winamp's extern "C" __declspec(dllexport) Out_Module* winampGetOutModule() interface is not being called for the out_apx.dll plug-in.  Without this recognition/initialization, the rest of the plug-in will not work.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34410
would either of you be happy to run a debug version as i am not seeing why it would not be called (that wasnt the case in earlier v3.0+ versions)

https://www.mediafire.com/file/ru5ja8fcd3jmuoi/MusicBeeDebugWinamp.zip
unzip and replace the existing musicbee.exe file
a couple of lines will be written to the end of the error log (help/ support/ view error log)
Last Edit: November 19, 2017, 10:11:16 PM by Steven

blueriver

  • Jr. Member
  • **
  • Posts: 41
11/19/2017 3:29:51 PM - G:\Music\:Thread was being aborted.
11/19/2017 3:31:59 PM - C:\Users\Roy and Kim\Music\Roy MP3\Cream - Eric Clapton  Royal Albert Hall London May 2-3-5-6, 2005 mp3@320kbps\CD 1\03 - Cream - Outside Woman Blues.mp3:refresh:Thread was being aborted.
11/19/2017 3:35:57 PM - 10.0.16299.0 - 3.1.6512.37408 - #=quNSXZemwORqHO5QqjC7ijhXVLfzpQsJwh1VUBeeWjw4=: Unable to initialise sound device
   at #=q_i_LrTKK7BwuATKOua8qmqutzCW6b15xw1dKCwcv_Zc=.#=q36MFYyP0JJ0gJ7U0phM70A==(#=qccM21pX5G5sd6tbVaj0MyKyngxtuC2v87b0lcla4rbY= #=qTLDI2SZOe2inY4_HCaMpHw==, String #=qZJixqmOCNOLB2KDiGj9Hb_3avtxDGPo9Gh6tOZdMNN8=, #=quUsQu7wW7Q8y0$dMYNdliw== #=qig0YJosWFsI_2yqlkXqrTKNjf3bx$xjwtnNQNP452GE=, Int32 #=qrK$OiSL_YnfcZhIkwj3NLA==, String #=qnkZ6LKFdJjQrAdRfUFhC$Q==, IntPtr #=qvoWXCntRJbbttJfWnERskA==)
   at #=qmZhwHJF$AlGFGV33nuDlwmVP4G9dMChTV_8ROnXyWzGrduk0XGGp3964ylGmgjU_.#=qDodk6x9AWvGRrHce$$oEKgpuSbf4sp_urJjTnJ8P1xo=()
   at #=qmZhwHJF$AlGFGV33nuDlwmVP4G9dMChTV_8ROnXyWzGrduk0XGGp3964ylGmgjU_.#=qoSBkZ2mJyjcabvWcVmasTm1mLft3EZ0HgTcDKDIApBU=(Object #=qVyzYECkIDukvFDZQ0Mtecg==, EventArgs #=qw4YhS5lJ_jPDh2Ce58nwuw==)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at #=qSsdSC9rRktz$BkretIIc59Wcw$Y0415L4iGYH0s0buY=.OnClick(EventArgs #=qPe5NK7Z7Hh$IEcfWOhJl8w==)
   at #=qSsdSC9rRktz$BkretIIc59Wcw$Y0415L4iGYH0s0buY=.#=qzKuhVx$cqofnCfc5MF5jpu1MUK06RD8BnEW8YEpH274=(Object #=qDD3MujgLjt2evcGg34lZ2A==, EventArgs #=qhpw4ur0cvYHzJi5qLajU4Q==)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

emilles

  • Jr. Member
  • **
  • Posts: 22
I get no additional output in the Error Log or in Output view in Visual Studio.  And the init method is still not called; I think the dll is not loaded.

blueriver

  • Jr. Member
  • **
  • Posts: 41
So, Is this a problem with my set up or is it something to be addressed by a modification to the the Musicbee program?  I assume it is not my set up but the program itself.  Comment please?

emilles

  • Jr. Member
  • **
  • Posts: 22
Here is a good 3.0 load and a 3.1 load.  In 3.0 my plug-in loads right after the nsi.dll (which I'm guessing is the Nullsoft Interface library).

3.0 loading:
Code
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\dsound.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\powrprof.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\MMDevAPI.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Users\Public\MusicBee-3.0\basscd.dll', No symbols loaded.
'MusicBee.exe': Loaded 'C:\Users\Public\MusicBee-3.0\MusicBeeBass.dll', No symbols loaded.
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\ws2_32.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\nsi.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Users\Public\MusicBee-3.0.5995\Plugins\out_apx.dll', Symbols loaded.
'MusicBee.exe': Loaded 'E:\Development Projects\!Remote Speakers output\mainline1\rsoutput\out\apxCore.dll', Symbols loaded.
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\IPHLPAPI.DLL', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\winnsi.dll', Cannot find or open the PDB file
Player attaching to plug-in...
Player requesting plug-in interface...
Reading plug-in options from 'C:\Users\U0076777\AppData\Local\Remote Speakers output\plugin.ini'...
Read 'VolumeControl' value '1'.
Read 'PlayerControl' value '0'.
Read 'ResetOnPause' value '1'.
Read 'Device1_Type' value '99'.
Read 'Device1_Name' value 'Klipsch G-17'.
Read 'Device1_Address1' value 'CC909300E218@Klipsch G-17'.
Read 'Device1_Address2' value '_raop._tcp.'.
Read 'Device1_ZeroConf' value '1'.
Read 'Device1_Activated' value '1'.
Read plug-in options from 'C:\Users\U0076777\AppData\Local\Remote Speakers output\plugin.ini'.
Initializing remote speakers output component...
Initialized remote speakers output component.
Starting playback state monitoring thread...
'MusicBee.exe': Loaded 'ImageAtBase0x61e90000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Loaded 'ImageAtBase0x9e40000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Unloaded 'ImageAtBase0x61e90000'
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\xmllite.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\thumbcache.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\SearchFolder.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\actxprxy.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\StructuredQuery.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\secur32.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\dnsapi.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\dhcpcsvc.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\dhcpcsvc6.dll', Cannot find or open the PDB file

3.1 loading:
Code
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\dsound.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\powrprof.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\MMDevAPI.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\AudioSes.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Users\Public\MusicBee\basscd.dll', Binary was not built with debug information.
'MusicBee.exe': Loaded 'ImageAtBase0x626d0000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Loaded 'ImageAtBase0xa4c0000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Unloaded 'ImageAtBase0x626d0000'
'MusicBee.exe': Loaded 'ImageAtBase0x62690000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Loaded 'ImageAtBase0x79c0000', Loading disabled by Include/Exclude setting.
'MusicBee.exe': Unloaded 'ImageAtBase0x62690000'
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\xmllite.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\thumbcache.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\SearchFolder.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\actxprxy.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\StructuredQuery.dll', Cannot find or open the PDB file
'MusicBee.exe': Loaded 'C:\Windows\SysWOW64\secur32.dll', Cannot find or open the PDB file

blueriver

  • Jr. Member
  • **
  • Posts: 41
So is there something I need to do?  How can this be fixed for my use? Please and thanks.

emilles

  • Jr. Member
  • **
  • Posts: 22
Steven and I can work this out.  There is something different between MB 3.0 and 3.1 that is preventing Winamp plug-ins from loading.

blueriver

  • Jr. Member
  • **
  • Posts: 41
Great thanks!  I appreciate the effort, knowledge and skill that is required.  I will wait for further advisement.  Thanks again!

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34410
can either of you send me a link to your settings file (help/ support/ view settings)

blueriver

  • Jr. Member
  • **
  • Posts: 41
Tried to post settings and got this message:

The following error or errors occurred while posting this message:
The message exceeds the maximum allowed length (20000 characters).

blueriver

  • Jr. Member
  • **
  • Posts: 41

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9391
Upload it to a file sharing site - Mediafire, Google drive (or whatever they're calling it now,) etc. Get the link to you uploaded file, and send the link to Steven. Mediafire is very simple to use and you don't have to register.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here