Author Topic: Album Types (LP's ; EP's ; Singles ; Compilations, etc.)  (Read 7393 times)

wobbly

  • Sr. Member
  • ****
  • Posts: 255
its  only the  Various Artists albums iam having  problems with now

what should my custom sorting be ?

eg sorting set 1
i have
1 grouping
2 year (yyy)
3 album

i thinking artist may need to be in there somewhere

or i would be happy not to  see  Various Artists for now ..


wobbly

  • Sr. Member
  • ****
  • Posts: 255
artist for group by field and grouping for sub grouping field.
still no joy


wobbly

  • Sr. Member
  • ****
  • Posts: 255
ok i made a new install   have not changed  any settings

and still having problems  with Various Artists albums


update
i got it to work  in new install
 so loaded old install and still had problems with Various Artists albums  being messed up

but then the Various Artists albums started working old install   ... have not worked out why

the test version is using new database  nothing from old version  not even same music path

i need to  work out  what's going on here

one thing i did notice in new install 
and it set to  album cover view and when  i did a search for Dave Edmunds it switch to tracks view so i set it back to  album cover view could that be something ?

wobbly

  • Sr. Member
  • ****
  • Posts: 255
ok i quit musicbee and reload  now the Various Artists albums are messed up again

this bug is a cool one haha

wobbly

  • Sr. Member
  • ****
  • Posts: 255
ok i think i've got something  
if i right click a Dave Edmunds track and go to search (right click menu) find artist Dave Edmunds
all works great

BUT if i use  the search  from search icon it find all the same albums but all the Various Artists  are messed up

hope this helps
Last Edit: December 05, 2017, 08:05:41 PM by wobbly

wobbly

  • Sr. Member
  • ****
  • Posts: 255
i will test a few more artist now and see if the same thing happens

wobbly

  • Sr. Member
  • ****
  • Posts: 255
i think i  cracked it  from the search icon
always show the entire album was on

yes can confirm always show the entire album is the problem

just so you know with always show the entire album is on just did a search for abba and again

Various Artists albums are messed up
always show the entire album ( is not showing  the entire album they are messed up)
Last Edit: December 05, 2017, 09:14:07 PM by wobbly

wobbly

  • Sr. Member
  • ****
  • Posts: 255
here are the steps
1 set to album cover view
2 set group by "artist" set sub grouping  to "grouping" 
3 turn on always show the entire album form right click menu search icon
4 search for an artist from search icon eg Abba
5 now click a Various Artists album should see random tracks (not abba )

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3388
  • MB Version: 3.3.7251 P
Occasionaly a sub-grouping header gets missed


I've tried to find some sort of pattern to the behaviour, to make a more useful bug post, but I can't find any rhyme or reason to it.
The only thing, if I change the grouping tag to another grouping, save the tag and refresh the page, the new sub-grouping shows.
If change the grouping back to the correct grouping, save and refresh, the tag is missing again.  And that's not confined to any single grouping tag.

The only consistent thing is that when it occurs, it's always the first grouping sub-header after the grouping header.
Maybe it's some sort of spacing issue for the panel?
Last Edit: December 15, 2017, 11:09:09 AM by Bee-liever
MusicBee and my library - Making bee-utiful music together

wobbly

  • Sr. Member
  • ****
  • Posts: 255
Occasionaly a sub-grouping header gets missed


I've tried to find some sort of pattern to the behaviour, to make a more useful bug post, but I can't find any rhyme or reason to it.
The only thing, if I change the grouping tag to another grouping, save the tag and refresh the page, the new sub-grouping shows.
If change the grouping back to the correct grouping, save and refresh, the tag is missing again.  And that's not confined to any single grouping tag.

The only consistent thing is that when it occurs, it's always the first grouping sub-header after the grouping header.
Maybe it's some sort of spacing issue for the panel?

i have   found the same thing   if i add a new  grouping  tag in 3.1 not updated in 3.2 will come back after more testing

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
Occasionaly a sub-grouping header gets missed
is this after a fresh start if MB or only after editing tags?

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3388
  • MB Version: 3.3.7251 P
is this after a fresh start if MB or only after editing tags?
after a fresh start, a restart or F5 refresh after editing tags
MusicBee and my library - Making bee-utiful music together

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
thats fixed for the next update. Its when the sub-grouping value is the same as the one from the previous grouping