Author Topic: additional buffer setting for wasapi (asio?) to solve some problems  (Read 7880 times)

rurutia10

  • Jr. Member
  • **
  • Posts: 122
Seems like they both enable the same outcome; small delay to stop music at the start from being cut off.

I don't use WASAPI though, mainly sticking with ASIO. I don't like having to fiddle around before I can hear sound from YouTube videos or other sources :o

hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
Yes, you are right. In foobar, setting the buffer only solves it for wasapi, but activating the 'silence plugin' fixes it for both wasapi and asio.
Thanks, that's useful.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
given its been confirmed this can be solved with a DSP, i will make a couple more attempts at this.
Its possible the bass function i am using is not doing what i think its doing, so i will make one more attempt after this if it doesnt work

https://www.mediafire.com/file/1gtbnfct3qd2f9p/MusicBee.zip

its hard-coded for 0.5 seconds. Even if it does work i wont include it in future v3.1 patch updates and will only officially include it in v3.2 via a configurable setting

hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
This indeed fixes it for me. Both for wasapi event, and push mode.
(not for asio, but that's probably to be expected)

Thanks! I'll keep using this one until 3.2 gets released.


hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
it should have worked for ASIO

I double-checked, and it doesn't work on asio for me. Only for wasapi.
(which is perfectly satisfactory for me personally)

Perhaps rurutia10 has other results with it?
Last Edit: October 09, 2017, 10:01:59 PM by hiccup

rurutia10

  • Jr. Member
  • **
  • Posts: 122

hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
I now have this pre-silence tweak working with asio too.

When checking the asio output configuration settings, I noticed that by default all kind of surround channels were enabled.



I disabled all but Left and Right front, and now the audio isn't truncated for asio also anymore.
 


This might be device-specific, but I thought to share it anyway.

sveakul

  • Editor
  • Hero Member
  • *****
  • Posts: 1647
In regard to this thread, I noticed that un4seen has just released a revised basswasapi.dll (2.4.2) today, whose description says :

"Adds support for lower latency shared mode on Windows 10, more precise latency measurement, buffer size specification in samples, and notification of unexpected stoppages."

Steven, maybe this could be helpful in supplying the additional buffer settings you have been working with?

hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
Well spotted.

I just tried this new dll (on a separate portable test installation), and it solves one of the problems I have been experiencing:

In wasapi mode, I couldn't skip within the playing track by using the progress- or wavebar, because then the playback would immediately freeze.
That seems to be resolved by using this new basswasapi.dll


But I am not advising anybody to do the same on their day-to-day MB installation.
I believe there is some finicky interaction between MusicBee and the basswasapi dll, so Steven probably will be needing to make some further adjustments and fine tuning of MusicBee's core to make it really solid.

But for now I am already happy that this will very likely make it possible to improve on MB's wasapi playback and buffering.

So thanks for reporting this sveakul!

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
i will include the new basswaspi going forward.
I dont see anything noted that should affect musicbee's handling nor fix any bugs but thats good news if it has fixed a mystery problem

hiccup

  • Editor
  • Hero Member
  • *****
  • Posts: 4911
Because of the buffer issue, I'll keep using the tweaked MB version you made available some five weeks ago. ( https://getmusicbee.com/forum/index.php?topic=22493.msg134648#msg134648 )
But for when 3.2 gets released, I'm keeping my fingers crossed that that will resolve both issues for me.