Author Topic: How to get MB to act like itunes in regards to importing new music  (Read 2548 times)

Bitgod

  • Newbie
  • *
  • Posts: 2
Hi, new user moving over from itunes, using the 6336 build.  I've done some searching on this, but it doesn't seem to work the way I expected.

So I want it to be like itunes in that if I have music on an external drive and I drag-and-drop it into the MB app, that it copies the music to the internal drive library folder (In this case, D:\MusicBee\Music).

From what I read, it seems like what I need to do is enable the auto-organize option in the Library preferences to get the app to do this, but it still doesn't act in that manner.  When I drop in a folder from an external drive and then play that file, it's still pointing to the song file on the external drive (I enabled the URL option in track information to see this and confirmed a new folder wasn't added to the artist on the internal drive).

Any suggestions on what I could be missing.  Is it normal for the auto-organize checkbox to always have the exclamation next to it?  I can't tell if it's complaining about something or just saying "hey, note this".

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8300
Is it normal for the auto-organize checkbox to always have the exclamation next to it?  I can't tell if it's complaining about something or just saying "hey, note this".
If you hover your cursor over the exclamation mark, it should pop up an error/alert message. Let us know what it says.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

hiccup

  • Hero Member
  • *****
  • Posts: 6540
I believe that -a should work to encode to mono.
So in encoder settings you could use something like:

--cbr -b 320 -a --noreplaygain - [outputfile]

 

boroda

  • Hero Member
  • *****
  • Posts: 4016
mostly probably some tags used in autoorganization template are missing and you have ticked 'dont organize tracks with missing tags' in mb prefs.

redwing

  • Guest
To auto-organize files from drives different from the drive where your library is located, you need to add an additional drive mapping to the auto-organization setting, otherwise MB will just point to those files without moving them.

But if you want to copy files like iTunes does, you can take the following approach without creating additional mapping.

- Create a new folder in C drive for importing music files and set the folder as one of the monitored folders in library setting.
- Now drag and drop tracks from the external drive not to music library node but to that new folder under MB's computer node in left navigator.
- Then those files will be copied because drag and drop between different drives copies files.
- Now they will be auto-imported either to inbox or library depending on your settings.

boroda

  • Hero Member
  • *****
  • Posts: 4016
@redwing, sorry, completely confused copy and move operations on file organization :)

@Bitgod, please ignore all my posts on this topic.

edit: i've deleted them because they are just flood.
Last Edit: May 16, 2017, 05:46:22 PM by boroda74

Bitgod

  • Newbie
  • *
  • Posts: 2
mostly probably some tags used in autoorganization template are missing and you have ticked 'dont organize tracks with missing tags' in mb prefs.
Errr, that could probably be the reason right there.  Ok, so checked that again, let it run, this time.  Exclamation is still there, but the text (which didn't change) still seems more like a note than a warning.  Here's the warning.


To auto-organize files from drives different from the drive where your library is located, you need to add an additional drive mapping to the auto-organization setting, otherwise MB will just point to those files without moving them.

But if you want to copy files like iTunes does, you can take the following approach without creating additional mapping.

- Create a new folder in C drive for importing music files and set the folder as one of the monitored folders in library setting.
- Now drag and drop tracks from the external drive not to music library node but to that new folder under MB's computer node in left navigator.
- Then those files will be copied because drag and drop between different drives copies files.
- Now they will be auto-imported either to inbox or library depending on your settings.

Ok, that seems to work.  Made a D:\Music Import folder, told it to monitor it, imported an album folder, let it go to inbox first to inspect, then told it to send to library and it shows one of the songs is in the D:\MusicBee\Music... folders now.  Thanks.