Author Topic: Custom sorting  (Read 12708 times)

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10296
Thanks!  At a glance, it's much more as expected now.  The "composer:" entries are showing up in the sorting pop-up, and in the composer "sort as" field.  That was the biggest issue.

Quote
Specially to the ! message, i expect it really is the case George Winston is not defined as a custom artist mapping. As "George Winston" doesnt need to set as "composer:George Winston" - the composer: prefix is only needed if George Winston also was set in the artist field and you wanted it sorted differently.
edit: Actually there might have been a bug in your case with the ! validation. Try again with the new verson when its available before doing the next steps below.

I'm still seeing that message.  George Winston doesn't have a custom Artist/Album Artist mapping, as you say.  There is a Sort Composer tag in the file, but NOT a Sort Artist/Sort Album Artist value, which is how I was handling this previously.  Anyway, if MusicBee can't automatically read that as a "composer:" sort, I'm going to have to manually do them all anyway, so probably not worth worrying about the message.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.4)
(Unzip and overwrite existing program files)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31853
Anyway, if MusicBee can't automatically read that as a "composer:" sort, I'm going to have to manually do them all anyway, so probably not worth worrying about the message.
i also put some logic in so when a new file is scanned, if the composer name is the same as the artist in that file then MB will assign the composer sort value as "composer:XXXX".

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10296
i also put some logic in so when a new file is scanned, if the composer name is the same as the artist in that file then MB will assign the composer sort value as "composer:XXXX".

Sweet!
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.4)
(Unzip and overwrite existing program files)

chrswrn

  • Guest
Picking up an old thread here - I think my current problem is relevant.

Taking one album as an example, I'll use:

Album: Good Morning To The Night
Album Artist: Elton John; Pnau
Year: 2012

I split the display artist so it appears in two places in my Main Panel - both in Elton John's section, and Pnau's section.

It uses my default sort settings: <Album Artist>/Year/<Sort Album>

Because the default "Sort as" Album Artist is Elton John; Pnau, the album sits in the correct place in Elton John's section (his albums sorted by year, it sits where 2012 should do) but in Pnau's because the "Sort as" starts with 'Elton' it sits above all Pnau's albums, so it comes before their debut album in 1999.

My requirement is that is is sorted by year in both Elton's section and Pnau's section. Is there currently a working solution for that, which I just haven't figured out yet?

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10296
Unfortunately, the only way to make that happen would be to remove Album Artist from your sort and just sort by year. Which, if you're mostly looking at one artist at a time, might not be a big problem.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.4)
(Unzip and overwrite existing program files)