Author Topic: ALAC encoding  (Read 16547 times)

bbutlerau

  • Newbie
  • *
  • Posts: 11
i've added ALAC in the File Converter preferences for the next update
thanks heaps, i can now finally uninstall itunes!

Antonski

  • Sr. Member
  • ****
  • Posts: 356
I've tried this, just out of curiosity, but it didn't work for me.

As I see, the command line suppose using of pipe encoding, but correct syntax of standard input (with ffmpeg) is 'pipe:0'.
For example, the following command line (in command prompt) works fine:

Code
cat test.wav | ffmpeg -i pipe:0 -acodec alac output.m4a

The equivalent command line in MB however doesn't work, here is the log:

Code
08.10.2010 01:36:16 - 5.1.2600.196608 - 1.2.3929.33619 - System.IO.FileNotFoundException: Could not find file 'C:\Documents and Settings\power\Local Settings\Temp\tmp6E.m4a'.
File name: 'C:\Documents and Settings\power\Local Settings\Temp\tmp6E.m4a'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
   at #=qKgrTK7xGiiM4vbusPi$3yMR7aaflot7crAEjt59qvOC341tihwMU_lfj3bMNxLov.#=qhm5pkZNpPfuSLyhX4VUAGg==(#=qmGKUPwli5HBdXh8eI9GfXYLUr$P0yozBKwZawwZM5iA= #=q5OvkMBvVTXL0Vw5OtTFgcA==, FileOptions #=q4$wvHzV0vM7p80uTBeqZug==)
   at #=qn$dtZdXb3PUi5jUNwUSwy2c0NxEOagsVjP07cchTRqNoU101QTTKym5tROhwucHH.#=qKDYZxkNJpm9USAPfE_Ly_Q==.#=qbIaZVDt7KH9VZPbbOO4mGA==.#=qxMmApz21QxkbvhZu_Z130xKKKdIYOC5NI2lG3XIxstM=(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qT1YMmx$bOgmHJJZnpSIVqA==, List`1 #=qugjWC$GIWXZLg5m1JqCN5A==)
   at #=qn$dtZdXb3PUi5jUNwUSwy2c0NxEOagsVjP07cchTRqNoU101QTTKym5tROhwucHH.#=qKDYZxkNJpm9USAPfE_Ly_Q==.#=qbIaZVDt7KH9VZPbbOO4mGA==.#=q4tz4byGu5W8AAk1sTkINeg==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qb8BWKuUS2IPZ0TPINYwjkw==)
   at #=qn$dtZdXb3PUi5jUNwUSwy2c0NxEOagsVjP07cchTRqNoU101QTTKym5tROhwucHH.#=q_lSHKdmUmHhErOEcuHRqEg==.#=qYP21w18KL0VFOf8ZvFEbfg==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qg2EMmCfmJwhawMjG4MdDIg==)
   at #=qn$dtZdXb3PUi5jUNwUSwy2c0NxEOagsVjP07cchTRqNoU101QTTKym5tROhwucHH.#=qpIgsTx2KCLEtAeNWXA_fgw==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=q54jl_LLiXSOaSSGZQNDm9w==)
   at #=qKgrTK7xGiiM4vbusPi$3yMR7aaflot7crAEjt59qvOC341tihwMU_lfj3bMNxLov.#=qBniXPEZioo5XxV15kruNHg==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qqOkV04xY5tlzKq2dgCc$yw==, Boolean #=qJspNdO8asy3XFuXNXW0RMZ1xBOVyvEfalgZ4TnDxzq4=)
   at #=qNLJAyq_x8$6ipfK64TnRPjFTtZIHXJsAgath3FZHY36DVSyrxCIfQ4Kbkm45J5pK.#=q2$Ad$IL71oEaWtjIaknGYdrcRUJt_vajD0LU9fHA$14=(#=q108wQ_HGr3AX3vkfi2XSJg== #=qYN29chmN2je1R1xvygIUxA==, #=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qrkUN5Gvavs5fR65PRa7nvg==, Boolean #=qTp6XtMd2WEjDYqKDPAYpBKdsPSZVM7h9oz7wvcAs0hw=, List`1 #=q5IdMDO$IKez8B1lTNLDrjw==)
   at #=qNLJAyq_x8$6ipfK64TnRPjFTtZIHXJsAgath3FZHY36DVSyrxCIfQ4Kbkm45J5pK.#=qRc199r5JTTWl2w0Sg5WrKg==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=q27PLOG_R_1wFkw8i$iHjaA==, Boolean #=qA6s9mMr1Bu15CJTXsxGHZ1RauwffC2yC19bo13VgazE=)
   at #=qVbrkIxpXohgGdBuR3ulkwhONK1bfj5kwEV0kX9Z5WQQ=.#=q$xvi$SmChxFS1zJBpVK5vw==(#=qNbwa4gJtY7Rg8o8Ft7Rx4zaye14J9kf0naEj$M7vEcjNp4rVvFryxQ1QN6RfSXGq #=qqWE5lTvuo$c57hu_ietpqw==, Boolean #=qid6u0zP35W2XdvNNXHtkMj2X3XsLUGxJxmgdXfHKQWI=, Boolean #=qdW5yiJGeTAa3utEwCxTB$w==)
   at #=q8kqtwm6MvhEyFa8ivQJqq6jNzfz03Ut7vPjRe3IroNY=.#=q5aUbGAPlGw_K3iWDR8EnJIJ89UELvlPQF66oqXvOtjI=(Object #=qaMrrcv46xIxKAO06ob9c5g==)

Additionally, it seems that ALAC doesn't benefit by lossyWav, so maybe this option should be removed from encoding profiles.

P.S. The same is true for APE, so if you, Steven decide to add support for Monkey's Audio, you should not add lossyWav as an option too.
Last Edit: October 08, 2010, 12:14:46 AM by Antonski

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32034
this type of error means the encoder didnt generate the expected output file (I will make the error handling better so it displays a meaningful message)
did you use the default command line settings that came with MB? If you changed it as above i expect it wouldnt work

Antonski

  • Sr. Member
  • ****
  • Posts: 356
Both command lines didn't work, neither the default one nor the modified one (with pipe:0).
Does it work for you?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32034
not any more - thanks for letting me know! its incorrectly using the aac encoder so i will fix that