Author Topic: Not sure if new feature or bug  (Read 2741 times)

AntidoteYYMBR

  • Guest
Normally when you left click and hold a song to drag it to a playlist, it does just that. Now with Musicbee 3, when you click it tends to highlight all the other songs that you drag your cursor over. I have to left click and hold on the song for like 2 seconds to avoid this. Any thoughts?

boroda

  • Sr. Member
  • ****
  • Posts: 4595
its a new feature. but may it wold be better if this was an option.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34346
It is standard windows behavior eg. check windows explorer, but is inconsitently used by other players. Personally i hate it but i know many do make use of it.
I am going to add support for this for the next update:
<GUI_DisableRowAutoSelect>true</GUI_DisableRowAutoSelect>

you would need to edit MusicBee3Settings.ini and add it after the 3rd line (while MB is not running)

http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip
Last Edit: April 09, 2016, 10:34:54 AM by Steven

AntidoteYYMBR

  • Guest
I don't have a MusicBee3Settings.ini nor any .ini file in my MusicBee install. I tried using the download patch you sent me, but I wasn't sure what to do with it. I extracted it and copied the files into my MusicBee programs folder and relaunched but the highlight effect didn't change so I am thinking I did it wrong.

r2h

  • Newbie
  • *
  • Posts: 8
The MusicBee3Settings.ini you find in the AppData folder.

AntidoteYYMBR

  • Guest
Ok so my file looks like this:

<?xml version="1.0" encoding="utf-8"?>
<ApplicationSettings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<ENV_OrigSetPath>C:\Users\Alex\AppData\Roaming\MusicBee\</ENV_OrigSetPath>
<ENV_LibPath>C:\Users\Alex\My Music\MusicBee\</ENV_LibPath>
<ENV_PromptLib>false</ENV_PromptLib>

So I need to add it in between <ENV_OrigSetPath>C:\Users\Alex\AppData\Roaming\MusicBee\</ENV_OrigSetPath> and
<ENV_LibPath>C:\Users\Alex\My Music\MusicBee\</ENV_LibPath>??

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34346
search for GUI_DisableRowAutoSelect and change the value to true