Author Topic: GUI changes for v3.0  (Read 1247289 times)

redwing

  • Guest
What does that mean? Say you click on a track in the main panel from a music node and then click on inbox node. Track info panel keeps showing the same "selected track". Is that a display bug or not?

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
What does that mean? Say you click on a track in the main panel from a music node and then click on inbox node. Track info panel keeps showing the same "selected track". Is that a display bug or not?
the Track Info panel shows the last clicked track from the main panel or the playing tracks panel (no doubt if you try hard enough you will find some exception)
for hotkey actions that rely on the selected track, if no panel is in focus then MB uses the selected track in the main panel. So if the main panel or playing tracks is not in focus then there can be a difference between the track used for a hotkey action and whats displayed in the Track Info panel.
I wont change that behavior at this point in time

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
I'm a bit confused...are you saying the right main panel should always be visible in these panels, overriding any settings in the Panels Configuration? For me, the only panels that appear for Radio or Podcasts are the right and left sidebars. The right and left main panels are not displayed regardless of the configuration settings. Should this be functional? If not they should probably be disabled/greyed-out.
Radio and Podcasts use the track detail layout. You have the track detail layout configured with a panel override so that the right main panel is hidden.
The issue with the playing tracks panel not displaying correctly is fixed for the next update

sleepless

  • Sr. Member
  • ****
  • Posts: 287
Ah-ha, got it. I was using the "overrides for the current musicbee tab" setting in the layout editor. Thanks for the info.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

fixes for the above. Unzip into the folder MB is installed and run MusicBee.exe

redwing

  • Guest
@redwing, yes it is the case that MB sends all files if none are selected so i will change that.

Thanks for the change! It no longer happens.

I wont change that behavior at this point in time

I can see there are various use cases to consider. I'll think about that.

cmg

  • Jr. Member
  • **
  • Posts: 55
A bug similar to that I reported before (link is shown below) exists.
When I enable grouping and select genre from the library explorer, the number of albums is mistakenly counted at the lower right of the window.

previous bug: http://getmusicbee.com/forum/index.php?topic=15050.msg109111#msg109111

screen shot: http://i.imgur.com/0RdvhUg.png

redwing

  • Guest
On Tracks view with medium-size artwork, mouse-over glitch appears over rating. With small-size artwork or no artwork, it doesn't happen:



If you add both rating and album rating on Tracks view, rating doesn't show if you click on areas near to rating. Also auto-calculate album rating requires refreshing. Maybe it is intended album rating should not be added on this view, but I'm not sure.



On Album & Tracks view, if you add album rating under artwork and adjust each track's rating, auto-calculate album rating requires refreshing:
 

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
@redwing, the first is fixed for the next update. The other two glitches are a bit more tricky and i will leave them unsolved for v3

A bug similar to that I reported before (link is shown below) exists.
When I enable grouping and select genre from the library explorer, the number of albums is mistakenly counted at the lower right of the window.
thats fixed for the next update

redwing

  • Guest
Did you make any changes related to running milkdrop?
Recently I noticed whenever I try to run milkdrop MB crashes. But if I run another visualizer first and then switch to milkdrop, it works. But the color of milkdrop looks quite poor.
I tried old patches and the last stable one seems 5941. It runs without any problem and looks just the same as it used to.
Then I applied the latest patch again, sometimes it works fine, sometimes it crashes again. I wonder others can reproduce this too.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
no changes have been made to the visualiser or anything i can think of that is remotely related.
For myself i have always had occasional crashes with milkdrop

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
fixes for the items stated as fixed above
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

unzip into the folder MB is installed and run MusicBee.exe

redwing

  • Guest
no changes have been made to the visualiser or anything i can think of that is remotely related.
For myself i have always had occasional crashes with milkdrop

OK, maybe just its code is old and partly incompatible with latest OS patches.

hiccup

  • Sr. Member
  • ****
  • Posts: 7856
It feels a bit weird that the toolbar icons bar escape the bounds of the minimized MB panel when being 'unconsolidated'.


hiccup

  • Sr. Member
  • ****
  • Posts: 7856
When hovering over the years, the 'yyyy' gets a bold font, but the small single digits seem to change form a little bit, but not very nice or distinctive.
If possible it might be better to have them changing to bold also.