Author Topic: CD name within multi-disk albums  (Read 3362 times)

Novatlan

  • Jr. Member
  • **
  • Posts: 34
I have quite a lot of albums with multiple CDs. Most of these CDs actually have their own disc name. Right now I enter this additional "sub album name" in the grouping tag. What would be awesome would be a way to show the individual CD name above the tracks of that CD within musicbee. See https://dl.dropboxusercontent.com/u/104901/mb.JPG for a mockup.

In the example shown, the first 2 CDs are the original recording, CDs 3 and 4 are a re-recording, but they all belong to the same album. There currently is no place to enter this besides the grouping and there is no way to show it in the UI.

Another example might be (does not exists, just for showing what I mean)
"Disneyland Full Collection" (5 CDs).
CD1 Main Street USA
CD2 Adventureland
and so on.

Even though these discs all need to be in the same album, they each have their own disc name and it would be good to be able to show that name somewhere.

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3460
  • MB Version: 3.3.7367 P
This can already be achieved with the sub-grouping header.

There is a guide here on the 'Tips and Tricks' board.

Give a yell if you need any help in setting them up.
MusicBee and my library - Making bee-utiful music together

Novatlan

  • Jr. Member
  • **
  • Posts: 34
Wow - that is awesome!
I tried the instructions in the thread and when I use
$If(<Disc Count>>1,$IsNull(<Set Subtitle>,"• Disc "<Disc#>" •","• Disc "<Disc#>" • "<Set Subtitle>" •"),$IsNull(<Set Subtitle>,,"• "<Set Subtitle>" •"))
as a virtual tag, MB complains that "The virtual tag could not be analyzed". I copied it from the forum post, so I'm pretty sure there is no typo.
Also - maybe I'm dumb, but I can't find a place to set this "Set Subtitle" tag.

Pingaware

  • Hero Member
  • *****
  • Posts: 1090
Also - maybe I'm dumb, but I can't find a place to set this "Set Subtitle" tag.

It's a custom tag you need to have set. That will also be why MB can't parse the virtual tag.
Bold words in my posts are links unless expressly stated otherwise. Have fun with them!

Novatlan

  • Jr. Member
  • **
  • Posts: 34
Aah. I found out what it was: The tag names are localized! I need to use German tag names.

Carmilien

  • Newbie
  • *
  • Posts: 7
Hello,

I'm sorry to bother you but I can't configure the sub-grouping header despite reading the topic https://getmusicbee.com/forum/index.php?topic=11990.0 and numerous tests.
For example, I would like to separate this album from Dropkick Murphys which is in 2 cds and name each cd, "Going Out In Style" for the first one and "Live At Fenway" for the second :





Can you please help me configure this feature?

The Incredible Boom Boom

  • Jr. Member
  • **
  • Posts: 26
You need to set up the Virtual Tag in order to use the code you pasted and then also make sure that the Virtual Tag is pointing to the correct tags in your files.

Carmilien

  • Newbie
  • *
  • Posts: 7
Thank you very much for your response. I changed MusicBee language in English because I couldn't find the "Set Subtitle" field in French (does anyone know the translation of this field into French?)
I still have one problem: Why does "Disc 1 - CD" also appear in the place I circled in red? :



I have tagged the first cd of the album "CD" and the second cd "Live" :



and they are well separated in the album display but I don't understand why MusicBee also writes the tag of the first cd on top of the album.

Here the configuration of my pannel Album Covers :



Can you help me with this last problem ?

PS :
It works in Album and Tracks view :



But I would like to keep the Album Covers view :D
Last Edit: March 10, 2020, 09:43:31 PM by Carmilien

The Incredible Boom Boom

  • Jr. Member
  • **
  • Posts: 26
in your third screenshot, in the "View Configuration" settings panel, you have <Virtual1> set as a "sub-grouping header." Blank that and it will remove the tag from above the album art.

Carmilien

  • Newbie
  • *
  • Posts: 7
in your third screenshot, in the "View Configuration" settings panel, you have <Virtual1> set as a "sub-grouping header." Blank that and it will remove the tag from above the album art.

Apparently not, if I blank that, it looks like this:



And it's the opposite result that I want.
Last Edit: March 11, 2020, 08:14:51 PM by Carmilien

The Incredible Boom Boom

  • Jr. Member
  • **
  • Posts: 26
I should've paid more attention to what you were asking - my bad. That being said, I've never used that view before, so I don't quite know what is going on. Maybe someone who has more experience with it can assist.

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3460
  • MB Version: 3.3.7367 P
@ Carmilien
You're using the virtual tag:
Code
$If(<Disc Count>>1,$IsNull(<Set Subtitle>,"• Disc "<Disc#>" •","• Disc "<Disc#>" • "<Set Subtitle>" •"),$IsNull(<Set Subtitle>,,"• "<Set Subtitle>" •"))
This will always display • Disc # • for any multi-disc album with or without a <Set Subtitle> tag.


If you want to display just the <Set Subtitle> and not the Disc#, change the vitual tag to:
Code
$If(<Disc Count>>1,$IsNull(<Set Subtitle>,"• Disc "<Disc#>" •","• "<Set Subtitle>" •"),$IsNull(<Set Subtitle>,,"• "<Set Subtitle>" •"))
MusicBee and my library - Making bee-utiful music together

Carmilien

  • Newbie
  • *
  • Posts: 7
@The Incredible Boom Boom
Thank you for your help anyway!

@Bee-liever
I changed the tag to yours but the problem is that I'd like the subtitle to appear in the album (green circles) but not on top of the album cover (red circle) :


Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3460
  • MB Version: 3.3.7367 P
@Bee-liever
I changed the tag to yours but the problem is that I'd like the subtitle to appear in the album (green circles) but not on top of the album cover (red circle)

I should've paid more attention to what you were asking - my bad.
Guess that applies to me too!

Check your 'Group By' settings for that view.
Maybe your 'Sub Grouping' is set to your 'Virtual1' tag?
MusicBee and my library - Making bee-utiful music together

Carmilien

  • Newbie
  • *
  • Posts: 7
Yes! You guys are great!
My "Sub Grouping" was set to "Virtual 1" tag, my bad.
Thank You very much for your help!
I'll be able to get busy retagging my music library in the next few weeks as I'll be stuck at home teleworking because of the coronavirus  ::)
Last Edit: March 13, 2020, 09:31:46 AM by Carmilien