Author Topic: Music Stuttering  (Read 4110 times)

Tahn

  • Guest
Hi all,

Problem: Music stutters every now and then. Gets stuck in a continuous mini-loop that lasts from 1 second to 20.

I've uninstalled a majority of programs from my laptop so only the bare process are running and just MusicBee. Basically dedicating my old laptop to MusicBee. MusicBee version: 2.4..4504. The computer is Intel 2.13ghz, 2gb RAM, Windows 7.

I've also tried increasing the buffer in the preferences to no avail.

Any suggestions/assistance would be appreciated!


Pingaware

  • Sr. Member
  • ****
  • Posts: 1111
First, try updating to the latest patch to see if that helps.
Bold words in my posts are links unless expressly stated otherwise.

MeeMeeMee

  • Full Member
  • ***
  • Posts: 235
I'm experiencing the same thing. I'm playing my FLAC library from a low-end NAS (DNS-323) over LAN (1Gbit, Wired - not wireless) to my Win7 SP1 64bit i5-3470, 8Gig PC.
In Preferences, under Player I have the following checked:
Use HW Mixing
Use 32 bit output
increase buffer size
I'm guessing that if the buffer was bigger this problem could be so infrequent to the point of disappearing altogether.

I'm using the latest MB v2.4.5404
MusicBee 3.5.8516 / Windows 10 (64-bit) / Intel i5-3470 / 8GB RAM
Media on NAS (CIFS share)
20K+ tracks, predominantly FLAC ; converted to mp3 (lame -V 0) when synced to a Cowon D2+
________________________________________________________________________________________________
Get the latest patch: https://getmusicbee.com/patches/

Pingaware

  • Sr. Member
  • ****
  • Posts: 1111
That's not the latest version. See the underlined link in my post.
Bold words in my posts are links unless expressly stated otherwise.

MeeMeeMee

  • Full Member
  • ***
  • Posts: 235
OK. I "updated" to v2.5.5575.
It's still happening. Most notably during the startup scan (includes folders on the NAS where the media is playing from) but also when the scan is done.
MusicBee 3.5.8516 / Windows 10 (64-bit) / Intel i5-3470 / 8GB RAM
Media on NAS (CIFS share)
20K+ tracks, predominantly FLAC ; converted to mp3 (lame -V 0) when synced to a Cowon D2+
________________________________________________________________________________________________
Get the latest patch: https://getmusicbee.com/patches/

Pingaware

  • Sr. Member
  • ****
  • Posts: 1111
Steven's general response is to try turning off each setting one at a time to see if that fixes it, and then if that doesn't, to try combinations. What happens if you do that?
Bold words in my posts are links unless expressly stated otherwise.

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9388
OK. I "updated" to v2.5.5575.
It's still happening. Most notably during the startup scan (includes folders on the NAS where the media is playing from) but also when the scan is done.
Have you increased the buffer size?  Edit > Preferences > Player > increase buffer size

Another thought - is the NAS set to sleep after x minutes of inactivity?  Could be that the drive is slow in starting up. 
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34408
Also try disabled "check for updated files" and "remove dead links" on startup in the library preferences as those involve a lot of disc activity

MeeMeeMee

  • Full Member
  • ***
  • Posts: 235
Have you increased the buffer size?  Edit > Preferences > Player > increase buffer size
Yes I have, as I wrote in my reply above. You can see there other settings I use that I thought might be relevant to performance).

Another thought - is the NAS set to sleep after x minutes of inactivity?  Could be that the drive is slow in starting up.  
To be more accurate, the HDDs are set to sleep (not the NAS) after some period (=minutes) of inactivity, yes. But that is, certainly not the reason for the problem as it happens WHILE the music is playing, i.e. while the drive is being accessed.

Also try disabled "check for updated files" and "remove dead links" on startup in the library preferences as those involve a lot of disc activity
No doubt that might help during the scan. Since I don't make changes frequently I just turn this off altogether and perform manual scans whenever necessary. Still, correct me if I'm wrong, Steven, this doesn't address the issue of stuttering when the scan is finished (which is far less frequent).
Is there any config file I can manually edit to tweak the buffer size? I don't imagine there's some method to monitor the buffer water mark, either in real time or in a log file?

Edit: forgot to thank you for taking the time and trying to help me with this issue.
MusicBee 3.5.8516 / Windows 10 (64-bit) / Intel i5-3470 / 8GB RAM
Media on NAS (CIFS share)
20K+ tracks, predominantly FLAC ; converted to mp3 (lame -V 0) when synced to a Cowon D2+
________________________________________________________________________________________________
Get the latest patch: https://getmusicbee.com/patches/