Author Topic: UPnP/ DLNA device support  (Read 148504 times)

lodiped

  • Newbie
  • *
  • Posts: 2
I'm using this with ChromeCast and for some reason the songs always cut off a second in the beginning and another at the end. It's really annoying and I can't find anyone with the same problem. What settings could be impacting this?

zehuti

  • Newbie
  • *
  • Posts: 3
First of all - thank you for very good media player and DLNA plugin! I tried a lot of media players and MB is the best imo. 👍

But... there is that but with bugs 😁

Not sure if its MB or plugin related.


Over time in "Output to" new lines with same DLNA player is added. Even if MB is idling without anything playing. In DLNA plugin server and play to is enabled.

When MB is set Output to DLNA player. Choosing song on the phone from MB Media Library, file streamed as PCM. But if MB is set Output to Primary Sound Driver. Then file streamed as is - FLAC M4A MP3...

Playing to DLNA player from MB is always in PCM 44.1 kHz / 16 bit no matter what is set in settings.

MB version 3.3.7252
UPnP/ DLNA plugin from  25.06.2019





some lines from log

5; 1 Initialise - 09.11.2019 23:33:34
106; 2 GetNetworkAddresses - 192.168.2.1,dns=True,name=Wi-Fi,speed=300000000
117; 3 GetNetworkAddresses - 127.0.0.1,dns=False,name=Loopback Pseudo-Interface 1,speed=1073741824
127; 4 GetNetworkAddresses - http://192.168.2.1:21038
178; 5 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
1585; 6 Profile - DENON, useragent=LINUX UPnP/1.0 Denon-Heos/147202
11120; 7 Profile - DENON, useragent=Shares User defined folders and files to other Universal Plug and Play media devices.|LINUX UPnP/1.0 Denon-Heos/147202
11131; 8 Profile - DENON, useragent=Shares User defined folders and files to other Universal Plug and Play media devices.|LINUX UPnP/1.0 Denon-Heos/147202
11168; 9 Activate - ACT-Denon AVR-X1400H:
11903; 10 Profile - Generic Device, useragent=libcurl-agent/1.0
11920; 11 ProcessRequest:HttpException:404 - Bad parameter
17842; 12 Play - D:\Music\flac\Simply Red - Greatest Hits (1996)\01. Simply Red - Holding Back the Years.flac (http://192.168.2.1:21038/encode/053C8DBDF4AF1361-2147483643.L16)
17893; 13 Profile - Generic Device, useragent=AvegaMediaServer/2.0 Linux/2.6
17956; 14 Profile - Generic Device, useragent=AvegaMediaServer/2.0 Linux/2.6
17967; 15 GetEncodedFile[1] 192.168.2.1 - GET D:\Music\flac\Simply Red - Greatest Hits (1996)\01. Simply Red - Holding Back the Years.flac to 192.168.2.43; mime=audio/L16;rate=44100;channels=2,rate=44100,channels=2
18509; 16 StateTimer - Playing,old=Loading
18957; 17 Profile - Generic Device, useragent=libcurl-agent/1.0
42694; 18 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
42798; 19 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
52193; 20 Profile - DENON, useragent=LINUX UPnP/1.0 Denon-Heos/147202
52220; 21 Browse - 0,BrowseDirectChildren,0,20,sort=
102691; 22 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
102795; 23 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
162691; 24 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
162793; 25 ProcessMessage 192.168.2.43 - device 'uuid:4e85d473-636b-1031-0080-0005cdca56be:ACT-Denon AVR-X1400H',valid=True
Last Edit: November 09, 2019, 10:40:28 PM by zehuti

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
Over time in "Output to" new lines with same DLNA player is added. Even if MB is idling without anything playing. In DLNA plugin server and play to is enabled.
are you willing to run a debug version of the plugin?

zehuti

  • Newbie
  • *
  • Posts: 3
Over time in "Output to" new lines with same DLNA player is added. Even if MB is idling without anything playing. In DLNA plugin server and play to is enabled.
are you willing to run a debug version of the plugin?

Sure! I will gladly help to make it better. Just tell me what and how to.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
Sure! I will gladly help to make it better. Just tell me what and how to.
I wont be able to do anything for a couple of days, however I already had made a couple of changes, so could you re-download the link from the first post to see if it helps. Make sure MB is closed when you replace the plugin dll

zehuti

  • Newbie
  • *
  • Posts: 3
Quote
I wont be able to do anything for a couple of days, however I already had made a couple of changes, so could you re-download the link from the first post to see if it helps. Make sure MB is closed when you replace the plugin dll

Still the same. New lines with DLNA player is added even if i just open MB and AVR is just idling. Also tried with clean MB portable.