Author Topic: Autocomplete Enable/Disable  (Read 4111 times)

pauljwk

  • Guest
Is there a way to disable autocomplete when editing in the main panel (or anywhere).
I'm trying to enter tag values in a column in the main screen.
I used to be able to enter a value, then press the down key to save and edit the next record.

Now, the autocomplete appears and the down arrow simply selects the matching value. I have to press enter then slow double click in the next cell down. Quite a bit more effort.

It would be handy to be able to disable the autocomplete feature, but I cannot find a setting anywhere.

Anyone know how to change this behaviour?

WolfFhang

  • Newbie
  • *
  • Posts: 1
I've been having this issue for a bit as well with the newest version. Not sure how to turn it off but would love to know how to since it's making my sorting a bit of a hassle at times.

LordFigTree

  • Guest
Bumping this, i've been having this issue a lot with the latest version too, huge pain when editing full albums and it suggest the original title all the time, would love to turn it off.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33447
i dont mind making a change to address this but i am confused by the statement that this is a new issue. Trying with MB v2.3 i dont see any obvious difference in this behavior so can one you give me a clear explanation why the v2.4 behaviour is suddenly an issue?

Lunatic

  • Guest
Maybe the auto complete feature was blocked by antivirus or firewall or not properly executed in 2.3. idk (have used Musicbee since long before) i just know that typing in multiple artist, title, etc. entries became really tiresome because when you cut something out from the title for example (ft. <artist>) it immediately enters the same text which has just been cut out. So the cut becomes a copy. Also deleting brings the same result.

A roundabout way was to go into "auto tag album" and make the changes there if it has found the album and the info is nearly the same.
Did anyone say it being a 2.4 behaviour? It is just there and it is annoying. Maybe someone could fix this?

Another problem is the cover art implementation in the "auto tag album" dialog behaves differently. When you choose "Select picture" to select a picture from disk it opens a default directory. When you click the same option in the main program it opens the folder currently being in use. (The logic way) Would be nice if it would behave in the "Album Auto Tagger" the same way.

In the Album Auto Tagger the album artist is "often" not selected even though the checkmark in the options is on. And i want to always replace every info in the <album artist> tag so i have to check every time if the checkmark is on or not. It's the only case that behaves different than the others. (Except from the lyrics which are never added)


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33447
i dont get that behavior and see no reason for it to occur. Are you using v2.5 from the first forum topic?

pauljwk

  • Guest
Steven,

Thanks for engaging with this topic.
I've just installed 2.5 RC2 and the autocomplete behaviour is the same as 2.4 which was different from 2.3.
In order to replicate the issue: in the main window simply edit an empty cell. As you type, the autocomplete drop box appears. now press the down key. In 2.3 this last keypress (down arrow) performs a 'save cell, next record, edit cell' sequence. in 2,4 & 2.5 the down key engages the autocomplete drop box.

So imagine you are entering a list of Highest Position values in a long list of singles from Top 40.
the records would appear thus:
Title              Artist     Album         Year     HP    Weeks
Juniors Farm   Wings     Hit Parade   1975
Only You       Ringo S   single          1975   
......

So you are editing 1st record - HP and you enter '0' the drop box appears and 01 02 03 04 05 06 07 08 09 are available. then you key 9 (making the entry 09) and the drop box has shrunk to 09.
The next key is the critical one.
In 2.3 the down key will save and move down to the next record with an open edit in HP and the 09 having been saved in the previous record.
In version 2.4 & 2.5 the down key event engages the drop box focus instead of the 2.3 behaviour of: save; next; edit.

So in 2.3 you would edit HP cell and type 09, down, 07, down, 23, down....
In 2.5 the same outcome requires 09, enter, mouse slow double click on next record, 07, enter, mouse slow duble click on next record, 23, and so on.

Hope that makes sense. Certainly my solution is to use version 2.3 for my Top 40 chart data entry and later version for general activity.

BTW Music Bee is awsome and I really don't want this tiny issue to be taken as a critisism in anyway. Also note that not too many people are engaging with this topic or experiencing this as an issue, But I thought I'd try to expain it anyway.
Paul

Lunatic

  • Guest
Thanks to pauljwk for this detailed description of the problem.
It's nice to see that there is some concern about that.

What's worse is when you are in "edit mode" (with the additional register) and try to cut something from the title to paste it in the artist tag.

Let's say, for example:
Title:   5 Fingas Of Death &(=ft.) Big L
Artist:  Diamond D

And you want it to be:
Title:   5 Fingas Of Death
Artist:  Diamond D & Big L

When you cut: "& Big L"

the entry is at first autofilled with the cut entry which can be deleted with the DEL Key but after that comes the most annoying part.

When pasting it to the artist tag and if there already is an existing tag from another song it autocompletes:

Artist: Diamond D & Big L & Fat Joe & Lord Finesse

so i also have to 1st mark and 2nd delete the autofilled "& Fat Joe & Lord Finesse" again!

When there are a lot of entrys to edit: It becomes a daytime job and for the large library i own, this really is no tiny issue.

It would be so nice to have a button to turn autocomplete/autofill off or a checkmark in settings to do that.
(btw. after editing over 3000+ i began to hate it so much  :'( )

PS: In normal mode it would be nice to switch the tag entries from left to right. So one can jump from title to artist and back.

cynflux

  • Jr. Member
  • **
  • Posts: 76
Any update on this?
I have got some erroneous entries that I would love to remove from the drop-down when editing tags.
Thank you in advance.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8159
Any update on this?
I have got some erroneous entries that I would love to remove from the drop-down when editing tags.
Thank you in advance.
If I understand the issue correctly, the fact that they're in the drop-down means it exists in the tag. Say you're editing the Title tag and you want "It's Only Rock 'n Roll" but as you type you see "It's Only Rock And Roll". That's coming from a Title tag that has that data in it. So do a Custom Search using Title IS It's Only Rock And Roll" which you display the tracks that are not the way you want. Edit those tracks, save the change, exit and restart MB. Edit any track (as a test) and start entering "It's Only Rock" and you should see that "It's Only Rock And Roll" doesn't appear. If it does, you missed one when editing.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.