Author Topic: Please restore the Toolbar button spec!  (Read 2371 times)

butty

  • Sr. Member
  • ****
  • Posts: 435
[Moved from wishlist and edited.]
From 2.4.5316, the Toolbar button spec has been changed. And I feel it very unuseful.

I have assigned "Playback: Replay Gain Toggle" function to a button.
Old versions worked well (one of four labels is displayed showing replay gain state), however, this version just assumes ON and OFF of each button.
And, the button works somewhat odd: button text does not match with actual replay gain state: always both ON and OFF labels.

Old versions:
- Can assign more than two button labels.
- Displays one of multiple button states.

Current version:
- Can assign only two button labels.
- Cannot display button states.

So, please restore the Toolbar button spec to the previous version.

Regards.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33268
- Can assign more than two button labels.
i am not sure what you mean by this point, but i see there is a bug where it isnt showing the replay gain text. Thats fixed for the next v2.4 update and hopefully it addresses your first point

butty

  • Sr. Member
  • ****
  • Posts: 435
Thanks for the reply.

- Can assign more than two button labels.
i am not sure what you mean by this point, but i see there is a bug where it isnt showing the replay gain text. Thats fixed for the next v2.4 update and hopefully it addresses your first point

I would like to make an explanation: Older versions can assign more than two button labels when the button function is Replay Gain Toggle, such as "Off", "Album", "Track", and "Smart".


butty

  • Sr. Member
  • ****
  • Posts: 435
Thanks for the patch.
now, the button works well for Replay Gain Toggle function.