Author Topic: Radio, Import Stations, OPML file - nothing happens  (Read 8247 times)

fredbloggs

  • Guest
I'm using version 2.3.5188.
When right clicking on Radio and then choosing Import Stations, I tried a couple of OPML files and nothing happens.
I'd expect a bunch of stations to appear in the main panel.
An example of the OPML file I tried is here:
http://blog.koenvermoesen.be/2013/02/25/musicbee-di-radio-station-list/

Any ideas?

ma_t14

  • Hero Member
  • *****
  • Posts: 2491
I managed to get it to work with the example you posted, but you need to restart MusicBee for the list to appear.

Also try using the latest version which currently is 2.4.x, read more here: http://musicbee.wikia.com/wiki/Latest_Update

fredbloggs

  • Guest
You're right, I got that example to work after a restart too.
But trying to import after that makes everything disappear again.
Also, the file I'm trying to get working doesn't work even after a restart: http://freezone.iinet.net.au/freezone-radio-playlist.opml

I installed 2.4.5227 and confirmed the issue happens in that version as well.

Bug?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32732
i wont have time to look at this for a few days but as a guess it sounds like a bug and you might need to edit the tags on a library music file so MB knows to save the library cache.

fredbloggs

  • Guest
I'm not sure what you mean by "edit the tags on a library music file". For example, the following is the start of an OPML file. What would I need to edit to get this to work? Or alternatively, can I change registry/files manually as a work-around?

<?xml version="1.0" encoding="ISO-8859-1" ?>
<opml version="1.1">
   <head>
         <title>Freezone Radio Streams</title>
         <dateCreated>Feb 29 2000 03:33:33 GMT</dateCreated>
         <dateModified>Jun 14 2011 02:25:00 GMT</dateModified>
         <ownerName>Freezone</ownerName>
         <ownerEmail></ownerEmail>
   </head>
   <body>
        <outline text="Channels from around the Net">
            <outline text=".977 The 80s Channel" type="audio" url="http://radio1.internode.on.net:8000/4#slim:noscan=1" />
            <outline text=".977 The 90s Channel" type="audio" url="http://radio1.internode.on.net:8000/198#slim:noscan=1" />

Pingaware

  • Hero Member
  • *****
  • Posts: 1100
I'm not sure what you mean by "edit the tags on a library music file".

What Steven means is, after you've imported the station, edit the tags on a music file within your MB library. This will make the library update its cache. (And maybe exit MB afterwards just to make sure.)
Bold words in my posts are links unless expressly stated otherwise. Have fun with them!

fredbloggs

  • Guest
Thanks, tried that, but didn't seem to make any difference.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32732
its adding the files as music files instead of radio stations. I have fixed that for the next v2.4 update but that might be several days