Author Topic: Track Previewer  (Read 25356 times)

holuschi

  • Jr. Member
  • **
  • Posts: 79
I do not understand where I can activate  the plugin with right click, I do not find "Enble Track Preview Mode" and " Suspend Track Preview Mode" . I could find the hot key commands and the toolbaar commands but only "Enble Track Preview Mode" is working. I can only stop preview mode by restart of MusicBee. What I am doing wrong?

aldredd

  • Newbie
  • *
  • Posts: 18
I do not understand where I can activate  the plugin with right click, I do not find "Enble Track Preview Mode" and " Suspend Track Preview Mode" . I could find the hot key commands and the toolbaar commands but only "Enble Track Preview Mode" is working. I can only stop preview mode by restart of MusicBee. What I am doing wrong?


right click in the 'now playing' queue area --> Preview Mode --> Enable Track Preview Mode

holuschi

  • Jr. Member
  • **
  • Posts: 79
I do not understand where I can activate  the plugin with right click, I do not find "Enble Track Preview Mode" and " Suspend Track Preview Mode" . I could find the hot key commands and the toolbaar commands but only "Enble Track Preview Mode" is working. I can only stop preview mode by restart of MusicBee. What I am doing wrong?


right click in the 'now playing' queue area --> Preview Mode --> Enable Track Preview Mode

I click right but I cannot find "Preview Mode", Plugin is enabled.

ma_t14

  • Hero Member
  • *****
  • Posts: 2296
@holuschi

You probably need to set up the offsets in the plugin settings.


On the matter of offsets, I have a few suggestions.

I think it would be better if the offsets were calculated in percentages instead of seconds. This would eliminate any possible discrepancies between short and long tracks. The durations would still be calculated in seconds for the sake of having a consistent length for each preview.

Additionally, when previewing a track I think it would be even better to add an additional offset that would read, for example "middle of track", which would be fixed and you would only have to choose the duration. Having three different sections (beginning, middle, ending) would actually give a much better insight into what a track is all about when previewing it.

Thoughts?

holuschi

  • Jr. Member
  • **
  • Posts: 79
@holuschi

You probably need to set up the offsets in the plugin settings.

I have set up  plugin settings exactly as Steven did in his screenshot. The problem is the same: I do not find "Preview Mode" with right click  and I cannot suspend the track preview mode when I started it with Hotkey or Toolbaar button command.

ma_t14

  • Hero Member
  • *****
  • Posts: 2296
Hm, the only other thing that comes to my mind, are you using the latest 2.4 version?

ssergey

  • Newbie
  • *
  • Posts: 5
I use the latest version and do not see any of the item, although it is the list of plugins

Pingaware

  • Hero Member
  • *****
  • Posts: 1090
By latest version, do you mean the latest patch (currently 2.4.5310)? You can check in help - about. Don't be offended by me questioning you - lots of people think they have the latest version when they don't because there are usually three different releases at any one time.
Bold words in my posts are links unless expressly stated otherwise. Have fun with them!

ssergey

  • Newbie
  • *
  • Posts: 5
yes, the last one, just specifically checked - 2.4.5310. In the list of plugins this plugin is included and the playing time is written there

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31537
it doesnt show in the menu when the now playing list is docked in the main panel - this will be fixed in the near future. Not sure why the hotkeys wouldnt work in this case though

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31537
this should be fixed with the latest patch version:
http://musicbee.niblseed.com/V2_4/MusicBee_Exe_Patched.zip

unzip and replace the existing files


holuschi

  • Jr. Member
  • **
  • Posts: 79
Thank you, I can see Preview mode now and it works fine in that mode, it is not important for me to use the hotkeys.

puruff

  • Newbie
  • *
  • Posts: 1
Than you so mutch for this plug-in. It works wery well for me. I hope you will continue to work with it är uppdate it.

Best Regards
Marcus

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31537
Than you so mutch for this plug-in. It works wery well for me. I hope you will continue to work with it är uppdate it.
i was not planning any further updates. What do you think is missing?