Author Topic: Using MusicBee on multiple computers  (Read 25082 times)

garay

  • Jr. Member
  • **
  • Posts: 56
Ticked show hidden files and went through all my library sub folders and deleted the thousands of files that windows had created while using media player, plus some not hidden. Not needed after using MB to imbed all info and album art. No harm leaving them there, but did create some extra space. Also noticed that when I would copy files to my MP3 player, all the hidden files where going as well, definitely don't need them there.
Another hiccup I've picked up is that when I imported my windows media player playlists into MB, (every music file I have is in at least one playlist), nearly 500 individual songs out of 4350 didn't show up in the various playlists. Extensive cross checking has identified the missing songs.

garay

  • Jr. Member
  • **
  • Posts: 56
Successfully running MB on second computer for a while now. Just recently bought an Asus tablet running windows 8.1. After much trial and error have got MB working with all my files and artwork showing under music, but trying to get playlists working is another story. Due to the Asus only being 64g, I bought a 64gb sd card and transferred all my music files onto that. The MB folder that contains app data and the playlist folder is on C drive (the card is D drive). The playlists show up, but a percentage of the files in each playlist (15 playlists) have the blue exclamation mark next to them. Also, every time I try to open a playlist, I have to tap it several times, and then it takes a couple of minutes for the playlist to open. Also trying to open or scroll through a playlist just opened can cause ghost screen and the message that the program is not responding, do you want to close or wait. There's something not right somewhere but I just can't find it.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33113
i made some changes for playlists in v2.4 from the first topic on the forum so you might try that to see if things improve (espcially long opening time for playlists with files that no longer exist)


garay

  • Jr. Member
  • **
  • Posts: 56
I'm running the same MP3 folder and playlist folder on each PC. The playlist folder works fine on the second PC regardless if I copy and paste it or sync it using AJC, the only difference on the notepad is that the MP3 folder is on the sd card and the playlist folder is on the C drive. But if that was the problem, why is at least 50% of each playlist correct, to me it should be all or nothing, it doesn't make sense.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
I'm running version 2.4.5227

The latest beta is 2.4.5270.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)


garay

  • Jr. Member
  • **
  • Posts: 56
Still the same, as soon as I try to open any playlist, the problems start. Is there anywhere I can download a full 2.4.5270 version and start afresh. I should be able to just copy my playlists from the MB folder on another PC and they work! I don't know what I could be doing wrong, I had so much trouble trying to get it to work on the second PC, and now going through it again, great program but its wearing me out.

Alumni

  • Hero Member
  • *****
  • Posts: 1007
My current setup has been working fine for a while, with no problems.
Our situation is a bit different though, the laptop reads the music library of the desktop PC, and its playlist folder is mirrored via symbolic links.

garay

  • Jr. Member
  • **
  • Posts: 56
We go overseas every year for 7 weeks and I take a laptop with me to be able to play my music as well as internet etc. while we're traveling, that's why I need to have it standalone. I'll try a clean install of MB later today and follow Bee-lievers posted checklist from a few months ago.

garay

  • Jr. Member
  • **
  • Posts: 56
Just did a clean install, copied appropriate folders and files from PC1 to new tablet PC. Music library spot on, but playlists have same problem as before. Each playlist indicates the correct number of files in it, but a percentage in each playlist have the blue exclamation mark, eg: 30/156, 38/118, 28/98, 43/282. I've rescanned playlists and library over and over, recopied playlist files from PC to PC, same every time. Looks like have to reconnect them manually unless someone has a better suggestion. 

garay

  • Jr. Member
  • **
  • Posts: 56
Finally found the problem.
MB music library files on PC1 have a directory of C:\users\geoff\music\MP3's\
Playlist files are a mixture of same directory plus \\office\my music\MP3's\, both directories work in playlists.

MB music library files on tablet have a directory of \\notepad\d\MP3's, d being the sd card where the files from PC1 were copied to.
Playlist files are a combination of  \\office\my music\MP3's\, which work and show up correctly,
and C:\users\geoff\music\MP3's\, which show up as missing, blue exclamation mark.

MB on PC2, that I sync playlists and music library to from PC1 works fine.

I've got no idea how all that happened, and why the different directories work on PC1 and 2, but not the tablet, over my head. But at least I now know why some playlists files won't play. If that helps anyone come up with a suggestion on how to fix the playlists, much appreciated, otherwise it's the old manual fix, one at a time.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
I've got no idea how all that happened, and why the different directories work on PC1 and 2, but not the tablet, over my head. But at least I now know why some playlists files won't play. If that helps anyone come up with a suggestion on how to fix the playlists, much appreciated, otherwise it's the old manual fix, one at a time.

You could do a search-and-replace of the directory path in the playlists using something like Notepad++.  In fact, Notepad++ could do all files at once.  Still manual, but much quicker than one track at a time.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

garay

  • Jr. Member
  • **
  • Posts: 56
Thanks for the advice scampbll, I had a look at Notepad++, but with my very long but limited computer experience I think I'd probably dig a bigger hole attempting to use that. I have my IT friend coming around soon to set up a few things on my tablet before I head OS, I'll see if he can setup Notepad++ for me. I suppose the upside is that I eventually found the problem,  I don't give up on something, even if it means a lot of trial and error, I must have spent nearly 20 hours trying to get MB running on my tablet over the last few weeks, but, that's how you learn.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
Kudos for persistence!
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)