Author Topic: "copy source files into the library" setting no longer supported  (Read 11259 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32922
As of v2.3, the "copy source files into the library" for auto-organised libraries is no longer supported and will be disabled. This is mainly because it causes files to be duplicated for a number of users and as a fool-proof solution cant be implemented, the setting will no longer be supported. It also had a bug where in certain setting combinations it didnt copy the files and to fix would make the duplication problem worse.

For those of you who do use this setting, understand how it works and didnt have files being duplicated, you can re-enable the function by amending the following setting in "MusicBeeLibrarySettings.ini" which is located in the root music folder for each library you have.

<OrganisationLibraryCopySourceFiles2>false</OrganisationLibraryCopySourceFiles2>
change to
<OrganisationLibraryCopySourceFiles2>true</OrganisationLibraryCopySourceFiles2>

You need to have the latest v2.3 update installed and have run it at least once, where you would have received a message saying the setting has been disabled, and then exited MusicBee so the above entry in the settings file is created.
Last Edit: February 09, 2014, 06:32:42 PM by Steven

Simpuhl

  • Guest
I would like a COPY instead of just MOVE.

Ill follow your instructions,
Thank you

Simpuhl

  • Guest
This worked perfectly,

Just make sure you have MusicBee closed when you do it.

The first time I had it open, I did them modify and then closed and reopened and it reset the setting.

prscustom

  • Newbie
  • *
  • Posts: 4
Hello,

I've been using MB for years and recently updated it to ver 2.3.
I had problem first with 'not copying to the desginated hard drive that it used to' but found this thread, follow the instruction, and the problem solved.
But, a couple days ago I upgraded my PC with newer ssd, installed Windows 7, installed MB ver 2.4.
Followed the instruction exactly that I once already did, but nothing happens. Could someone please help me?

What  I used to do and want to have now is this.

1. I always reorganize the mp3 files with Mp3tag program in a different folder.
2. Then I add those mp3 files to MB library which is located to another hard disk drive.
3. MB duplicate those files to library.
4. I erase the mp3 files in my work folder.

I have about 5TB of mp3s to add into MB library. I bought new 6TB hdds. I want these mp3s moved into new 6TB hdd and be added to MB library.
What should I do?

Thanks for reading.

JY

redwing

  • Guest
If you want it auto-organized, consult the following thread: http://getmusicbee.com/forum/index.php?topic=12336.msg77529#msg77529
If not, you could just add those files in the new HDD to your library.

prscustom

  • Newbie
  • *
  • Posts: 4

Tried again with v2.4 and failed.

Back with v2.3 and it is working fine.

I think I should stick to v2.3 for the moment.

Thanks anyway.

JY

drawersystem

  • Guest
was this the same as itunes "Add items from your computer to your iTunes library"

BoringName

  • Jr. Member
  • **
  • Posts: 56
<OrganisationLibraryCopySourceFiles2>false</OrganisationLibraryCopySourceFiles2>
change to
<OrganisationLibraryCopySourceFiles2>true</OrganisationLibraryCopySourceFiles2>

This no longer works which is disappointing, it was a good feature in iTunes. That sweep feature setting should be removed if it doesn't do anything, I wasted a good half an hour today trying to get it to work only to find out it doesn't do anything. I should have read to the bottom of the thread...

I just liked it because it would auto create the folder structure based on the song tags. Now I have to browse to the music folder, create the artist folder if it doesn't exist, then the album folder, then paste the songs which also might need to be renamed, then import.

I realise there were issues with it doubling songs when autoscan was enabled but wouldn't the solution be to just check if the destination folder was a folder/subfolder of a folder in the autoscan list and depending on the result do one of the following -
Folder in the autoscan list - Create the folder structure specified and move the songs to it, don't import them into the library, let the autoscan do it.
Folder not in the autoscan list (or autoscan not used) - Create the folder structure specified and move the songs to it. Add them to the library.

Either way, I think it should be fixed or removed so as not to confuse users.


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32922
Its still supported so can you provide the steps you took and what you were expecting.

edit:
i can see that it can re-copy the file over and again - is that what you are seeing?
Last Edit: June 04, 2022, 05:39:04 AM by Steven

BoringName

  • Jr. Member
  • **
  • Posts: 56
Its still supported so can you provide the steps you took and what you were expecting.

I had a folder on the desktop with a bunch of new songs. When I imported them I was expecting MB to make a copy (or move) them into the folder specified under the auto sweep rules menu and set the location to that folder. I initially tried without a template and that did nothing. Then I setup a template with <Artist>\<Album>\<Track#> - <Artist>

Neither of those worked. The files were imported with the location set to the desktop folder.

edit: There is a post in the thread stating it worked in 2.3 but no longer worked in 2.4 so I assumed the functionality had been removed.
Last Edit: June 04, 2022, 07:30:50 AM by BoringName

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32922
the OrganisationLibraryCopySourceFiles2 setting only works for auto-organised libraries
If the files you used for testing were in one of the monitored folders you configured then with auto-sweep enabled, the files should have been moved using the template you used. Just tested to re-confirm it still works. So if it didnt move the files then you are not doing something from these steps.

Given I am currently looking at the file organiser I will look at adding a check-box to the auto-sweep dialog to copy the files instead of move. The intention is that would work whether or not auto-organise is enabled. I will deprecate OrganisationLibraryCopySourceFiles2 given its not accessible in the GUI and had a bug of re-copying the same files over again so i dont see how anyone could be using it successfully anyway

BoringName

  • Jr. Member
  • **
  • Posts: 56
I don't have auto organise ticked so that would be the issue.

Also I didn't realise the monitored folder section was part of the auto sweep feature and I don't have any listed in there.

So in theory, if I had my desktop as a monitored folder and setup the sweep rules above, when I saved the files to the desktop it would have grabbed them and swept them to the folder I specified in the auto-sweep rules?

Your suggested changes sound good to me.

Thanks.


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32922
support for OrganisationLibraryCopySourceFiles2  is removed and a new tick box in the auto-sweep settings copies rather than moves the files in the monitored folders

https://getmusicbee.com/patches/MusicBee35_Patched.zip