Author Topic: Q: Why "smooth fade when stopping" is not effective in WASAPI?  (Read 10410 times)


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416

butty

  • Sr. Member
  • ****
  • Posts: 435
here you are:
2013/11/23 6:12:15 - stop close=True,fade=True,hardstop=True,save state=Paused,is plugin=False,output=Wasapi
2013/11/23 6:12:15 - close handle=-1342177279,ramp down=False,dec=False,in mix=True

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
there is 2 reasons - the player is paused when you do this (do you agree?)
and secondly, the function is being instructed to stop immediately. That would happen if your test was to shut-down musicbee while it is playing for example. So can you describe what steps you are doing?

butty

  • Sr. Member
  • ****
  • Posts: 435
there is 2 reasons - the player is paused when you do this (do you agree?)
and secondly, the function is being instructed to stop immediately. That would happen if your test was to shut-down musicbee while it is playing for example. So can you describe what steps you are doing?

Yes, actually I have paused instead of stopping.
The steps:
1. Pressed the pause button on MB.
2. After that, quitted MB because the log is not flushed until it.

Would you inspect my settings file?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
so you are testing the feature with pausing not stopping then?
Last Edit: November 22, 2013, 09:44:13 PM by Steven

butty

  • Sr. Member
  • ****
  • Posts: 435
so you are testing the feature with pausing not stopping then?

i think for pause you are right and i will look to fix that

Sorry for not having mentioned it. But, for stopping, the same problem occurs.

butty

  • Sr. Member
  • ****
  • Posts: 435
And here are the logs when stopping:
2013/11/23 6:45:06 - stop close=True,fade=True,hardstop=False,save state=Playing,is plugin=False,output=Wasapi
2013/11/23 6:45:06 - close handle=-1342177279,ramp down=True,dec=False,in mix=True

butty

  • Sr. Member
  • ****
  • Posts: 435
I tested with the test version with stopping. Yes, it did fade for a long time.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
I tested with the test version with stopping. Yes, it did fade for a long time.
I do agree it doesnt appear to be a smooth fade and tends to accelerate down more near the end. I'm not sure i have any control over that. I will have a quick look but i dont want to spend much time on this. I have also increased the fade period to 0.6 secs for pausing


butty

  • Sr. Member
  • ****
  • Posts: 435
I'm sorry.
This reply is wrong.

The "smooth fade when stopping" is not effective when WASAPI is used.
I have accidentally used DirectSound and misunderstood.

---
Hi, I've found the reason of this problem!

When "use logarithmic volume scaling" is on, "smooth fade when stopping" is not effective.
So, for now, I turned off the logarithmic volume. I'd be happy if you fix this problem.

Thanks in advance.

butty
Last Edit: August 14, 2015, 08:44:29 AM by butty