Author Topic: What is the last Itunes version that works for reinstall Ipod ?  (Read 12959 times)

Video99

  • Jr. Member
  • **
  • Posts: 61
I've reinstall my Ipod Classic 120GB (Firmware 2.01PC) with the actual Itunes 10.6.17.

The Database on the IPod seem to be another than earlier. So the sync does not work properly
Which version of Itunes is the right one to reset my Pod with correct filestructure, so it's work with MB?
Is v9.21 ok?
     

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34354
i would say so. I think some of the 10 releases also work but i havent been keeping up with all the changes being made so its quite possible they have done something to disable third party apps

Video99

  • Jr. Member
  • **
  • Posts: 61
So,  now I've reset my iPod back with iTunesversion 9.0.70.
But the sync with MusicBee & iPod Classic 120GB doesn't run.
So, for synching my iPod, I went back and use my former program "MediaMonkey".

In the meanwhile I've testet SharePod for syncing too.  That works also.
I've seen there is a link for developers, and SharePodLib is now open-source!
Code is for free for non-commercial use.   (DotNet 2.0)

http://code.google.com/p/sharepod-lib
http://www.getsharepod.com/fordevelopers/

Perhaps it is worth to visit this links.  
Last Edit: May 27, 2012, 01:12:36 PM by Video99

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34354
can you give some more detail around the steps you are doing in MB to synch
Is there any error in the error log around the time you run the sync (help/support/view error log)
and lastly, can you see existing files and playlists from the device node in musicbee?

Video99

  • Jr. Member
  • **
  • Posts: 61
Hi Steven!

First I reset the iPod with iTunes 10 (and 9x) several times.  Next I start MB as Admin.

Device Settings are Standard  :  
  \iPod_Control\Music
  F01\nnnn
  \iPod_Control\iTunesPlaylists\Audiobooks
  \iPod_Control\iTunesPlaylists\Video
  \iPod_Control\iTunesPlaylists\Podcasts
  mark radiobutton "copy artwork to the iPod database"

Than I configure the Auto-Sync Settings :
 checkmark "Folder" and point to my MP4-AudiobookFolder
 checkmark under playlists my three playlists for sync
 (Playlist one has round about 90GB (14000 Titles) and there are two small ones more.

Than i have to wait for a long time.....

  After that the sync seems to be ok.  Music, Covers, Audiobooks, Podcast are ok and working on iPod
 
Now start MB next (normal NOT admin)
When I reconnect the iPod, the Ipod comes up as Device iPod120GB(K:) with correct node for Music, Podcast, Audiobooks, Video and my three playlists.

  But, if I resync next time with minor changes, the iPod has no Music, no books and so on. (The iPod used furthermore 90GB HDD-Space)
  The iPod device is displayed now as an normal USB-Drive in MB directorytree!
The Device Settings has now StoragePath ie. "G:\"   and the Music files filed contains now "Music\<Album Artist>\<Album>\<Disk-Track#> - <Title>" and so on for the following fields.  

Next sync goes then to the wrong location on my iPod because MB thinks it syncs an USB-Device. Ipod Database is out of sync now and the game is over.

The problem seems to be the lost of status as an iPodDevice  to USBDevice.

At the moment it works fine with MM-syncing. But if you need more info, let me know.

(System  Win 7  Prof 64)
Last Edit: May 28, 2012, 06:29:38 AM by Video99

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34354
trying now its still working fine for me but i did make a fix in early march to remove a temporary file that was being left behind.
I think you said MusicBee used to work ok for you, do you recall when it stopped working properly?
If it is around that time, then i can give you the old version of that to see if thats what the problem is from

Video99

  • Jr. Member
  • **
  • Posts: 61
I think in must be around begin of march (perhaps MusicBee 2.0.4467?)   
Let me try your old version. 
I additional will do that at a blank installation on another partition and report the result here.   

 


Video99

  • Jr. Member
  • **
  • Posts: 61
I've replaced the current DLL's with the (old)one  from Stevens last thread.

I start MB but the Ipod was read-only now.
Message: "The device is read-only and cannot be updated by MusicBee"

So I start MB as admin  - the same result (read-only)

I deinstall MB with the win7 deinstall routine under programs. The userfiles stay untouched after deinstall.
After that, I install MB with MusicBeeV2Installer.exe and start the new installation.
 
The device (iPod classic 120GB) shows up in directorytree of MB.
Inside the nodes I see all my music, podcasts, audiobooks and so on.. So far so good.

Because MB was readonly now, I check with "MediaMonkey V4" the readwrite status. All works fine and sync works properliy! - ok.

Next, I fire up "SharePod V3.99". All the transfers from and to the iPod are working fine and nothing is locked or R/O.

The same Test I've made before with iTunes [10.6.17] and at last with [9.0.70]

The result is nearly the same. The difference is, that after reset with iTunes 9, the entries and DriveSettings will stay correct.

   Device Settings
   \iPod_Control\Music  F01\nnnn
   \iPod_Control\iTunesPlaylists\Audiobooks
   \iPod_Control\iTunesPlaylists\Video
   \iPod_Control\iTunesPlaylists\Podcasts
 
  After reset with iTunes 10 they are different & wrong.
    Device StoragePath "G:\"      Music files "Music\<Album Artist>\<Album>\<Disk-Track#> - <Title>"
   and so on for the following fields. 

What is so special on MB?
Will MB remain the status of an locked iPod and think it's forever. Or set windows a flag in the user control for exclusive use only for i.e. MM.
But why will SharePod still working?

At last I've have made all these tests with an 2GByte iPod Shuffle.
All three programs MM, MB, & SharePod working fine.

I am clueless. Are there another people that this problems with the Apple Classic?
Steven, what test can I do next?

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34354
if this was a generally reported problem i might look at this further but so far you are the only person reporting this and i dont have the time to spend investigating weird problems that only happen for one or two people. Also as Apple seems to go out of its way so other apps have trouble interfacing to its devices i'm not inclinded to spend time battling that

Video99

  • Jr. Member
  • **
  • Posts: 61
Hi Steven, after all this trouble I've made a big cut.
I deinstall all the Apple Software, MusicBee and MediaMonkey. After that, I clear the registry.
Then I install iTunes 9 and start it.  iTunes find out that the libray (ituneslibrary.itl) was newer and abort the start of iTunes. So I delete the whole iTunesdirectory in the subdirectory of USERS.

Than I reset the iPod and reinstall MusicBee.  And, after a start as admin, the iPod was not longer ReadOnly - an sync was possible now.
So I try some Playlist syncs - all works fine. After I was brave, I sync, for fun, with MediaMonkey. That works also fine.
At the moment I sync the long Playlist and restore the iPod.  I hope that tomorrow everything continues to run.

So, I mean my mistake was that I reset my iPod not with right iTunes9 Version.
Perhaps there are some registry entrĂ­es or a mix of 10 and 9 or the directory with the newer ITL-File was wrong.


Thanks for your patience and support.    

-------- Edit --------

After the fifth sync in MB there now covers on iPod & one sync later  the iPod was only an USB-Pod like I wrote before.
I give up - syncing AppleClassic and MB = NO GO

 
Last Edit: June 02, 2012, 02:53:47 PM by Video99

liebezeit

  • Guest
I have the same problem. My iPod Classic comes up as an iPod sometimes and as a USB/MTP device most of the time. In the latter mode it appears to sync but just puts stuff on the iPod drive root.  I am using MusicBee 1.4.4443.

liebezeit

  • Guest
I noticed something--when I removed non-standard files from the iPod's mounted drive (a copy of Floola) then MusicBee sees it as an iPod again! Is this really how iPods are detected?

Video99

  • Jr. Member
  • **
  • Posts: 61
I think Steven has not much time, to support our old IPod Classic.

He has wrote this wonderful program for us and for free!  Thx 2 him.

 I use MB only for tagging and playing, for synching, I use MM 4.


But, if Steven has a little bit of time ..   

The SharePod resources are free now for non commercial use. The download comes over SVN

svn checkout http://sharepod-lib.googlecode.com/svn/trunk/ sharepod-lib-read-only

I've read some of the sources.

SharePod differs from various Ipods, I think MB does not.

/*
public enum IPodFamily
    {
        Unknown = 0,
        iPod_Gen1_Gen2 = 1,
        iPod_Gen3 = 2,
        iPod_Mini = 3,
        iPod_Gen4 = 4,
        iPod_Gen4_2 = 5,
        iPod_Gen5 = 6,
        iPod_Nano_Gen1 = 7,
        iPod_Nano_Gen2 = 9,
        iPod_Classic = 11,
        iPod_Nano_Gen3 = 12,
        iPod_Nano_Gen4 = 15,
        iPod_Nano_Gen5 = 16,
        iPod_Shuffle_Gen1 = 128,
        iPod_Shuffle_Gen2 = 130,
        iPod_Shuffle_Gen3 = 132,
        IPhone_ITouch = 2000,
        IPhone_ITouch2 = 2001,
        IPhone_ITouch3 = 2002,
        IPhone_ITouch4 = 2003
    }
  *      SharePodLib - A library for interacting with an iPod.
  *      Jeffrey Harris 2006-2010
  *      Website: http://www.getsharepod.com/fordevelopers
  */

But i think only Ipod Nano & Ipod Touch has special routines, Ipod Classic not.

Perhaps, Steven can investigate the differences into the sources.
And fix our problem  8)




 
Last Edit: July 13, 2012, 12:44:15 PM by Video99