Author Topic: Support for MIDI playback  (Read 9617 times)

Cypher

  • Jr. Member
  • **
  • Posts: 67
This option keeps me away from Musicbee for a couple of months and since there's a file called "bassmidi.dll" in the Musicbee folder, why don't make it functional?

Thanks,

Cypher
Last Edit: May 05, 2019, 08:10:58 PM by Cypher

Cypher

  • Jr. Member
  • **
  • Posts: 67
BUMP, i hope it will be in the next weekly build.

silasje1

  • Member
  • Hero Member
  • *****
  • Posts: 654
i can't playback MIDI neither. But why would you want to play those?
HDMI GTX570->YAMAHA RX-V471->DALI ZENSOR 1

Dutch Translation

WMP 12 Skin

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33454
adding MIDI support is not trivial and i cant believe it would be important to many people so i havent decided whether to add it or not. But in any case i wouldnt be able to look at it for a number of months so you best use another player that supports it if its important to you.

Nokiaman

  • Jr. Member
  • **
  • Posts: 63
Sorry for bumping, but I wish to see this too.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10682
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Nokiaman

  • Jr. Member
  • **
  • Posts: 63
Odd. Doesn't work for me on latest patched version.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10682
Did you install a sound font file?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Nokiaman

  • Jr. Member
  • **
  • Posts: 63
Yeah I just did and it works. There really should be some basic one OOTB.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10682
I agree, that'd be a good addition for 3.1
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

ShinMak

  • Newbie
  • *
  • Posts: 3
On earlier versions of Musicbee, I have been able to play Midi files.
Now I am trying to play Midi files with the latest version and it's not working.
My computer has not changed, neither has the software.
Just wondering what could have happened.
I have not adjusted the settings either.

Every other program seems to play Midi files with no issue, only Musicbee has stopped playing Midi files.
The audio track will iterate through the audio timeline but no sound can be heard.
I've looked at the volume mixer and all the volume settings are as they have always been, I've tried setting everything to maximum volume and still no sound.

Any suggestions/help would be appreciated very much as I like to use Musicbee when organizing my Midi files.

ShinMak

  • Newbie
  • *
  • Posts: 3
Solved it.
The Midi SoundFont is blank.
Never noticed this setting before.
So I guess I'll have to find a soundfont.

ShinMak

  • Newbie
  • *
  • Posts: 3
Actually, didn't solve it. Even with a soundfont there is no sound. I give up.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33454
can you send me a link to one of the files you are trying to play