Author Topic: Cataloging and playing DSD files  (Read 55741 times)

frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

I tried out the new MB version, and unfortunately, it is still converting DSD to 88.2 kHz PCM.  Just to verify: I turned off all effects in "Preferences -> Player -> Sound Effects", and no equalizer / dsp is selected.  I also verified that the same DSD files are received as DSD files when using foobar2000 with foo_dsd_asio.dll plugin.

Let me know if I can provide any additional information, and thanks again for a great player.


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33440
you might also need the latest bass.dll file - replace the existing one in the MB folder
http://www.mediafire.com/download/gczhw123y2hbhqm/bass.dll

frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

unfortunately, even with the new bass.dll, MB is still converting to DSD to 88.2 PCM.  Thanks for your quick response on a Saturday :-).

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33440
i have taken out the sample rate check on the device. If it still forces PCM then i would need someone to run a debug version

http://musicbee.niblseed.com/V2_5/MusicBee_Exe_Patched.zip

frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

something really broke in that latest release (2.5.5433).  When I play a DSD file, I only hear white noise, and my DAC reports the incoming file is 352.8 khz PCM.  I did a quick test of some other PCM files, and MB does correctly play 44.1 PCM and 192 PCM. 

Let me know how I can help further.


Alumni

  • Hero Member
  • *****
  • Posts: 1007
I just tried putting my mode back on ASIO but it won't play anything, gives a BASS error.
I'm assuming that WASAPI is not sufficient for DSD playback? (my DAC is ASIO compatible)

frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

OK, I have some mixed progress to report with the latest MB build.  DSD files still sound like white noise when output=ASIO, but my DAC is recognizing a DSD file.  However, then MB locks up, and won't play anything (PCM or DSD).  Here is the sequence of steps I ran:
play 44.1 PCM (OK)
play DSD64 (DAC recognizes DSD, white noise playback, MB locks up.  I have to kill MB, disconnect and reconnect my DAC, and re-start MB to play music again).
Also, this is probably not important now, but MB is sending DSD64 and DSD128 files as DSD64.

Let me know if I can provide any additional information.

P.S. if output = WASAPI, MB converts DSD to 88.2 PCM (and they play just fine)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33440

frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

I'm sorry to report that I'm experiencing the same "white noise" for DSD files with the latest version (5436).  Thank you so much for your perseverence.

Frank

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33440
in that case i will remove support for playing native DSD files and revert to having them converted to PCM as before

frankcreed

  • Jr. Member
  • **
  • Posts: 44
I'm sorry that you couldn't get native DSD support going, but I do want to thank you for your great support!


frankcreed

  • Jr. Member
  • **
  • Posts: 44
Hi Steven,

Nope - same 'white noise' problem with DSD files, and then MB locks up.  The version number is 5436 - is this supposed to be different from the last version?