Author Topic: OCD - WASAPI (Bit Perfect)  (Read 324 times)

Jippett0

  • Newbie
  • *
  • Posts: 2
Morning All!

Disclaimer - I don't pretend to be an audiophile, nor do I *know* I am able to hear the minute differences beween a FLAC at 16 Bit/44100Hz (or higher) and MP3 320Hz. However, if you would kindly induldge a man with minor OCD in accomplishing "Bit Perfect" playback on Windows, with MB, I would appreciate it.

Here's what I understand.

 - WASAPI Exclusive Mode, allows for the track(s) to be sent directly to the sound device, without going via the Windows Mixer, preventing Windows from interfereing with the playback. Is this correct?

 - There will be some additional settings that need to be changed in MB, to ensure there is no resampling or post processing. Could someone enlighten me as to what I would need to disable/change to ensure the files are not resampled/modified during playback?

 - My sound device is able to play back these "formats".



I understand that when I play a file outside of the "Supported" formats (i.e. 88200Hz), "bass.dll" is called upon to resample the file, to ensure playback is successful. Is this correct?

 - How can I confirm MB is playing back a file "unmodified" or is using bass.dll to resample. Other players like FB2000 or AIMP have a console view or a Sound Output window which confirms the playback attributes during playback. So I can visually see whether a file is being resample etc...

Is there anything inside MB which will confirm exactly what is being played back (i.e. the files original atrributes or whether bass.dll is being used to resample?

Appreciate it's a long post and some of these might have already been answered elsewhere, but I tried to do a fair amount of searching before hand.

Cheers.

sveakul

  • Sr. Member
  • ****
  • Posts: 2499
Your questions were not numbered, but I'll try and answer them in the order they were presented:

1.  YES

2.  Go to Preferences/Player, and be sure upmix/resample are not checked, and un-check everything in "Sound Effects", but if you prefer logarithmic volume it's fine to check that.  In Equaliser/DSP uncheck any effects.  Do NOT enable replay gain.

3.  Keep the MB volume control at max, and instead control volume from the system volume panel, or with a tool like Volume2 (https://github.com/irzyxa/Volume2).

4.  YES as far as bass.dll resampling formats it is told your device does not support.

5.  There is no "console" way to visually confirm what is going on.
Last Edit: April 15, 2024, 06:04:38 PM by sveakul

Jippett0

  • Newbie
  • *
  • Posts: 2
Your questions were not numbered, but I'll try and answer them in the order they were presented:

1.  YES

2.  Go to Preferences/Player, and be sure upmix/resample are not checked, and un-check everything in "Sound Effects", but if you prefer logarithmic volume it's fine to check that.  In Equaliser/DSP uncheck any effects.  Do NOT enable replay gain.

3.  Keep the MB volume control at max, and instead control volume from the system volume panel, or with a tool like Volume2 (https://github.com/irzyxa/Volume2).

4.  YES as far as bass.dll resampling formats it is told your device does not support.

5.  There is no "console" way to visually confirm what is going on.

Great. Thanks for your response. I have made the changes as suggested.

It's a shame there is no way to visually confirm the output "format" via MB, perhaps this could be considered for future versions?

Regards

hiccup

  • Sr. Member
  • ****
  • Posts: 7936
Also make sure crossfade is disabled.
(often overlooked by users attempting bit-perfect playback)

sveakul

  • Sr. Member
  • ****
  • Posts: 2499
Also make sure crossfade is disabled.
(often overlooked by users attempting bit-perfect playback)
Yep, which is the very first box in "Sound Effects":
2.  Go to Preferences/Player, and be sure upmix/resample are not checked, and un-check everything in "Sound Effects",
Just didn't want the OP to think he missed anything  ;)

hiccup

  • Sr. Member
  • ****
  • Posts: 7936
Yep, which is the very first box in "Sound Effects":
I must have had some brainfart, I thought it was at some other location that people often overlook.