Author Topic: remove auto-dj from shuffle toggle  (Read 6135 times)

ntb

  • Newbie
  • *
  • Posts: 7
Hi, in an ideal world I would like the auto-dj button removed from the normal/shuffle toggle (see screenshot), and perhaps placed elsewhere if it's a commonly used toggle. 

https://dl.dropboxusercontent.com/u/6654913/shuffle.png

I feel that it adds an extra and clunky step to a very common action (turn shuffle on and off), which seems like a basic enough toggle that it should be done in one click. 

Not urgent, obviously, but it's something to consider. 

Thanks!

theG

  • Jr. Member
  • **
  • Posts: 77
+1

We use MusicBee for the music in my friend's pub and have playlists already created. I've asked the staff to make sure it's on shuffle when they start the music at the beginning of the day and sometimes it's on Auto-DJ instead. I would really like an option to remove the Auto-DJ toggle as well.
I'd turn it off in my setup at home as well.

Since we're at it, an option to remove it from the playlist nod would be nice too.

Alumni

  • Sr. Member
  • ****
  • Posts: 1007
+1

We use MusicBee for the music in my friend's pub and have playlists already created. I've asked the staff to make sure it's on shuffle when they start the music at the beginning of the day and sometimes it's on Auto-DJ instead. I would really like an option to remove the Auto-DJ toggle as well.
I'd turn it off in my setup at home as well.

Since we're at it, an option to remove it from the playlist nod would be nice too.

As I said in the other thread, it's up to the skin author to enable/disable the auto-dj toggle in the (main window) player controls.
For example in my most recent custom skin that toggle is not included - it's just shuffle on/off.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34405
in v3, the user has the option to remove the auto-dj node from the navigator. If the user chooses to remove the auto-dj node, i guess it makes sense to also remove the auto-dj from the shuffle mode toggle button as well so i will do that for the next v3 update


vitesse

  • Newbie
  • *
  • Posts: 8
What you can do in the meantime is use a hotkey.

For example, I have a global hotkey set for it (Player: Toggle Shuffle Mode) and it's what I use most of the time to toggle the option.

Using it just toggles shuffle on and off, so you don't bother with AutoDJ.

imminiman

  • Jr. Member
  • **
  • Posts: 62
  • Music is my life, 'cause my life is music.
in v3, the user has the option to remove the auto-dj node from the navigator. If the user chooses to remove the auto-dj node, i guess it makes sense to also remove the auto-dj from the shuffle mode toggle button as well so i will do that for the next v3 update

What you can do in the meantime is use a hotkey.

For example, I have a global hotkey set for it (Player: Toggle Shuffle Mode) and it's what I use most of the time to toggle the option.

Using it just toggles shuffle on and off, so you don't bother with AutoDJ.

Hi,
There is a problem still.
I'm using a global hotkey just like vitesse, but I'm guessing he's not using V3. When I used V2.5 it worked just as he described it, but now it doesn't. I even removed the Auto-DJ node, and it doesn't work like I want it to. Clicking the toggle button now works fine, but I mostly use the hotkey. Can you please fix it Steven?


imminiman

  • Jr. Member
  • **
  • Posts: 62
  • Music is my life, 'cause my life is music.
this version now takes the Auto-DJ node into account:
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

Now it's working as it's expected to. Thank you Steven. You're the best!

hardware pirate

  • Newbie
  • *
  • Posts: 1
this version now takes the Auto-DJ node into account:
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

hello, i have the same issue at present and don't know how to resolve it, running 3.5.8698.
somehow i got it to work, i don't remember if i prior had access to your now disabled file or if i managed to get auto dj removed from shuffle in settings.

anyway, could you update your insights on how to resolve it ?
this bug is so annoying i even created an account after having returned to this most likely plausible answer for several times, but being hindered by the hosting website of the link not working anymore.

thank you very much!

Zak

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 2469
I don't know why you're using the word 'bug' in an 8-year old thread that wasn't about one in the first place, but if you're asking how to disable the Auto-DJ option, uncheck it in the Layout preferences:

Bee excellent to each other...