Author Topic: Import problem  (Read 1038 times)

Babydoll32

  • Full Member
  • ***
  • Posts: 140
Hi, I‘ve a question. Maybe it‘s a bug.
Yesterday, I had to reinstall my Windows 11 and also Musicbee. For some reasons, need to have a few „fake“ FLAC & MP3‘s with 0-byte on my HDD. I checked the „ignore tracks less…“ option and files were ignored as they should till yesterday. I still have it checked, but now Musicbee always recognize them, imports them and send them to the inbox. I‘ve version 3.5.8698 installed, I think before I had the previously released version. Could it be a bug or is something wrong with my setup?

Best regards

tjinc

  • Sr. Member
  • ****
  • Posts: 383
I do not believe that this is your setup. It seems that, once a file has been imported into your library and then removed, it will no longer be filtered out by the small file size filter. (Did you originally scan them all in before setting this file size filter option?)
This seems to be dependent on the filename.

You could check this theory:
Working with one of these small files that is in your library: right click > delete > delete from library only.
Scan the folder for new files and, presumably, this file will be re-imported.
Delete from library again
Rename the file (in Windows Explorer)
Scan the folder for new files again and confirm that it is not imported.

Babydoll32

  • Full Member
  • ***
  • Posts: 140
Yes, you‘re right. That’s the problem. Damn 😭
Now I need to look for a solution 😬
Thanks for helping!

hiccup

  • Hero Member
  • *****
  • Posts: 8013
I probably shouldn't mingle in a Q&A that was quickly resolved to satisfaction.
But here I am ;-)
(because I don't understand)

The OP used clean installs of both Windows and MusicBee, and reported that after that the setting to ignore small file sizes was ignored, and small file-sized tracks where imported anyway.

What am I missing that made this some 'user oversight'?

tjinc

  • Sr. Member
  • ****
  • Posts: 383
No user oversight here - just the confirmation of a suspected bug.

hiccup

  • Hero Member
  • *****
  • Posts: 8013
No user oversight here - just the confirmation of a suspected bug.
The assumed bug being…?

tjinc

  • Sr. Member
  • ****
  • Posts: 383
The assumed bug being…?

In certain circumstances the setting to ignore small file sizes is ignored, and small file-sized tracks are imported anyway.
(Circumstances being that the files have previously been imported before this setting was enabled)

hiccup

  • Hero Member
  • *****
  • Posts: 8013
The assumed bug being…?
In certain circumstances the setting to ignore small file sizes is ignored, and small file-sized tracks are imported anyway.
(Circumstances being that the files have previously been imported before this setting was enabled)
Thanks for your efforts in explaining and trying to figure out what's going on.
But I still don't understand, because the OP mentioned a clean install of both Windows and MusicBee.
In that case I can't imagine how the new and clean install of MusicBee could know anything about what happened before.
So I am missing something here? But what?

edit:
Never mind, I saw a bug report was created, so that will probably make things clear and will get them resolved if needed.
Last Edit: October 27, 2023, 09:31:30 PM by hiccup

tjinc

  • Sr. Member
  • ****
  • Posts: 383
But I still don't understand, because the OP mentioned a clean install of both Windows and MusicBee.
In that case I can't imagine how the new and clean install of MusicBee could know anything about what happened before.
So I am missing something here? But what?

My guess is, and this would have to be confirmed by the OP, that on setting up the new system (and scanning the music folders), all the small files were imported. Then the ignore small files settings was enabled and the small files deleted from library.
Thereafter, on any rescan, whether manual or automated, the small files are re-imported (ignoring the small file-size setting).

It's just a theory but the only one that seems to make sense (and fits what is being seen when testing for this bug).

hiccup

  • Hero Member
  • *****
  • Posts: 8013
It's just a theory but the only one that seems to make sense (and fits what is being seen when testing for this bug).
Thanks, that seems to make some sense.

But now I am wondering:
Why is there the option to 'ignore tracks less than .. KB' to begin with?
Come to think of it, I never understood that one.

Ah well, don't bother to answer that, I'll pretend that google is my friend.

Babydoll32

  • Full Member
  • ***
  • Posts: 140
Hi Hiccup, thanks for joining my thread.
Maybe I should start from the beginning. Sorry, English isn‘t my native language, but I hope you understand what I mean.

I had/have a Musicbee database before I ruined my system, which I backed up. I have some FLAC & MP3 files, which was imported to database. I made those files to 0-byte files and kicked them out of library. I need to keep the files with their original filenames and endings, but don’t wan’t them in my library. When I scanned my HDD for new files with old setup and „Ignore files less…“ checked, they weren‘t reimported to library (cause 0-byte) and it worked as it should for my preferences. After reinstalling WIN11 and Musicbee and restore my library backup, Musicbee sends all those 0-bytes again to Inbox. But I still wan‘t them ignored, but it doesn’t work. New 0-bytes are ignored fine as they should, but old files will be reimported 🤷🏻‍♂️

Maybe it thread should be moved to bug reports, cause I don’t think, that it should work this way…
Last Edit: October 28, 2023, 06:00:14 AM by Babydoll32