Author Topic: Need help with naming template for folder organization  (Read 597 times)

tw1zta

  • Newbie
  • *
  • Posts: 15
Hello all, so I am trying to figure out how to make my files in my folders show up as:
01 -  Album Artist - Track Name (Feat. Artist 2)

Normally it will work, but the problem is, I have tracks where there is only 1 artist, so for those files, the file is named something like:
02 - Album Artist - Track Name (Feat. Unknown Artists: Guest) < I want to eliminate that

I want the tracks with solo artists to be blank (Without "Feat.) since it doesn't need it.

The folder naming template that I am using is this:
<Album Artist>\(<Year (yyyy)>) <Album> (<Grouping>)\<Disc-Track#> - <Album Artist> - <Title> (Feat. <Artists: Guest>)

Thanks for your help in advance!
Last Edit: May 06, 2023, 02:10:49 AM by tw1zta


tw1zta

  • Newbie
  • *
  • Posts: 15
add exception to organization template:



Hey thanks for your reply!

I'm having a problem though. What exactly am I suppose to type where you marked "type another template here"?
Because I tried to do that and it still says "featuring unknown artists" for every track with solo artist.

boroda

  • Sr. Member
  • ****
  • Posts: 4606
the same pattern as at 1st line (and the same path in the left field), but without "(feat. ...)", without the part, which generates what you have emphasized as italics in your template result:

02 - Album Artist - Track Name (Feat. Unknown Artists: Guest)

tw1zta

  • Newbie
  • *
  • Posts: 15
But I want (Feat... ) to be in the file names for the songs that have multiple artists...

I only want to stop the organizer to not put (Feat...) on songs with only 1 artist.

Here is what I want my files names to be:

01 Album Artist - Song Name (Feat. ARTISTS) ( because it has multiple artists)
02 Album Artist - Song Name2 _ (<--- BLANK or EMPTY because it is only 1 artist, so nothing is there after the track name)

The track number 2 is a solo track, so obviously it will not say (Feat..) at all

but track number 1 has multiple artists and I would like for it to say at the end of the track name (Feat...) and then the artist that are featured on the song.

Thank you again for your help.

Mayibongwe

  • Sr. Member
  • ****
  • Posts: 1058
  • Heal The World
I have never experimented with using MusicBee's exception feature in the File Organiser.
So what I would have suggested to you was that you amend your template to:

<Album Artist>\(<Year (yyyy)>) <Album> (<Grouping>)\<Disc-Track#> - <Album Artist> - <Title> $IsNull(<Artists: Guest>,,(Feat. <Artists: Guest>))
I already spend hours on end on social media. Might as well spare a few of those to a greater purpose here.

boroda

  • Sr. Member
  • ****
  • Posts: 4606
But I want (Feat... ) to be in the file names for the songs that have multiple artists...

I only want to stop the organizer to not put (Feat...) on songs with only 1 artist.

Here is what I want my files names to be:

01 Album Artist - Song Name (Feat. ARTISTS) ( because it has multiple artists)
02 Album Artist - Song Name2 _ (<--- BLANK or EMPTY because it is only 1 artist, so nothing is there after the track name)

The track number 2 is a solo track, so obviously it will not say (Feat..) at all

but track number 1 has multiple artists and I would like for it to say at the end of the track name (Feat...) and then the artist that are featured on the song.

Thank you again for your help.

did you see "except when" checkbox? second line is a template when artists:guest is empty.

though, Mayibongwe's suggestion must work also.

tw1zta

  • Newbie
  • *
  • Posts: 15
I have never experimented with using MusicBee's exception feature in the File Organiser.
So what I would have suggested to you was that you amend your template to:

<Album Artist>\(<Year (yyyy)>) <Album> (<Grouping>)\<Disc-Track#> - <Album Artist> - <Title> $IsNull(<Artists: Guest>,,(Feat. <Artists: Guest>))

Hey I tried your method but there is a paranthesis at the end of every title now. Do you know how to remove it?

https://imgur.com/a/HGdo7V1
Last Edit: May 07, 2023, 05:10:35 AM by tw1zta

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34359
its probably MB not able to correctly parse the double brackets
just define a separate virtual tag for: (Feat. <artists:guest>)
and use that virtual tag in the 2nd parameter of $IsNull

boroda

  • Sr. Member
  • ****
  • Posts: 4606
also, you could try the following, but i haven't tested it:

<Album Artist>\(<Year (yyyy)>) <Album> (<Grouping>)\<Disc-Track#> - <Album Artist> - <Title> $IsNull(<Artists: Guest>,,"("Feat. <Artists: Guest>")")