Author Topic: Smart playlist having issues with Last Played date  (Read 344 times)

Uri

  • Newbie
  • *
  • Posts: 9
I have a smart playlist that is meant to not have songs that were played recently.

I have this set as "Last Played" "is not in the last" "16" "months"

When I do this rule, or any other rule with the "Last Played" field it doesn't get it 100% correct.

Specifically, I get songs that were played this month in that rule, or other rules that are similar.



I am using MusicBee version 3.5.8447

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34408
i am not able to reproduce this. Could you confirm one thing though. If you untick the limit option, does it include all tracks last played in the last month and then all tracks >16 months? ie. the error is its including tracks last played in the last month

Uri

  • Newbie
  • *
  • Posts: 9
I removed the limit but it doesn't include all songs, but does include very specific albums it seems and it appears to be a somewhat new issue (Late February).

I changed audio players a couple of times on my phone, but it still syncs to LastFM properly so it doesn't really explain this.
Not sure anything else changed...


frankz

  • Sr. Member
  • ****
  • Posts: 3868
Strange question maybe and probably irrelevant, but it popped into my head - is the date on your computer set correctly?


Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34408
Click the 'Add files' button. I suspect you might have dragged those files into the playlist so they are always included

Uri

  • Newbie
  • *
  • Posts: 9
I went ahead and just deleted all songs from the playlist and it refreshed itself properly.

So that was for sure the issue.  :-X

I feel a bit silly, but also feel like either that should be possible or it should have an indication that I have songs there that overrode the "smart" part of the playlist.

Either way, you can consider this issue resolved. Thanks!