Author Topic: Additional Tagging & Reporting Tools  (Read 970354 times)

dr0mo

  • Newbie
  • *
  • Posts: 3
cant reproduce this and dont have any ideas why this would happen. sorry.
Thanks for taking a look at it. Since it is working with an older version, I'll keep using that until your next release and see what happens then.

 I'm also having problems with the latest version of the plugin and can't seem to find a link to older versions. Can you upload the version you have?

boroda

  • Hero Member
  • *****
  • Posts: 4748
i'm afraid i have only very old version designed for musicbee 2.5:

https://drive.google.com/file/d/0B-D1MoIY406HbUllM1VzMlhrVXc/view?usp=sharing

maybe phred can upload the version he has (which is working for him without problems).

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
maybe phred can upload the version he has (which is working for him without problems).
Happy to help out. Here's the last version that works for me...
https://www.mediafire.com/file/noxrurht2m3zpeb/mb_TagTools_5.1.7154_2019-08-03.zip/file
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

dr0mo

  • Newbie
  • *
  • Posts: 3
maybe phred can upload the version he has (which is working for him without problems).
Happy to help out. Here's the last version that works for me...
https://www.mediafire.com/file/noxrurht2m3zpeb/mb_TagTools_5.1.7154_2019-08-03.zip/file

Thanks for the answers & links. No more freezes, it's working fine now.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
Thanks for the answers & links. No more freezes, it's working fine now.
Great to hear it worked. For two reasons - one, your problem is solved. Two, because boroda couldn't reproduce the freezing issue I was having. The fact that you experienced it also, confirms that I'm not as crazy as I thought.

Perhaps boroda can dig into this a little more when he has the time.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
@phred, could you try this version?
http://www.mediafire.com/file/lx6lk42gdeci018/mb_TagTools.dll/file
A test of 5.2.7214 shows no progress in resolving the issue.
I selected six tracks and selected the preset to change title to lower case.
The preview window shows what the new tag value would be, as expected.
Clicked on apply and MB went into a deep freeze requiring a CTRL-ALT-DEL to get to the task manager and kill the process.
Replaced the dll with 5.1.7154 performed the same action and no problem whatsoever.

I just noticed a couple of odd things in the available presets. Entries which I had not noticed previously. At the very end of the list are two 'presets' that make no sense. Perhaps the name is in Russian. The first has a description and the second does not...


There is also a preset named 'test' and the description is the same as the one in the screenshot.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

boroda

  • Hero Member
  • *****
  • Posts: 4748
'delete' these 3 presets, manually delete all files from 'plugins\asr presets' folder, then unzip asr presets from any recent plugin zip and 'import all' presets.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
'delete' these 3 presets, manually delete all files from 'plugins\asr presets' folder, then unzip asr presets from any recent plugin zip and 'import all' presets.
@boroda...

Still not working. First off,my ASR Presets folder was under AppData not Plugins. Since it works there, I left it there.
Using the 'working' version of ASR I launched MB and deleted the three funky presets.
I closed and restarted MB  and using ASR I deleted all remaining presets and closed MB.
I checked the Presets folder and they were gone, and then copied them in from a recent zip.
Launched MB and ASR (older, working version) and imported the presets and ASR worked as it always has.
Closed MB, overwrote the working dll with the most recent dll, launched MB and as soon as I tried to apply a preset, MB locked up.
Closed MB, moved the presets folder to under Plugins and it still locked up.

So 5.2.7167 still not working for me. But know I'm wondering under what folder should the presets folder be? For the time being, I have it under the plugins folder. And 5.1.7154 is working as expected. Not so good with the latest version.

I appreciate you looking at this again. Let me know if you think of anything else that might be the cause.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
@phred, try this version:
I'm sorry to report that this is even worse than before. I just about always launch MB in Album View. With the new dll, MB hangs before the artwork even loads.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
and this?
Sadly no.

But I did notice something that may help in figuring out what's going on...

I selected the preset "Remove the track number followed by a dah or dot from Track title."
Clicked 'preview' and saw the the proposed changes were correct and clicked 'apply'. In the 'new tag value' column all the changes were made, but as soon as it was done, MB locked up. And the changes were not applied to the actual tags. The first thing I checked was the file properties to see if they were Read Only. They were not.

Here's a screenshot of when the plugin was finished applying the changes. Note that the 'apply' button is showing 'stop' and has not returned to 'apply' as is usually the case when the changes are completed.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9451
Some new information.

Since I run the portable edition, I created a new MB install, left everything as default, then installed the plugin and presets. Relaunched MB and the plugin worked just fine on the one test I did.

I then imported my settings file to MB, which I had exported from the install I had been using up until today. Launched MB and it hung immediately. Closed MB, overwrote the dll with the one that had been working, and MB didn't hang. And the plugin worked as expected.

My conclusion is that there's a conflict between the AT&RT dll and -something- in my settings. But I have no idea how to proceed from here with any troubleshooting.

I know there is at least one other user who is experiencing this issue, so perhaps Steven can jump in and offer some advice.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3840
  • MB Version: 3.6.8878 P
I was able to reproduce the MB freeze!

Still using 5.2.7214

I have an ASR preset that is auto-applied. Normally works fine.

If I use the tag editor and make changes to the tag that triggers the ASR, then use the arrows to move to the next track,

MB will lock up and I have to kill via Task Manager.

If I save and then move to the next track, no lock up.
MusicBee and my library - Making bee-utiful music together