Author Topic: Additional Tagging & Reporting Tools  (Read 970310 times)

boroda

  • Hero Member
  • *****
  • Posts: 4748
delete plugins\mb_tagtools.dll, rename backed up mb_tagtools.dll.bak to original mb_tagtools.dll name. or (if you deleted original file) redownload non-debug version from here:

http://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

unzip mb_tagtools.dll to 'plugins' folder and overwrite existing file.

Arkada

  • Newbie
  • *
  • Posts: 6
I downloaded the latest build but for some reason it will not initialize correctly, and I get these pop ups. Any ideas? It installed correctly on my other machine.

boroda

  • Hero Member
  • *****
  • Posts: 4748
1st exception can be easily fixed: close mb, then delete <appdata>\mb_tagtools.settings.xml file.

second error means that you have 2 (maybe custom or virtual, but maybe generic) tags with the tag names. plugin won't work in this situation. go to edit> prefs> tags(2) and click 'configure fields' button. find 2 tags with the same name and rename 1 of them.

Johan_A_M

  • Jr. Member
  • **
  • Posts: 117
delete plugins\mb_tagtools.dll, rename backed up mb_tagtools.dll.bak to original mb_tagtools.dll name. or (if you deleted original file) redownload non-debug version from here:

http://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

unzip mb_tagtools.dll to 'plugins' folder and overwrite existing file.

Hmm, strange, that is precisely what I'm doing. Still, no numbered msg boxes with that new debug version.

Arkada

  • Newbie
  • *
  • Posts: 6
1st exception can be easily fixed: close mb, then delete <appdata>\mb_tagtools.settings.xml file.

second error means that you have 2 (maybe custom or virtual, but maybe generic) tags with the tag names. plugin won't work in this situation. go to edit> prefs> tags(2) and click 'configure fields' button. find 2 tags with the same name and rename 1 of them.

Found and deleted the xml file, but can't find duplicates in the configuations menu. here is a snippet from the error log though

Adding Artist (displayed) / -1
Adding Artist / -2
Adding Artwork / Artwork
Adding BPM / BeatsPerMin
Adding Composer (displayed) / -3
Adding Composer / -4

I take it the negative numbers shouldn't be there?

boroda

  • Hero Member
  • *****
  • Posts: 4748
yes, negative values are normal. post here full log, which is mentioned in error message. there is must be at least 1 entry saying "Can't add...".

boroda

  • Hero Member
  • *****
  • Posts: 4748
delete plugins\mb_tagtools.dll, rename backed up mb_tagtools.dll.bak to original mb_tagtools.dll name. or (if you deleted original file) redownload non-debug version from here:

http://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

unzip mb_tagtools.dll to 'plugins' folder and overwrite existing file.

Hmm, strange, that is precisely what I'm doing. Still, no numbered msg boxes with that new debug version.

excuse me, hasn't been sleeping for 2 days. here is the right one:

http://www.mediafire.com/file/ufh99qf34u441n2/mb_TagTools_ASR_debug.zip/file

archive and .dll names are the same as the 1st time, but its different debug version.

Johan_A_M

  • Jr. Member
  • **
  • Posts: 117
delete plugins\mb_tagtools.dll, rename backed up mb_tagtools.dll.bak to original mb_tagtools.dll name. or (if you deleted original file) redownload non-debug version from here:

http://www.mediafire.com/file/h2t08o9562efboi/mb_TagTools_latest.zip/file

unzip mb_tagtools.dll to 'plugins' folder and overwrite existing file.

Hmm, strange, that is precisely what I'm doing. Still, no numbered msg boxes with that new debug version.


excuse me, hasn't been sleeping for 2 days. here is the right one:

http://www.mediafire.com/file/ufh99qf34u441n2/mb_TagTools_ASR_debug.zip/file

archive and .dll names are the same as the 1st time, but its different debug version.

Sorry but no matter what I do, I don't get the numbered boxes, only the freeze. Anyway, you should go to sleep!!  :)  :o

Arkada

  • Newbie
  • *
  • Posts: 6
yes, negative values are normal. post here full log, which is mentioned in error message. there is must be at least 1 entry saying "Can't add...".

Yeah, virtual26 - virtual32, which aren't visible in the config menu, and don't seem to be present at all in the machine I'm having trouble with. The machine that works has those virtual tags though

Edit: I fixed it. Despite having check for updates checked, I was two versions behind. I've since updated it and the plugin works fine. Thank you for the support!
Last Edit: October 02, 2019, 07:54:12 PM by Archada

Shepherd Jim

  • Jr. Member
  • **
  • Posts: 26
Hello All:  I have downloaded and installed/enabled the plugin "Additional Tagging & Reporting Tools". I find a lot of information (it comes with a "Read Me") about what the plugin can do. But, maybe it's me. I cannot figure out how to accomplish what I want to do -- I'm about 98% sure the plugin IS capable of the task.

My immediate problem: I have the Beatles' Abbey Road in MusciBee as downloaded MP3's, I have extensively modified the tracks' tags/metatdata. I have now ripped the Abbey Road CD into my Inbox as flac's. I am going to import the "flac album" into my Library and will retain the MP3 album. I want to copy the tags from the MP3 files to the incoming flac's.

How do I find instructions on how to use the plugin?

Thanks for all comments and assistance!
Jim in Maine
— old dog learning new tricks ....having a blast !!

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10718
If you need help with a plugin, you should post in the plugin's thread. I merged your post for you.

You're looking for the copy tags and paste tags command, which are easiest to use if you have the plugin configured to show up in the context menu. If not, it's in the Tools menu somewhere.

Although in this case you can get it done almost as easily with MusicBee's built in copy tags command (probably the more complete version), configured to a hot key.

MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

boroda

  • Hero Member
  • *****
  • Posts: 4748
just make sure that mp3 tracks and flac tracks of the album are sorted the same way, because 'paste tags' command wont search for appropriate track, it will use appropriate track sequence number in current view.

fjelsten

  • Jr. Member
  • **
  • Posts: 28
Hello

I am trying to get Episode date into my tags before the title on my podcasts so they will be sorted correctly on my Garmin watch.

"Episode date" as shown under podcasts is not available (why not?) so I want to use Date (which turns out to be added date and time: "24-10-2019 13:35").

So for the match of only the date part I have put in ^.{10} in the part that should read the date. I have kept the $1 that was in the Replace with field - my preset is based on "Combine tags '<Tag 1>', '<Tag 2>' placing between them <Custom text 1> and write result in '<Tag 3>'."

However when I preview the result I get:
$1 13:35 <content of the title field>

What am I doing wrong?


PWN3D_

  • Jr. Member
  • **
  • Posts: 20
Hello,

I decided to update my version of this plugin,from 4.xxx  (I don't remember honestly) version to the latest one.

I have a problem with musicbee getting slower than before and not responding program when I update tags normaly (without the use of the plugin)... Like updating the title of an album result in musicbee not responding for few seconds.

I also noticed that when I update tags from an album, as soon I as press apply, I can see all the tracks getting remove one by one, then replace with the updated tags and I guess this is what causing slow down.

If I dissable the plugin, everything works as intended, and this problem never happened with my previous version so I don't know what to do.